Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 651346 - dev-python/pygtkglext-1.1.0-r1 fails to compile: /usr/lib/gcc/x86_64-pc-linux-gnu/7.3.0/../../../../x86_64-pc-linux-gnu/bin/ld:.libs/_gdkgl.ver:2: syntax error in VERSION script
Summary: dev-python/pygtkglext-1.1.0-r1 fails to compile: /usr/lib/gcc/x86_64-pc-linux...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-24 09:55 UTC by Doppler
Modified: 2018-06-13 16:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (file_651346.txt,20.77 KB, text/plain)
2018-03-24 09:55 UTC, Doppler
Details
emerge --info (file_651346.txt,7.24 KB, text/plain)
2018-03-25 18:46 UTC, Doppler
Details
package list (file_651346.txt,3.87 KB, text/plain)
2018-06-13 16:40 UTC, Doppler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Doppler 2018-03-24 09:55:26 UTC
Created attachment 525210 [details]
build.log

Recently tried to get pygtkgltext and it failed to compile. The buildlog mentions updating to a new API and some syntax error in a VERSION script?
Comment 1 Tomáš Mózes 2018-03-25 08:21:47 UTC
Please attach your $(emerge --info).
Comment 2 Tomáš Mózes 2018-03-25 08:23:23 UTC
Can you try rebuilding the dependencies and then rebuild pygtkglext?
Comment 3 Doppler 2018-03-25 18:46:29 UTC
Created attachment 525434 [details]
emerge --info

Alright, emerge --info's here. Will report on the results of emerge -ae1 pygtkglext later.
Comment 4 Doppler 2018-03-28 20:40:10 UTC
Well, that didn't work.
Comment 5 Doppler 2018-06-07 07:41:30 UTC
(one -e @world later, still the same issue :( )
Comment 6 Doppler 2018-06-10 23:38:33 UTC
Hmm. Well. I just removed dozens of fonts from my world set + depcleaned them (not 100% sure which ones) and this compiles now. I really don't know what to make of this.
Comment 7 Doppler 2018-06-13 16:40:23 UTC
Created attachment 535802 [details]
package list

Well, I suspect one of those is the culprit, in case anyone runs into this bug report with a similar issue.