Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 6504 - xchat segfaulting when loading perlscripts due to
Summary: xchat segfaulting when loading perlscripts due to
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2002-08-15 04:26 UTC by Peter Salanki
Modified: 2003-02-04 19:42 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Peter Salanki 2002-08-15 04:26:17 UTC
xchat crasches while loading perl scripts, this occures with the standard
emerged perl and any versions of xchat (have tried manual compile aswell, same

Some gdb output:
GNU gdb 5.1.1
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...
(gdb) run 
Starting program: /usr/bin/xchat 
[New Thread 1024 (LWP 2557)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 2557)]
0x40073f1a in S_init_postdump_symbols () from /usr/lib/

I have tried to remerge perl without success
Comment 1 Spider (RETIRED) gentoo-dev 2002-08-15 17:26:24 UTC
try rebuilding xchat.. i'm quite stumped for other solutions...
Comment 2 Troy Dack 2002-08-15 19:37:36 UTC
I had a similar problem a while ago, not sure if it's related but ..

When xchat was built with  gnome  as one of the USE flags and I used xchat under
KDE it would segfault on loading perl plugins.

My only solution was to do:

USE="-gnome" emerge xchat

and xchat would work with perl plugins under KDE.

Stangely when built with USE="gnome" xchat worked fine under Gnome, but not
under  KDE.


Comment 3 Seemant Kulleen (RETIRED) gentoo-dev 2002-08-16 04:35:56 UTC
peter, that help?
Comment 4 Ryan Phillips (RETIRED) gentoo-dev 2002-08-26 16:07:07 UTC
disabled gnome support if use perl USE flag is set.