Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 650274 - media-gfx/freecad wrong version removed
Summary: media-gfx/freecad wrong version removed
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Michael Weber (RETIRED)
Depends on:
Reported: 2018-03-12 12:54 UTC by Gert Pellin
Modified: 2018-04-07 13:43 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Gert Pellin 2018-03-12 12:54:02 UTC
Freecad-0.16.6712 was removed in favour of the much older 0.17_pre.
As can be seen on github the 0.17 is a year older than the 0.16. also the 0.17 is not stable at all and constantly crashes while drawing for unhandled NaN errors. 

I tried to solve this bug myself but I can't manage to get the 0.16 version patched for the qt4 problem.
Comment 1 Larry the Git Cow gentoo-dev 2018-03-13 09:33:47 UTC
The bug has been closed via the following commit(s):

commit a9c5924be41e9457cdee147b28326b717e8fff40
Author:     Andreas Sturmlechner <>
AuthorDate: 2018-03-13 09:17:13 +0000
Commit:     Andreas Sturmlechner <>
CommitDate: 2018-03-13 09:33:24 +0000

    media-gfx/freecad: Re-add 0.16.6712
    It is actually more up-to-date than 0.17_pre.
    Package-Manager: Portage-2.3.24, Repoman-2.3.6

 media-gfx/freecad/Manifest                 |   1 +
 media-gfx/freecad/freecad-0.16.6712.ebuild | 132 +++++++++++++++++++++++++++++
 2 files changed, 133 insertions(+)
Comment 2 Andreas Sturmlechner gentoo-dev 2018-03-13 19:00:59 UTC
(In reply to gert from comment #0)
> I tried to solve this bug myself but I can't manage to get the 0.16 version
> patched for the qt4 problem.
FYI the qtwebkit-patch for 0.17_pre applied to 0.16 without any need for change.
Comment 3 Gert Pellin 2018-03-13 19:08:34 UTC
Thanks for the information. Very strange, that was the first thing I tried, with me the compiler gave a second error involving webkit. Will try it again tonight.
Comment 4 Andreas Sturmlechner gentoo-dev 2018-04-07 11:23:29 UTC
Well one thing is applying the patch which is what I replied to, that works, but I did not (can not) compile freecad myself. I need someone else to confirm build success - does 0.16 work for you now?
Comment 5 Gert Pellin 2018-04-07 13:43:39 UTC
Hi Andreas, thank you for coming back on it. In combination with bug #650596 that was pulled in 2 days ago, everything works fine again.