Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 648460 - dev-lang/perl-5.24.3-r1 stabilization
Summary: dev-lang/perl-5.24.3-r1 stabilization
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard: was: xlocale.h fix needs to be backpo...
Keywords: STABLEREQ
: 637432 639148 (view as bug list)
Depends on:
Blocks: glibc-2.26-stable
  Show dependency tree
 
Reported: 2018-02-21 23:09 UTC by Andreas K. Hüttel
Modified: 2018-04-21 09:34 UTC (History)
2 users (show)

See Also:
Package list:
dev-lang/perl-5.24.3-r1
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas K. Hüttel archtester gentoo-dev 2018-02-21 23:09:45 UTC
xlocale.h fix needs to be backported to 5.24, with *revbump* and stabilization.

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=59e5b94ccd20a044eaa752ca5077c7d6d2b065b4
Comment 1 Andreas K. Hüttel archtester gentoo-dev 2018-02-22 23:28:13 UTC
*** Bug 637432 has been marked as a duplicate of this bug. ***
Comment 2 Larry the Git Cow gentoo-dev 2018-02-22 23:48:22 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=32f2d135ae0be4622f332480c630b5d31134ef78

commit 32f2d135ae0be4622f332480c630b5d31134ef78
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2018-02-22 23:47:52 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2018-02-22 23:48:12 +0000

    dev-lang/perl: No pointless linking to libnsl, no including xlocale.h
    
    Bug: https://bugs.gentoo.org/648460
    Package-Manager: Portage-2.3.24, Repoman-2.3.6

 dev-lang/perl/files/perl-5.24-libnsl.patch |  13 +
 dev-lang/perl/perl-5.24.3-r1.ebuild        | 572 ++++++++++++++++++++++++++
 dev-lang/perl/perl-5.26.1-r2.ebuild        | 627 +++++++++++++++++++++++++++++
 3 files changed, 1212 insertions(+)}
Comment 3 Tim Harder gentoo-dev 2018-02-23 09:22:37 UTC
*** Bug 639148 has been marked as a duplicate of this bug. ***
Comment 4 Andreas K. Hüttel archtester gentoo-dev 2018-03-30 17:04:42 UTC
Please do, all arches.

This should be *very* unproblematic; we only add some minor fixes that make perl-5.24 safe for the future glibc-2.26 upgrade. 
(That, however, needs a rebuild via a revbump.)
Comment 5 Larry the Git Cow gentoo-dev 2018-03-30 19:08:10 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2ff16e8a08ebacdc1b38aff3b5d9036e1acdbd1e

commit 2ff16e8a08ebacdc1b38aff3b5d9036e1acdbd1e
Author:     Aaron Bauman <bman@gentoo.org>
AuthorDate: 2018-03-30 19:07:43 +0000
Commit:     Aaron Bauman <bman@gentoo.org>
CommitDate: 2018-03-30 19:08:00 +0000

    dev-lang/perl: amd64 stable
    
    Bug: https://bugs.gentoo.org/648460
    Package-Manager: Portage-2.3.26, Repoman-2.3.7

 dev-lang/perl/perl-5.24.3-r1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)}
Comment 6 Sergei Trofimovich (RETIRED) gentoo-dev 2018-03-30 20:21:22 UTC
ia64 stable
Comment 7 Larry the Git Cow gentoo-dev 2018-03-31 10:04:55 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=48c1d723d33932b547362812e228db59509c7fd5

commit 48c1d723d33932b547362812e228db59509c7fd5
Author:     Rolf Eike Beer <eike@sf-mail.de>
AuthorDate: 2018-03-31 08:31:22 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-03-31 10:04:42 +0000

    dev-lang/perl: stable 5.24.3-r1 for sparc
    
    Bug: https://bugs.gentoo.org/648460
    Package-Manager: Portage-2.3.24, Repoman-2.3.6
    RepoMan-Options: --include-arches="sparc"

 dev-lang/perl/perl-5.24.3-r1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)}
Comment 8 Tobias Klausmann (RETIRED) gentoo-dev 2018-03-31 17:54:00 UTC
Stable on alpha.
Comment 9 Matt Turner gentoo-dev 2018-04-01 04:21:15 UTC
ppc/ppc64 stable
Comment 10 Thomas Deutschmann (RETIRED) gentoo-dev 2018-04-05 18:31:10 UTC
x86 stable
Comment 11 Matt Turner gentoo-dev 2018-04-07 21:13:39 UTC
hppa stable
Comment 12 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-04-15 16:58:42 UTC
arm stable
Comment 13 Mart Raudsepp gentoo-dev 2018-04-18 08:05:06 UTC
arm64 stable
Comment 14 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-04-21 09:34:05 UTC
The rest have been done too.