Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 647974 - app-portage/grs triggers weird portage errors
Summary: app-portage/grs triggers weird portage errors
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal blocker (vote)
Assignee: Gentoo Release System project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-18 04:46 UTC by Steve Arnold
Modified: 2018-03-13 20:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
grs log up to cycle 2 (desktop-amd64-musl-hardened.log.2,90.94 KB, text/plain)
2018-02-18 04:46 UTC, Steve Arnold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Arnold gentoo-dev 2018-02-18 04:46:54 UTC
Created attachment 519912 [details]
grs log up to cycle 2

So far I've tried this and it only gets into cycle 2 on its own, and that's after fixing some emerge issues with qt4/qt5 and few circular dep issues (I made my own specs fork for that: https://github.com/sarnold/grs-specs).

The first error only seems to occur after emerge fails for any reason in cycle 2. Once it occurs grsrun won't run any more, but if I chroot/bind mount in the build tree I can run all the script commands by hand just fine.

Once it fails and hits error 1 it thinks the chroot is invalid:

Error 1:

">>> Regenerating /etc/ld.so.cache...
Failed to validate a sane '/dev'.
bash process substitution doesn't work; this may be an indication of a broken '/dev/fd'.
EXIT CODE: 1
SENDING SIGTERM: 6229"

If I comment out the above, it fails with the next (weird) error; I say "weird" because A) /dev/fd is not insane (since it works outside of when run by grs) and B) it's a perfectly valid symlink that points to the musl hardened profile.

Error 2:

">>> Regenerating /etc/ld.so.cache...


!!! /etc/portage/make.profile is not a symlink and will probably prevent most merges.
!!! It should point into a profile within /usr/portage/profiles/
!!! (You can safely ignore this message when syncing. It's harmless.)


!!! Your current profile is invalid. If you have just changed your profile
!!! configuration, you should revert back to the previous configuration.
!!! Allowed actions are limited to --help, --info, --search, --sync, and
!!! --version.
EXIT CODE: 1
SENDING SIGTERM: 25370"
Comment 1 Steve Arnold gentoo-dev 2018-02-18 04:52:11 UTC
This was tried on 2 different Gentoo installs (one AMD FX and one Intel CoreI5) and one VM running bluedragon.  Which set of system info should I post?  the attached log is from the Intel box; note these boxes build everything from Gentoo to Yocto to Lede and Android builds, all build just fine.  I need some pointers to debug this further...

Portage 2.3.19 (python 2.7.14-final-0, default/linux/amd64/17.0/hardened, gcc-7.2.0, glibc-2.25-r10, 4.15.2-gentoo x86_64)
=================================================================
System uname: Linux-4.15.2-gentoo-x86_64-Intel-R-_Core-TM-_i5_CPU_M_520_@_2.40GHz-with-gentoo-2.4.1
KiB Mem:     5959920 total,   1415576 free
KiB Swap:   12572668 total,  12571888 free
Timestamp of repository gentoo: Sat, 10 Feb 2018 01:00:01 +0000
Head commit of repository gentoo: b3a202cfca62bd932673628073b50cf51ce9af0b
Head commit of repository arm_support: e4e01d94f2f87d89cfb0eef6e817a918d2ef0cef

Head commit of repository nerdboy: d565a434a95a01c3733753002fb594bd56b2d6bd

sh bash 4.4_p12-r1
ld GNU gold (Gentoo 2.29.1 p3 2.29.1) 1.14
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
ccache version 3.3.4 [enabled]
app-shells/bash:          4.4_p12-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.26.1-r1::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.4.6-r1::gentoo, 3.5.4-r1::gentoo, 3.6.4::gentoo
dev-util/ccache:          3.3.4-r1::gentoo
dev-util/cmake:           3.10.1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.12::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15.1-r1::gentoo
sys-devel/binutils:       2.26.1::gentoo, 2.27::gentoo, 2.28-r2::nerdboy, 2.29.1-r1::gentoo, 9999::nerdboy
sys-devel/gcc:            4.9.3::nerdboy, 5.3.0::gentoo, 5.4.0-r3::gentoo, 6.3.0::gentoo, 6.4.0::ada, 7.2.0-r1::gentoo
sys-devel/gcc-config:     1.9.1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.14::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r10::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    eclass-overrides: nerdboy
    sync-rsync-extra-opts: 

ada
    location: /var/lib/layman/ada
    sync-type: laymansync
    sync-uri: git://github.com/sarnold/ada-overlay.git
    masters: gentoo
    priority: 50

ago
    location: /var/lib/layman/ago
    sync-type: laymansync
    sync-uri: https://anongit.gentoo.org/git/dev/ago.git
    masters: gentoo
    priority: 50

arduino
    location: /var/lib/layman/arduino
    sync-type: laymansync
    sync-uri: git://github.com/sarnold/arduino-overlay.git
    masters: gentoo
    priority: 50

arm_support
    location: /usr/local/arm
    sync-type: git
    sync-uri: https://github.com/sarnold/arm.git
    masters: gentoo
    priority: 50

mozilla
    location: /var/lib/layman/mozilla
    sync-type: laymansync
    sync-uri: git://anongit.gentoo.org/proj/mozilla.git
    masters: gentoo
    priority: 50

nerdboy
    location: /usr/local/portage
    sync-type: git
    sync-uri: https://github.com/sarnold/portage-overlay.git
    masters: gentoo
    priority: 50

qwin-overlay
    location: /var/lib/layman/qwin-overlay
    sync-type: laymansync
    sync-uri: git://github.com/Flex1911/qwin-overlay.git
    masters: gentoo
    priority: 50

tlp
    location: /var/lib/layman/tlp
    sync-type: laymansync
    sync-uri: git://github.com/dywisor/tlp-portage.git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA @GPL-COMPATIBLE @OSI-APPROVED @EULA dlj-1.1 skype-eula googleearth AdobeFlash-10.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mtune=westmere -O2 -pipe -flto -ftree-vectorize -ftree-loop-distribution -fvect-cost-model=cheap -floop-interchange -floop-strip-mine -floop-block"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/grs/systems.conf /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -mtune=westmere -O2 -pipe -flto -ftree-vectorize -ftree-loop-distribution -fvect-cost-model=cheap -floop-interchange -floop-strip-mine -floop-block"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news nostrip parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-march=core2 -mtune=westmere -O2 -pipe -flto -ftree-vectorize -ftree-loop-distribution -fvect-cost-model=cheap -floop-interchange -floop-strip-mine -floop-block -fuse-linker-plugin"
LINGUAS="en_US en"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_BZIP2_COMMAND="/bin/bzip2"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 amr apache2 apng aspell avahi bluetooth bzip2 bzlib cairo caps cdda cdr consolekit crypt cups curl cxx dbus diff djvu dnotify dts dvd eds enchant exif expat fam firefox3 flac fortran gd gif git glade glamor gmp gnome-keyring gnome-online-accounts gnutls gstreamer gtk gtk3 hardened iconv imagemagick inotify introspection ipv6 jpeg json lcms ldap libav libnotify libsecret lua lz4 mng mp3 multilib nautilus ncurses networking networkmanager nfs nls nptl nptlonly nsplugin ogg opengl openmp orc pam pango pax_kernel pcre pda pdf pic pie pkcs11 png policykit pulseaudio python qt5 readline rtc samba sasl sdl seamonkey seccomp sip slp smartcard snmp spell ssh ssl ssp startup-notification svg system-cairo system-harfbuzz system-icu system-jpeg system-libvpx system-sqlite tcl tcpd text theora threads thunar tiff tk tracker truetype udev udisks unicode upower usb v4l vala vdpau vorbis webp wheel wifi x264 xa xattr xcb xkb xml xtpax xvmc zeroconf zlib" ABI_X86="64 32" ALSA_CARDS="hda-intel usb-audio" APACHE2_MODULES="actions alias authn_core authz_core cgid access_compat auth_digest auth_basic authn_alias authn_anon cache_disk cern_meta authn_dbm authn_default authn_file authz_dbm authz_default cache authz_groupfile authz_host authz_owner authz_user unixd socache_shmcb autoindex dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_connect proxy_http rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2 agfa_cl20 canon casio_qv clicksmart310 digigr8 digita dimagev directory fuji hp215 iclick jamcam kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 spca50x" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3" CURL_SSL="nss" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-32 efi-64 pc" INPUT_DEVICES="keyboard mouse joystick evdev synaptics" KERNEL="linux" L10N="en-US en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-minimizer wiki-publisher" LLVM_TARGETS="AMDGPU BPF NVPTX X86 AArch64 ARM Hexagon MSP430 Mips Lanai RISCV PowerPC Sparc SystemZ XCore" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" QEMU_SOFTMMU_TARGETS="arm i386 microblaze mips mips64 mips64el mipsel mipsn32 mipsn32el ppc ppc64 x86_64" QEMU_USER_TARGETS="arm i386 microblaze mips mips64 mips64el mipsel ppc ppc64 x86_64" RUBY_TARGETS="ruby25 ruby24 ruby23" SANE_BACKENDS="net" USERLAND="GNU" VIDEO_CARDS="intel i915 i965 v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Anthony Basile gentoo-dev 2018-02-20 20:25:24 UTC
1. I think the fd error is caused by the portage problems releng has been hitting ever since portage-2.3.19-r1.  This causes issues with all ||() constructions which are prevalent in virtuals and really messes up /dev when virtual/dev-manager tries to pull in sys-fs/static-dev.  But I can't be sure without actually going through this myself.

On all my releng machines, i've backed up to portage-2.3.13-r1 until zac addresses all those problems.  I think the fix is coming with 2.3.24-r1 but it also pulls in more deps, so backing up was the solution for me.

2. The other cycle 2 error are due to the fact that I haven't updated the world.conf file and you're getting the same kind of circular dependencies that you get on any gentoo system.
Comment 3 Steve Arnold gentoo-dev 2018-03-13 20:49:18 UTC
Okay, as far as 1) do you mean on the host side?  Because inside the grs chroot portage is already set to sys-apps/portage-2.3.13-r1::gentoo.  And I don't understand how 2) relates to the profile error.