Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 647782 - =net-vpn/wireguard-0.0.20180202 with >=sys-kernel/gentoo-sources:4.15.0 - src_prepare(): ACCESS DENIED: unlink: /usr/src/linux-4.15.3-gentoo/null.dwo
Summary: =net-vpn/wireguard-0.0.20180202 with >=sys-kernel/gentoo-sources:4.15.0 - src...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jason A. Donenfeld
URL:
Whiteboard:
Keywords:
Depends on: 653286
Blocks:
  Show dependency tree
 
Reported: 2018-02-15 21:50 UTC by Nelo-T. Wallus (ntnn)
Modified: 2019-03-15 02:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info.txt,4.77 KB, text/plain)
2018-02-15 21:50 UTC, Nelo-T. Wallus (ntnn)
Details
build.log (wireguard-0.0.20180202:20180215-201407.log,7.29 KB, text/plain)
2018-02-15 21:51 UTC, Nelo-T. Wallus (ntnn)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nelo-T. Wallus (ntnn) 2018-02-15 21:50:47 UTC
Created attachment 519686 [details]
emerge --info

Issue is reproducible. Remerge of kernel gentoo-sources did not change the issue.
Compilation works <4.15.0.
Comment 1 Nelo-T. Wallus (ntnn) 2018-02-15 21:51:22 UTC
Created attachment 519688 [details]
build.log
Comment 2 Georgy Yakovlev gentoo-dev 2018-04-16 05:32:05 UTC
It's failing because of CONFIG_DEBUG_INFO_SPLIT in the kernel config. try disabling that.

I'm currently working on linux-mod.eclass and can look at the issue a bit deeper, seems it needs some patching or sandbox massage.
Comment 3 Georgy Yakovlev gentoo-dev 2018-04-16 05:48:13 UTC
this bug should depend on https://bugs.gentoo.org/653286