Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 64739 - mac-fdisk is broken on ppc64 2004.2 beta livecd
Summary: mac-fdisk is broken on ppc64 2004.2 beta livecd
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: PPC64 All
: High major (vote)
Assignee: ppc64 architecture team
Depends on: 61493
  Show dependency tree
Reported: 2004-09-20 04:06 UTC by Joshua Root
Modified: 2004-10-26 20:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Joshua Root 2004-09-20 04:06:30 UTC
The summary says it all really. Any attempt to use mac-fdisk results in this error message: 
"(null): Size of partion map entry (944) is not equal to block size (512)".

The following message indicates that emerging a newer mac-fdisk solves the problem:

However, this does not help people who don't have an existing Gentoo installation, so it should be
fixed on the livecd.
Comment 1 Tom Gall (RETIRED) gentoo-dev 2004-09-20 05:59:48 UTC
Hi Joshua,

Did you by chance just update your firmware on you g5 ? what kind of g5 do you have? (cat /proc/cpuinfo) 

There was another report just like this a couple of days ago.  The exact same thing was happening and the fix was they reset their pram, which strikes me as amazingly odd. I haven't been able to recreate this problem locally. 

To reset the PRAM you'll need five hands. ; )

   1. Simultaneously press the Command, Option, P, and R keys at startup.
   2. (Keep your hands on the keys until the third reboot has started.)
   3. The machine will reboot the first time and chime.
   4. The machine will reboot the second time and chime.
   5. The machine will start to reboot the third time and chime.
   6. Let go of the keys and allow it to finish booting. 
Comment 2 Joshua Root 2004-09-20 07:34:33 UTC
OK, I zapped the PRAM but it hasn't helped. Same error as before.

My machine is a dual 2.5 GHz Power Mac G5, aka PowerMac7,3 with 2x PPC970FX. I haven't ever updated the firmware; AFAIK firmware updates have only been released for rev A G5s.
Comment 3 Joshua Root 2004-09-30 23:52:58 UTC
I've tried the new beta 6 CD, and it doesn't fix the mac-fdisk error. (Actually it's worse than beta 5
for me, because the whole system locks up after a while...)
Comment 4 Joshua Root 2004-10-20 22:31:03 UTC
Fixed in 2004.3 beta 1.
Comment 5 Tom Gall (RETIRED) gentoo-dev 2004-10-26 20:06:46 UTC
no ill reports thus far. closing. Thanks!