Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 646604 - sys-fs/zfs-kmod-0.7.5 and sys-kernel/spl-0.7.5 fail to build on 4.15+ kernel.
Summary: sys-fs/zfs-kmod-0.7.5 and sys-kernel/spl-0.7.5 fail to build on 4.15+ kernel.
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Richard Yao
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-04 19:17 UTC by Rob Tongue
Modified: 2018-02-05 02:14 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rob Tongue 2018-02-04 19:17:12 UTC
I looked through the ebuilds for sys-fs/zfs-kmod-0.7.5, and it appears that there is a hard dependency on kernel version 4.14 or less being installed.  This causes building of zfs-kmod to fail with a warning stating that dependency.

Reproducible: Always

Steps to Reproduce:
Compile sys-fs/zfs-kmod-0.7.5 or sys-kernel/spl-0.7.5 against kernel sources version 4.15.x. 
Actual Results:  
zfs-kmod fails to build with a warning about kernel version 

Expected Results:  
sys-fs/zfs-kmod and sys-kernel/spl should build successfully against the 4.15.x kernel.

 * Messages for package sys-kernel/spl-0.7.5:

 * ERROR: sys-kernel/spl-0.7.5::gentoo failed (setup phase):
 *   Linux 4.14 is the latest supported version.
 * 
 * Call stack:
 *          ebuild.sh, line 124:  Called pkg_setup
 *   spl-0.7.5.ebuild, line  60:  Called die
 * The specific snippet of code:
 *   	[ ${PV} != "9999" ] && \
 *   		{ kernel_is le 4 14 || die "Linux 4.14 is the latest supported version."; }
Comment 1 Jonathan Vasquez (RETIRED) gentoo-dev 2018-02-05 02:14:21 UTC
Hey Rob,

There is a check in the ebuild that prevents building ZFS 0.7.5 on versions above 4.14 because kernel versions newer than 4.14 are not supported by ZFS.

https://github.com/zfsonlinux/zfs/releases/tag/zfs-0.7.5

"Supported Kernels

    Compatible with 2.6.32 - 4.14 Linux kernels.
"

You'll need to wait till upstream implements 4.15 support.

- Jonathan