Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 646102 - x11-terms/xfce4-terminal-0.8.6: failed to execute child
Summary: x11-terms/xfce4-terminal-0.8.6: failed to execute child
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: XFCE Team
Depends on:
Reported: 2018-01-30 07:41 UTC by Miroslav Šulc
Modified: 2018-02-02 08:45 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

build-0.8.6.log (build.log,70.45 KB, text/x-log)
2018-01-30 08:22 UTC, Miroslav Šulc
build-0.6.3.log (build.log,57.20 KB, text/x-log)
2018-01-30 08:24 UTC, Miroslav Šulc

Note You need to log in before you can comment on or make changes to this bug.
Description Miroslav Šulc gentoo-dev 2018-01-30 07:41:19 UTC
i'm running xfce and when i try to open xfce4-terminal, i get an error window stating this:

Failed to execute child

Failed to execute child process "" (No such file or directory)

i tried to re-emerge the terminal but that did not help. i have the same problem with version the only version that does not trigger this error is 0.6.3. i am running ~arm64.

# emerge --info

Portage 2.3.20 (python 3.4.6-final-0, default/linux/amd64/17.0/hardened, gcc-7.3.0, glibc-2.26-r5, 4.14.14-gentoo x86_64)
System uname: Linux-4.14.14-gentoo-x86_64-Intel-R-_Core-TM-_i7-3770K_CPU_@_3.50GHz-with-gentoo-2.4.1
KiB Mem:    32872216 total,  22918580 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Tue, 30 Jan 2018 07:00:01 +0000
Head commit of repository gentoo: fc29bf45412c227e5b0995472132913289d0f8f2
sh bash 4.4_p12-r1
ld GNU ld (Gentoo 2.29.1 p2) 2.29.1
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.4_p12-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.26.1-r1::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.4.6-r1::gentoo, 3.5.4-r1::gentoo, 3.6.4::gentoo
dev-util/cmake:           3.10.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.12::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.15.1-r1::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0::gentoo, 7.2.0-r1::gentoo, 7.3.0::gentoo
sys-devel/gcc-config:     1.9.1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.14::gentoo (virtual/os-headers)
sys-libs/glibc:           2.26-r5::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000
    sync-rsync-vcs-ignore: true

    location: /usr/src/fordfrog.git
    masters: gentoo
    priority: 0

    location: /usr/local/portage
    masters: gentoo

    location: /var/lib/layman/audio-overlay
    masters: gentoo
    priority: 50

    location: /var/lib/layman/proaudio
    masters: gentoo
    priority: 50

    location: /var/lib/layman/qt
    masters: gentoo
    priority: 50

    location: /var/lib/layman/stuff
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.3/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
EMERGE_DEFAULT_OPTS="--misspell-suggestions n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="cs cs_CZ en en_US en_UK"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac acl alsa amd64 bzip2 cdda cddb cdr colord crypt cups cxx d3d9 dbus dia dssi dvb dvd exif ffmpeg flac gegl gif gphoto2 gsm gtk gtk3 hardened http2 iconv icu id3tag ipv6 jack jacksession jpeg ladspa lastfm latex lcms libass libnotify libproxy lilypond lv2 mad modplug mp3 mpeg mtp multilib musepack ncurses nls nptl ocr ogg openexr opengl openmp opus pam pcre pdf pie png pulseaudio raw readline samba scanner seccomp sf2 sndfile soundio speex spell ssl ssp startup-notification svg taglib theora tiff timidity tk tray truetype udev unicode usb vaapi vdpau visio vorbis vpx vst wavpack webp wmf x264 x265 xattr xinerama xtpax xv xvid zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="alias auth_basic authn_core authn_file authz_core authz_host authz_user deflate dir expires filter headers http2 include info log_config mime mime_magic negotiation proxy proxy_ajp rewrite setenvif socache_shmcb status unixd vhost_alias" APACHE2_MPMS="event" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx f16c mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics wacom" KERNEL="linux" L10N="cs cs-CZ en en-US en-UK" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="*" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" RUBY_TARGETS="ruby21 ruby22 ruby23 ruby24 ruby25" SANE_BACKENDS="genesys" USERLAND="GNU" VIDEO_CARDS="intel i915 i965 radeon radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2018-01-30 08:04:45 UTC
Please attach a build log for the newest version, and preferably for the working one as well. Also, does 'getent passwd $(id -u)' print a valid shell in the last field? Also your x11-libs/vte version and flags.
Comment 2 Miroslav Šulc gentoo-dev 2018-01-30 08:20:33 UTC
here is some of the info you requested. i will attach the build logs once i rebuild the packages.

# getenv passwd $(id -u)


# equery list vte


# equery uses vte

Comment 3 Miroslav Šulc gentoo-dev 2018-01-30 08:22:40 UTC
Created attachment 517098 [details]

build log for version 0.8.6
Comment 4 Miroslav Šulc gentoo-dev 2018-01-30 08:24:22 UTC
Created attachment 517102 [details]

build log for version 0.6.3
Comment 5 Miroslav Šulc gentoo-dev 2018-02-01 08:21:59 UTC
i forgot to mention that the terminal window opens, but the cursor is stucked at left top corner and i am not able (i tried ctrl+c) to get the prompt, it even does not start to load my .bashrc. aterm, uterm, uxterm work fine but these are pretty limitted for my needs.
Comment 6 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2018-02-01 08:52:50 UTC
Er, I am pretty convinced a wrote a follow-up comment but I don't see it here...

Please open 'preferences' and see if you have a non-standard command set.
Comment 7 Miroslav Šulc gentoo-dev 2018-02-01 17:39:45 UTC
this is the difference in the files produced with these steps:

1) emerge xfce4-terminal-0.8.6
2) goto ~/.config/xfce4/Terminal
3) rename file accels.scm to accels.scm.old
4) start xfce4-terminal (it should start without issues)
5) run diff on the newly create file and the old one

the result in my case is here:

$ diff accels.scm.old accels.scm
< ; (gtk_accel_path "<Actions>/terminal-window/goto-tab-10" "")
< ; (gtk_accel_path "<Actions>/terminal-window/goto-tab-13" "")
< ; (gtk_accel_path "<Actions>/terminal-window/goto-tab-12" "")
< ; (gtk_accel_path "<Actions>/terminal-window/goto-tab-11" "")
> (gtk_accel_path "<Actions>/terminal-window/toggle-menubar" "F10")
Comment 8 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2018-02-01 18:28:31 UTC
Are you saying that old accelerator file is causing this?
Comment 9 Miroslav Šulc gentoo-dev 2018-02-02 08:45:57 UTC
it might be just a coincidence as i tried to switch back to the old one and terminal still starts up without issues. maybe it was fixed by some update or rebuild in gentoo.