Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 645470 - x11-themes/qtcurve-1.9.0_rc1-r1 : [TEST] 4/12 Test #4: test-printf ***Exception: Child aborted
Summary: x11-themes/qtcurve-1.9.0_rc1-r1 : [TEST] 4/12 Test #4: test-printf ***Except...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords: TESTFAILURE
: 668868 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-01-23 18:09 UTC by Toralf Förster
Modified: 2019-03-11 07:23 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.14 KB, text/plain)
2018-01-23 18:09 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,180.77 KB, text/plain)
2018-01-23 18:09 UTC, Toralf Förster
Details
environment (environment,150.81 KB, text/plain)
2018-01-23 18:09 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,17.03 KB, application/x-bzip)
2018-01-23 18:09 UTC, Toralf Förster
Details
LastTest.log (LastTest.log,7.50 KB, text/plain)
2018-01-23 18:09 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,5.35 KB, application/x-bzip)
2018-01-23 18:09 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,43.74 KB, application/x-bzip)
2018-01-23 18:09 UTC, Toralf Förster
Details
tests.tbz2 (tests.tbz2,1.10 KB, application/x-bzip)
2018-01-23 18:09 UTC, Toralf Förster
Details
x11-themes:qtcurve-1.9.0_rc1-r1:20180122-230925.log (x11-themes:qtcurve-1.9.0_rc1-r1:20180122-230925.log,209.50 KB, text/plain)
2018-01-23 18:09 UTC, Toralf Förster
Details
build.log x86 (build.log,143.84 KB, text/plain)
2018-06-10 14:55 UTC, Thomas Deutschmann
Details
build.log (qtcurve-1.9.0, ppc) (qtcurve-1.9.0:20181106-074739.log,142.30 KB, text/plain)
2018-11-06 08:10 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-01-23 18:09:30 UTC
 3/12 Test  #3: test-strmap ......................   Passed    0.25 sec
      Start  4: test-printf
 4/12 Test  #4: test-printf ......................***Exception: Child aborted  0.01 sec
      Start  5: test-strlist
 5/12 Test  #5: test-strlist .....................   Passed    0.01 sec
      Start  6: test-default-arg

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-desktop-gnome_libressl-test_20180117-214426

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python3.6 (fallback)
  [3]   python2.7 (fallback)

java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.6.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv x11-themes/qtcurve
[ebuild  N    ] x11-themes/qtcurve-1.9.0_rc1-r1  USE="X gtk nls qt5 -debug -plasma -qt4 {-test}"
Comment 1 Toralf Förster gentoo-dev 2018-01-23 18:09:33 UTC
Created attachment 516076 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-01-23 18:09:36 UTC
Created attachment 516078 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2018-01-23 18:09:40 UTC
Created attachment 516080 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2018-01-23 18:09:43 UTC
Created attachment 516082 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2018-01-23 18:09:46 UTC
Created attachment 516084 [details]
LastTest.log
Comment 6 Toralf Förster gentoo-dev 2018-01-23 18:09:48 UTC
Created attachment 516086 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2018-01-23 18:09:52 UTC
Created attachment 516088 [details]
temp.tbz2
Comment 8 Toralf Förster gentoo-dev 2018-01-23 18:09:55 UTC
Created attachment 516090 [details]
tests.tbz2
Comment 9 Toralf Förster gentoo-dev 2018-01-23 18:09:58 UTC
Created attachment 516092 [details]
x11-themes:qtcurve-1.9.0_rc1-r1:20180122-230925.log
Comment 10 Thomas Deutschmann gentoo-dev Security 2018-06-10 14:55:30 UTC
Created attachment 535550 [details]
build.log x86

On x86 I am getting two exceptions:


The following tests FAILED:
          4 - test-printf (OTHER_FAULT)
          7 - test-color-str (OTHER_FAULT)
Comment 11 Thomas Deutschmann gentoo-dev Security 2018-06-10 14:56:22 UTC
4/12 Testing: test-printf
4/12 Test: test-printf
Command: "/var/tmp/portage/x11-themes/qtcurve-1.9.0_rc1-r2/work/qtcurve-1.9.0_rc1_build/test/test-printf"
Directory: /var/tmp/portage/x11-themes/qtcurve-1.9.0_rc1-r2/work/qtcurve-1.9.0_rc1_build/test
"test-printf" start time: Jun 10 16:13 CEST
Output:
----------------------------------------------------------
test-printf: /var/tmp/portage/x11-themes/qtcurve-1.9.0_rc1-r2/work/qtcurve-1.9.0-rc1/test/test-printf.cpp:75: int main(): Assertion `buff8.get() != old_p8' failed.
<end of output>
Test time =   0.15 sec
----------------------------------------------------------
Test Failed.
"test-printf" end time: Jun 10 16:13 CEST
"test-printf" time elapsed: 00:00:00
----------------------------------------------------------




7/12 Testing: test-color-str
7/12 Test: test-color-str
Command: "/var/tmp/portage/x11-themes/qtcurve-1.9.0_rc1-r2/work/qtcurve-1.9.0_rc1_build/test/test-color-str"
Directory: /var/tmp/portage/x11-themes/qtcurve-1.9.0_rc1-r2/work/qtcurve-1.9.0_rc1_build/test
"test-color-str" start time: Jun 10 16:13 CEST
Output:
----------------------------------------------------------
test-color-str: /var/tmp/portage/x11-themes/qtcurve-1.9.0_rc1-r2/work/qtcurve-1.9.0-rc1/test/test-color-str.cpp:38: void
 test_short(): Assertion `color.blue == b / 15.0' failed.
<end of output>
Test time =   0.15 sec
----------------------------------------------------------
Test Failed.
"test-color-str" end time: Jun 10 16:13 CEST
"test-color-str" time elapsed: 00:00:00
--------------------------------------
Comment 12 Andreas Sturmlechner gentoo-dev 2018-10-17 18:01:02 UTC
*** Bug 668868 has been marked as a duplicate of this bug. ***
Comment 13 ernsteiswuerfel 2018-11-06 08:10:51 UTC
Created attachment 554258 [details]
build.log (qtcurve-1.9.0, ppc)

Same testfailure on ppc on qtcurve-1.9.0_rc1-r1 and qtcurve-1.9.0:

10/12 Test  #4: test-printf ......................***Exception: Other  0.34 sec
Comment 14 Larry the Git Cow gentoo-dev 2018-11-18 21:05:12 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=efa19ec2bfb692ffbf9bd39444b9c1b738627d75

commit efa19ec2bfb692ffbf9bd39444b9c1b738627d75
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-11-18 21:03:36 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-11-18 21:04:25 +0000

    x11-themes/qtcurve: Some tests are permanently broken, restrict
    
    Bug: https://bugs.gentoo.org/645470
    Package-Manager: Portage-2.3.51, Repoman-2.3.12
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 x11-themes/qtcurve/qtcurve-1.9.0.ebuild | 2 ++
 x11-themes/qtcurve/qtcurve-9999.ebuild  | 6 ++----
 2 files changed, 4 insertions(+), 4 deletions(-)