Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 645392 - net-libs/kdav2-0.1.0 : /.../davjob.cpp:58:18: error: invalid use of incomplete type class QDebug
Summary: net-libs/kdav2-0.1.0 : /.../davjob.cpp:58:18: error: invalid use of incomplet...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qt-5.11
  Show dependency tree
 
Reported: 2018-01-22 19:03 UTC by Toralf Förster
Modified: 2018-10-11 13:34 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.11 KB, text/plain)
2018-01-22 19:03 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,173.38 KB, text/plain)
2018-01-22 19:03 UTC, Toralf Förster
Details
environment (environment,147.84 KB, text/plain)
2018-01-22 19:03 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,16.90 KB, application/x-bzip)
2018-01-22 19:03 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,5.73 KB, application/x-bzip)
2018-01-22 19:03 UTC, Toralf Förster
Details
net-libs:kdav2-0.1.0:20180122-134237.log (net-libs:kdav2-0.1.0:20180122-134237.log,98.74 KB, text/plain)
2018-01-22 19:03 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,38.62 KB, application/x-bzip)
2018-01-22 19:03 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-01-22 19:03:29 UTC
/var/tmp/portage/net-libs/kdav2-0.1.0/work/kdav2-0.1.0/src/common/davjob.cpp: In lambda function:
/var/tmp/portage/net-libs/kdav2-0.1.0/work/kdav2-0.1.0/src/common/davjob.cpp:58:18: error: invalid use of incomplete type ‘class QDebug’
         qWarning() << "Error " << error << reply->errorString();
                  ^
In file included from /usr/include/qt5/QtCore/qglobal.h:1154:0,

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-desktop-gnome_libressl-test_20180117-214426

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python3.6 (fallback)
  [3]   python2.7 (fallback)

java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.6.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv net-libs/kdav2
Comment 1 Toralf Förster gentoo-dev 2018-01-22 19:03:32 UTC
Created attachment 515944 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-01-22 19:03:36 UTC
Created attachment 515946 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2018-01-22 19:03:39 UTC
Created attachment 515948 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2018-01-22 19:03:42 UTC
Created attachment 515950 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2018-01-22 19:03:46 UTC
Created attachment 515952 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2018-01-22 19:03:50 UTC
Created attachment 515954 [details]
net-libs:kdav2-0.1.0:20180122-134237.log
Comment 7 Toralf Förster gentoo-dev 2018-01-22 19:03:53 UTC
Created attachment 515956 [details]
temp.tbz2
Comment 8 Andreas Sturmlechner gentoo-dev 2018-02-01 01:32:38 UTC
Hmm, not reproducible here with gcc-7.3.0...
Comment 9 Toralf Förster gentoo-dev 2018-02-06 19:54:01 UTC
appeared here again at 17.0-desktop-gnome-systemd_libressl_20180204-221237

(gcc-7.3.0)
Comment 10 Michael Palimaka (kensington) gentoo-dev 2018-02-11 03:33:50 UTC
I can't reproduce either, but I see no direct QDebug include so I guess it's somehow not being provided transitively in this tinderbox image.
Comment 11 Larry the Git Cow gentoo-dev 2018-10-11 13:34:36 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=497e7517af05660fd8a1609134849d81fe097ea3

commit 497e7517af05660fd8a1609134849d81fe097ea3
Author:     Michael Palimaka <kensington@gentoo.org>
AuthorDate: 2018-10-11 13:33:51 +0000
Commit:     Michael Palimaka <kensington@gentoo.org>
CommitDate: 2018-10-11 13:34:24 +0000

    net-libs/kdav2: version bump 0.2.0
    
    Closes: https://bugs.gentoo.org/645392
    Signed-off-by: Michael Palimaka <kensington@gentoo.org>
    Package-Manager: Portage-2.3.49, Repoman-2.3.11

 net-libs/kdav2/Manifest                        |  1 +
 net-libs/kdav2/files/kdav2-0.2.0-qt-5.11.patch | 13 +++++++++++++
 net-libs/kdav2/kdav2-0.2.0.ebuild              | 25 +++++++++++++++++++++++++
 3 files changed, 39 insertions(+)