Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 644718 - x11-misc/sddm-0.17.0-r1 SwitchToGreeter error
Summary: x11-misc/sddm-0.17.0-r1 SwitchToGreeter error
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Gentoo KDE team
URL: https://github.com/sddm/sddm/issues/824
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: 649888
  Show dependency tree
 
Reported: 2018-01-15 23:10 UTC by Petr Morávek
Modified: 2018-06-03 09:47 UTC (History)
6 users (show)

See Also:
Package list:
x11-misc/sddm-0.17.0-r2
Runtime testing required: ---
stable-bot: sanity-check+


Attachments
sddm-0.17.0-switchToGreeter.patch (sddm-0.17.0-switchToGreeter.patch,1.84 KB, patch)
2018-03-14 01:27 UTC, Alexander Miller
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Morávek 2018-01-15 23:10:00 UTC
I am unable to "switch user" from Plasma session after upgrading to sddm 0.17 - selecting "new session" displays lock screen for current session instead of displaying the greeter and starting a new session.

It took a bit of digging, but it seems that this is a regression introduced by sddm 0.17 - downgrading to 0.15 solves the problem.

I've tracked the problem to the following dbus call:
$ dbus-send --print-reply --system --dest=org.freedesktop.DisplayManager /org/freedesktop/DisplayManager/Seat0 org.freedesktop.DisplayManager.Seat.SwitchToGreeter

On sddm 0.15 I get the following output (plus successful switch to a new session):
method return time=1516056773.188761 sender=:1.561 -> destination=:1.583 serial=21 reply_serial=2

On sddm 0.17 I get the following error output:
Error org.freedesktop.DBus.Error.UnknownObject: No such object path '/org/freedesktop/DisplayManager/Seat0'


$ emerge --info 
Portage 2.3.13 (python 2.7.14-final-0, default/linux/amd64/17.0/desktop/plasma, gcc-6.4.0, glibc-2.25-r9, 4.9.75-gentoo x86_64)
=================================================================
System uname: Linux-4.9.75-gentoo-x86_64-Intel-R-_Core-TM-_i3-6100_CPU_@_3.70GHz-with-gentoo-2.4.1
KiB Mem:    16314560 total,    727976 free
KiB Swap:   16775164 total,  16755468 free
Timestamp of repository gentoo: Sun, 14 Jan 2018 09:15:01 +0000
Head commit of repository gentoo: 121e063962a8dfc24a175a68785fdb79d7b5e013
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
ccache version 3.2.4 [enabled]
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.4.5-r1::gentoo, 3.5.4-r1::gentoo, 3.6.3-r1::gentoo
dev-util/ccache:          3.2.4::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.15.1-r1::gentoo                                                                                                
sys-devel/binutils:       2.29.1-r1::gentoo                                                                                                                   
sys-devel/gcc:            6.4.0-r1::gentoo                                                                                                                    
sys-devel/gcc-config:     1.8-r1::gentoo                                                                                                                      
sys-devel/libtool:        2.4.6-r3::gentoo                                                                                                                    
sys-devel/make:           4.2.1::gentoo                                                                                                                       
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)                                                                                                   
sys-libs/glibc:           2.25-r9::gentoo                                                                                                                     
Repositories:                                                                                                                                                 
                                                                                                                                                              
gentoo                                                                                                                                                        
    location: /usr/portage                                                                                                                                    
    sync-type: rsync                                                                                                                                          
    sync-uri: rsync://rsync.europe.gentoo.org/gentoo-portage                                                                                                  
    priority: -1000                                                                                                                                           
    sync-rsync-extra-opts: 

dotnet
    location: /var/lib/layman/dotnet
    sync-type: laymansync
    sync-uri: https://anongit.gentoo.org/git/proj/dotnet.git
    masters: gentoo
    priority: 1

gamerlay
    location: /var/lib/layman/gamerlay
    sync-type: laymansync
    sync-uri: git://anongit.gentoo.org/proj/gamerlay.git
    masters: gentoo
    priority: 10

jm-overlay
    location: /var/lib/layman/jm-overlay
    sync-type: laymansync
    sync-uri: https://github.com/Jannis234/jm-overlay.git
    masters: dotnet gentoo
    priority: 10

science
    location: /var/lib/layman/science
    sync-type: laymansync
    sync-uri: https://anongit.gentoo.org/git/proj/sci.git
    masters: gentoo
    priority: 50

mkyral
    location: /var/lib/layman/mkyral
    sync-type: laymansync
    sync-uri: git://github.com/mkyral/gentoo-overlay.git
    masters: gentoo
    priority: 100

xificurk
    location: /var/lib/layman/xificurk
    sync-type: laymansync
    sync-uri: https://github.com/xificurk/xificurk-gentoo-overlay.git
    masters: gentoo
    priority: 1000

Installed sets: @system
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.3/conf /usr/share/sddm/scripts/Xsetup /var/spool/munin-async/.ssh"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/apache2-php7.0/ext-active/ /etc/php/apache2-php7.1/ext-active/ /etc/php/apache2-php7.2/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cgi-php7.2/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/php/cli-php7.2/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="-j --load-average=5"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.dkm.cz/gentoo/ http://gentoo.mirror.web4u.cz/ http://distfiles.gentoo.org"
LANG="cs_CZ.UTF-8"
LC_ALL="cs_CZ.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en cs cz cs_CZ"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/tmp"
USE="X a52 aac accessibility acl acpi activities alsa amd64 apache2 apm bash-completion berkdb branding bzip2 cairo cdda cdr cjk cli consolekit crypt cups cxx dbus declarative djvu dri dts dv dvd dvdr emboss encode exif fam fat ffmpeg firefox flac fontconfig fortran ftp gd gdbm gif gimp glamor gnuplot gphoto2 gpm hddtemp iconv imagemagick innodb iproute2 ipv6 jabber java javascript jbig jingle jpeg jpeg2k kde kipi kwallet lame latex lcms libnotify libwww lm_sensors mad midi mime mng modules mozilla mp3 mp4 mpeg multilib musicbrainz mysql mysqli ncurses nls nptl nsplugin ntfs offensive ogg opengl openmp openstreetmap pam pango pcre pdf phonon php plasma plotutils png policykit posix ppds python qml qt3support qt5 quicktime rar raw readline rss rtc sasl scanner sdl seccomp semantic-desktop spell ssl startup-notification svg tcpd theora thunderbird tidy tiff timidity truetype udev udisks unicode upower usb vcd vorbis webkit widgets win32codecs wmf wxwidgets x264 xattr xcb xcomposite xml xmp xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="alias autoindex auth_basic authn_anon authn_core authn_default authn_file authz_core authz_default authz_host authz_owner authz_user cache dav deflate dir disk_cache env expires ext_filter file_cache filter headers info log_config logio mem_cache mime mime_magic negotiation proxy proxy_http rewrite setenvif socache_shmcb speling status unique_id unixd userdir vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext mpx popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="en cs cz cs_CZ" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0 php7-1 php7-2" POSTGRES_TARGETS="postgres10" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="intel i965 vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Anton 2018-01-19 14:48:52 UTC
I also confirm this bug with sddm 0.17.0-r1
Comment 2 Kent Hagebrand 2018-01-29 12:47:18 UTC
Same issue here, downgrading to 0.15 also solved my problem.
Comment 3 Alexander Miller 2018-03-14 01:27:56 UTC
Created attachment 523832 [details, diff]
sddm-0.17.0-switchToGreeter.patch

The attached patch fixes the issue for me.

Without logind, sddm's SeatManager object was creating its only seat ("seat0") too early, so the DisplayManager would never know about it and the dbus object for it wasn't created. The patch defers seat initialization until the DisplayManager has been connected.
Comment 4 augustin 2018-03-14 02:42:58 UTC
I tested the patch. It works for me. Thanks Alexander.

One odd thing: I am not sure if it's related nor relevant, but after re-emerging sddm with the patch, restarting xdm (service xdm restart) was not enough: I had a black screen. But after rebooting the whole computer it worked OK.
Comment 5 Andreas Sturmlechner gentoo-dev 2018-03-22 15:18:54 UTC
thanks Alexander, did you already submit your patch upstream?
Comment 6 Larry the Git Cow gentoo-dev 2018-04-05 15:55:23 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8e892dae48e6e695e7e809748a94d67e70be6c2f

commit 8e892dae48e6e695e7e809748a94d67e70be6c2f
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-04-05 15:53:03 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-04-05 15:54:47 +0000

    x11-misc/sddm: Fix SwitchToGreeter error
    
    Thanks-to: Alexander Miller <alex.miller@gmx.de>
    Bug: https://bugs.gentoo.org/644718
    Package-Manager: Portage-2.3.28, Repoman-2.3.9

 .../sddm/files/sddm-0.17.0-switchtogreeter.patch   | 54 ++++++++++++++
 x11-misc/sddm/sddm-0.17.0-r2.ebuild                | 83 ++++++++++++++++++++++
 2 files changed, 137 insertions(+)}
Comment 7 Andreas Sturmlechner gentoo-dev 2018-05-03 13:58:57 UTC
Arches, please stabilise.
Comment 8 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-05-03 15:50:28 UTC
amd64 stable
Comment 9 Thomas Deutschmann gentoo-dev Security 2018-05-04 15:37:36 UTC
x86 stable, closing
Comment 10 Michele Alzetta 2018-06-03 09:47:09 UTC
It seems that this patch introduces a new bug 
https://bugs.gentoo.org/show_bug.cgi?id=655912