Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 644378 - <dev-util/qstlink2-1.2.3 depends on deprecated Qt4
Summary: <dev-util/qstlink2-1.2.3 depends on deprecated Qt4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Boris Vingradov
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: qt4-removal qt4-r2-removal
  Show dependency tree
 
Reported: 2018-01-12 21:32 UTC by Andreas Sturmlechner
Modified: 2018-05-27 07:05 UTC (History)
1 user (show)

See Also:
Package list:
dev-util/qstlink2-1.2.3
Runtime testing required: ---
stable-bot: sanity-check+


Attachments
Ebuild for qtstlink2-1.2.3 version (qstlink2-1.2.3.ebuild,748 bytes, text/plain)
2018-05-13 13:02 UTC, Boris Vingradov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2018-01-12 21:32:18 UTC
Qt4 is dead and going away. Please bump to 1.2.3 release with Qt5 and cleanup old.
Comment 1 Boris Vingradov 2018-02-19 16:32:23 UTC
Current version of package more stability than 1.2.3. I need more time to introduce and test new version. New version don't have a build scripts too.
Comment 2 Andreas Sturmlechner gentoo-dev 2018-02-27 23:16:26 UTC
No build script sounds like a terrible upstream regression - but I see QStlink2.pro, where's the problem?
Comment 3 Boris Vingradov 2018-02-28 05:53:53 UTC
Zip hasn't required library and it cannot build without some operation. Also builded version from git repository has many problems with writing to devices - author doesn't update debugeer protocol.
Comment 4 Andreas Sturmlechner gentoo-dev 2018-03-15 10:38:33 UTC
(In reply to Boris Vingradov from comment #3)
> Zip hasn't required library and it cannot build without some operation.
Could you elaborate please? If there is a build issue I'm sure we could try to fix?
Comment 5 Boris Vingradov 2018-03-15 16:57:42 UTC
(In reply to Andreas Sturmlechner from comment #4)
> (In reply to Boris Vingradov from comment #3)
> > Zip hasn't required library and it cannot build without some operation.
> Could you elaborate please? If there is a build issue I'm sure we could try
> to fix?

Current version of zip archive doesn't have QtUSB library - it locate in another github repo. Author do not commit to their's repos about half year. I can move upper repos to one and create single zip. But I don't understand how to create qt5 ebuil script.

Thanks
Comment 6 Andreas Sturmlechner gentoo-dev 2018-03-15 18:39:06 UTC
(In reply to Boris Vingradov from comment #5)
> Current version of zip archive doesn't have QtUSB library - it locate in
> another github repo.
> I can move upper repos to one and create single zip.
Not necessary to repack the tarball. You can add QtUsb-0.3.0 as a second entry to SRC_URI and have them unpack both during src_unpack.

(In reply to Boris Vingradov from comment #5)
> But I don't understand how to create qt5 ebuil script.
You use qmake-utils.eclass and run at least src_configure and src_install manually - just look what qt4-r2.eclass was doing for you so far and simply adjust it for your needs inside qstlink2 ebuild.
Comment 7 Andreas Sturmlechner gentoo-dev 2018-03-17 10:49:35 UTC
Feel free to visit #gentoo-proxy-maint for more help.
Comment 8 Andreas Sturmlechner gentoo-dev 2018-04-09 21:31:44 UTC
Did you make progress here? Do you need some help?
Comment 9 Boris Vingradov 2018-04-12 18:04:34 UTC
Sorry. I don't have any time on this month, but I return to this task on next week.
Comment 10 Andreas Sturmlechner gentoo-dev 2018-05-12 14:22:49 UTC
One month passed, what's the current state? ;)
Comment 11 Boris Vingradov 2018-05-13 13:02:51 UTC
Created attachment 531210 [details]
Ebuild for qtstlink2-1.2.3 version
Comment 12 Boris Vingradov 2018-05-13 13:05:04 UTC
(In reply to Andreas Sturmlechner from comment #10)
> One month passed, what's the current state? ;)

Sorry for wait. I create ebuild for 1.2.3 version. I compile and test it on my devices. I adding Qt5 only ebuild because future releases couldn't support other version of Qt framework. Thanks for advice of creating ebuild.
Comment 13 Andreas Sturmlechner gentoo-dev 2018-05-13 15:06:07 UTC
Thanks for your work, keeping this open until old version is removed, and first of all we need to get the new version to tree. ;)

Of course, only Qt5 version makes sense at this point.
Comment 14 Andreas Sturmlechner gentoo-dev 2018-05-13 15:10:41 UTC
First, obvious error with the ebuild, wrong SRC_URI:

!!! Couldn't download 'qstlink2-1.2.3.tar.gz'. Aborting.
!!! Fetch failed for qstlink2-1.2.3.tar.gz, can't update Manifest

repoman complains as well:

  ebuild.minorsyn               3
   dev-util/qstlink2/qstlink2-1.2.3.ebuild: Ebuild contains leading spaces on line: 11
   dev-util/qstlink2/qstlink2-1.2.3.ebuild: Ebuild contains leading spaces on line: 24
   dev-util/qstlink2/qstlink2-1.2.3.ebuild: Ebuild contains leading spaces on line: 36


We'll need to drop back to ~amd64/~x86 because you can't add an ebuild with stable keywords, and I don't think you got all the dependencies in there (qtcore:5 most likely is not enough for a Qt5 GUI application).
Comment 15 Andreas Sturmlechner gentoo-dev 2018-05-13 15:18:04 UTC
In addition, lines 24 and 25 are missing `|| die`
Comment 16 Andreas Sturmlechner gentoo-dev 2018-05-13 15:24:10 UTC
QA notice during install:

 * QA Notice: udev rules should be installed in /lib/udev/rules.d:
 * 
 *   /etc/udev/rules.d/49-stlinkv2.rules
 *
Comment 17 Andreas Sturmlechner gentoo-dev 2018-05-13 15:27:38 UTC
Project configures and links fine with libusb-1, but ebuild limits to virtual/libusb:0.

> Project MESSAGE: Building QtUsb with LibUsb 1.0 support.
Comment 18 Larry the Git Cow gentoo-dev 2018-05-13 15:51:22 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=022e3abda43a0b5dfadd675f045c104d0cb6ebd9

commit 022e3abda43a0b5dfadd675f045c104d0cb6ebd9
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-05-13 15:48:27 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-05-13 15:51:08 +0000

    dev-util/qstlink2: 1.2.3 Qt5-based version bump
    
    - Use udev.eclass to fix rules.d install path
    - DEPEND on libusb-1
    
    Thanks-to: Boris Vingradov <no111u3@gmail.com>
    Bug: https://bugs.gentoo.org/644378
    Package-Manager: Portage-2.3.36, Repoman-2.3.9

 dev-util/qstlink2/Manifest              |  2 ++
 dev-util/qstlink2/qstlink2-1.2.3.ebuild | 45 +++++++++++++++++++++++++++++++++
 2 files changed, 47 insertions(+)
Comment 19 Andreas Sturmlechner gentoo-dev 2018-05-13 15:52:48 UTC
Please test, we'll give it some time then call for stabilisation.
Comment 20 Boris Vingradov 2018-05-13 17:01:27 UTC
(In reply to Andreas Sturmlechner from comment #19)
> Please test, we'll give it some time then call for stabilisation.

I successfull build for current version of package and use current build for flashing one of all my boards.

Thanks.
Comment 21 Andreas Sturmlechner gentoo-dev 2018-05-23 15:14:03 UTC
Arches, please stabilise.
Comment 22 Agostino Sarubbo gentoo-dev 2018-05-24 14:32:02 UTC
amd64 stable
Comment 23 Thomas Deutschmann gentoo-dev Security 2018-05-26 00:02:21 UTC
x86 stable, closing
Comment 24 Larry the Git Cow gentoo-dev 2018-05-27 07:05:17 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=51352e3292480c0521de875714a1773cb957c55f

commit 51352e3292480c0521de875714a1773cb957c55f
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-05-27 07:04:20 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-05-27 07:05:01 +0000

    dev-util/qstlink2: Drop old Qt4-based
    
    Bug: https://bugs.gentoo.org/644378
    Package-Manager: Portage-2.3.40, Repoman-2.3.9

 dev-util/qstlink2/Manifest              |  1 -
 dev-util/qstlink2/qstlink2-1.0.3.ebuild | 22 ----------------------
 2 files changed, 23 deletions(-)