Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 644362 - media-libs/SoQt depends on deprecated Qt4
Summary: media-libs/SoQt depends on deprecated Qt4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Maciej Mrozowski
URL:
Whiteboard: scheduled for removal on 2018-07-26
Keywords: PMASKED
Depends on:
Blocks: 659478 qt4-removal 638260
  Show dependency tree
 
Reported: 2018-01-12 19:34 UTC by Andreas Sturmlechner
Modified: 2019-05-29 22:41 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
SoQt-9999.ebuild (SoQt-9999.ebuild,868 bytes, text/plain)
2018-06-26 08:27 UTC, Fabio Rossi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2018-01-12 19:34:01 UTC
Qt4 is dead and going away, SoQt master apparently switched to CMake and already builds with Qt5 instead by default.
Comment 1 Maciej Mrozowski gentoo-dev 2018-05-06 09:20:15 UTC
In theory, yes, unfortunately upstream is messing with extracting common buildsystem and project stuff now to separate projects (akin to git submodules), this requires some custom src_unpack to fetch symlink those deps.. and doesn't work anyway because some files are missing according to CMake or misplaced. I might need to take some trial & error approach to find commit that works.
Comment 2 Andreas Sturmlechner gentoo-dev 2018-05-13 22:41:19 UTC
Thanks for your update; together with emfengine and quarter this is quickly becoming one of the very last blockers of qt4-removal.
Comment 3 Andreas Sturmlechner gentoo-dev 2018-06-24 23:37:07 UTC
Tuesday mask day.
Comment 4 Fabio Rossi 2018-06-26 08:27:52 UTC
Created attachment 537278 [details]
SoQt-9999.ebuild
Comment 5 bug2017 2018-06-28 12:31:32 UTC
The attached ebuild depends on coin-9999 which is not in tree. I suggest a small change to fix that:

+ >=media-libs/coin-4.0
- >=media-libs/coin-9999

It would be nice if the SoQt mask could mask only qt4 dpendend versions
Comment 6 Andreas Sturmlechner gentoo-dev 2018-06-28 18:44:47 UTC
The mask can be adjusted as soon as a relevant ebuild would be in tree.
Comment 7 Larry the Git Cow gentoo-dev 2018-08-07 07:28:18 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b0050dd898ed6e7290320c748aff6286989aa4fb

commit b0050dd898ed6e7290320c748aff6286989aa4fb
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-07-01 16:52:01 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-08-07 07:27:04 +0000

    media-libs/SoQt: Remove last-rited
    
    Closes: https://bugs.gentoo.org/644362

 media-libs/SoQt/Manifest                           |  1 -
 media-libs/SoQt/SoQt-1.5.0-r1.ebuild               | 57 ----------------------
 .../SoQt/files/SoQt-1.5.0-pkgconfig-partial.patch  | 13 -----
 media-libs/SoQt/metadata.xml                       | 10 ----
 profiles/package.mask                              |  1 -
 5 files changed, 82 deletions(-)
Comment 8 bug2017 2018-08-07 08:36:58 UTC
Closing this bug solved the qt4 removal.
But pivy (bug 659478) requires the newer SoQt ebuild attached to this bug.

Should I open a new bug?
Comment 9 Andreas Sturmlechner gentoo-dev 2018-08-07 08:43:02 UTC
(In reply to bug2017 from comment #8)
> Should I open a new bug?
Yes please.