Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 643758 - media-gfx/gimp: broken localization after removal of linguas
Summary: media-gfx/gimp: broken localization after removal of linguas
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sebastian Pipping
: 643838 (view as bug list)
Depends on:
Blocks: linguas-to-l10n
  Show dependency tree
Reported: 2018-01-07 08:34 UTC by tt_1
Modified: 2018-01-16 18:15 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description tt_1 2018-01-07 08:34:32 UTC
So appareantly the linguas useflags got removed for many packages where they made not too much sense, such as app-portage/eix or sys-apps/shadow. But for gimp, this does break localization. Is there another way to reenable this but to simply revert the commit?
Comment 1 Ulrich Müller gentoo-dev 2018-01-07 14:42:35 UTC
Can you be more specific, please?
- What is the value of your LINGUAS variable (or simply post emerge --info)?
- What exact version of gimp have you installed?
- What locales are missing?
Comment 2 Mikhail Kurinnoi 2018-01-07 15:28:47 UTC
Faced with same issue with current stable media-gfx/gimp-2.8.22 after "media-gfx/gimp: Remove linguas_* from IUSE."

Russian localization are missed after gimp re-emerged.

Portage 2.3.13 (python 3.5.4-final-0, targets/desktop, gcc-6.4.0, glibc-2.25-r9, 4.14.11-gentoo-r2 x86_64)
System uname: Linux-4.14.11-gentoo-r2-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9450_@_2.66GHz-with-gentoo-2.4.1
KiB Mem:     8167708 total,   2618684 free
KiB Swap:    4194300 total,   4194300 free
Timestamp of repository gentoo: Sat, 06 Jan 2018 00:45:01 +0000
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p12::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.4-r1::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.15.1-r1::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r9::gentoo

    location: /usr/portage
    sync-type: webrsync
    sync-uri: rsync://
    priority: -1000

    location: /usr/local/portage
    masters: gentoo

CFLAGS="-march=core2 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
EMERGE_DEFAULT_OPTS="--binpkg-respect-use=y --with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs cgroup config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en ru ru_RU"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac acl acpi alsa amd64 berkdb branding bzip2 cairo cdda cdr cli consolekit crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam flac fontconfig gdbm gif glamor gpm gtk hardened iconv jpeg lcms libnotify mad mng modules mp3 mp4 mpeg multilib ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf pie png policykit ppds pulseaudio qt5 readline sdl seccomp session smp spell ssl ssp startup-notification svg tcpd threads tiff truetype udev udisks unicode upower urandom usb vdpau vorbis wxwidgets x264 xattr xcb xinerama xml xtpax xv xvid zlib" ABI_X86="32 64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" L10N="en ru ru-RU" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 3 Ulrich Müller gentoo-dev 2018-01-07 16:37:15 UTC
(In reply to Mikhail Kurinnoi from comment #2)
> Timestamp of repository gentoo: Sat, 06 Jan 2018 00:45:01 +0000

That timestamp is older than the commit that has (hopefully) fixed it:

Please resync and try again.
Comment 4 Mikhail Kurinnoi 2018-01-07 18:12:33 UTC
Ahhh... only now noticed, that the portage timestamp is older than the commit. I did resync and I can confirm, that the issue is fixed for me.
Comment 5 tt_1 2018-01-07 18:59:27 UTC
(In reply to Ulrich Müller from comment #3)
> (In reply to Mikhail Kurinnoi from comment #2)
> > Timestamp of repository gentoo: Sat, 06 Jan 2018 00:45:01 +0000
> That timestamp is older than the commit that has (hopefully) fixed it:
> ?id=8c05c61b85a891b0b86168eb8deb8fdd5ad0420e
> Please resync and try again.

It is fixed, thanks.
Comment 6 Ulrich Müller gentoo-dev 2018-01-16 18:15:24 UTC
*** Bug 643838 has been marked as a duplicate of this bug. ***