Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 643700 - net-analyzer/scapy: depends on old version of dev-python/pyx
Summary: net-analyzer/scapy: depends on old version of dev-python/pyx
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mike Auty
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-06 13:15 UTC by Michał Górny
Modified: 2020-02-02 12:42 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2018-01-06 13:15:15 UTC
Only the oldest version of dev-python/pyx supports py2.7, while scapy supposedly supports py2.7 only. Please check whether this package can be made to work with python3.
Comment 1 Pacho Ramos gentoo-dev 2020-02-02 12:42:31 UTC
I asked upstream and latest version should work with any pyx version
https://github.com/secdev/scapy/issues/657#issuecomment-581129886