Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 643004 - app-misc/anki-2.1.0_beta27: Missing dependency on qt >= 5.9
Summary: app-misc/anki-2.1.0_beta27: Missing dependency on qt >= 5.9
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-01 18:10 UTC by Erik Hahn
Modified: 2020-06-12 17:32 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Output of emerge --info (equery--info.txt,5.74 KB, text/plain)
2018-01-01 18:10 UTC, Erik Hahn
Details
Output of equery depgraph '=app-misc/anki-2.1.0_beta27' (depgraph.txt,1.03 KB, text/plain)
2018-01-01 18:11 UTC, Erik Hahn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Hahn 2018-01-01 18:10:42 UTC
Created attachment 512640 [details]
Output of emerge --info

When I try to start Anki, I get the following error:

$ anki
Traceback (most recent call last):
  File "/usr/lib/python-exec/python3.6/anki", line 6, in <module>
    import aqt
  File "/usr/lib64/python3.6/site-packages/aqt/__init__.py", line 14, in <module>
    from aqt.qt import *
  File "/usr/lib64/python3.6/site-packages/aqt/qt.py", line 42, in <module>
    raise Exception("Anki requires Qt 5.9.0+")
Exception: Anki requires Qt 5.9.0+
Comment 1 Erik Hahn 2018-01-01 18:11:24 UTC
Created attachment 512642 [details]
Output of equery depgraph '=app-misc/anki-2.1.0_beta27'
Comment 2 Erik Hahn 2018-01-05 04:28:31 UTC
Anki now works for me after upgrading Qt and rebuilding PyQt.
Comment 3 glyphimor 2018-01-22 02:01:32 UTC
Just chiming in to report that this bug in app-misc/anki-2.1.0_beta27 affected me as well, w/ dev-python/PyQt5-5.7.1 installed.
Comment 4 cburroughs 2020-06-12 17:32:44 UTC
 Erik Hahn, do you still see this (or a similar) problem with the 2.1.15 ebuild?