Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 642602 - app-office/libreoffice[pdfimport] fails to build with >=app-text/poppler-0.62.0
Summary: app-office/libreoffice[pdfimport] fails to build with >=app-text/poppler-0.62.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: poppler-qt4-removal
  Show dependency tree
 
Reported: 2017-12-29 07:24 UTC by Lars Wendler (Polynomial-C)
Modified: 2018-01-05 00:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.xz (build.log.xz,438.94 KB, application/x-xz)
2017-12-29 07:24 UTC, Lars Wendler (Polynomial-C)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2017-12-29 07:24:01 UTC
Created attachment 511936 [details]
build.log.xz

[build CXX] sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
S=/var/tmp/portage/app-office/libreoffice-5.4.4.2/work/libreoffice-5.4.4.2 && I=$S/instdir && W=$S/workdir &&  mkdir -p $W/CxxObject/sdext/source/pdfimport/xpdfwrapper/ $W/Dep/CxxObject/sdext/source/pdfimport/xpdfwrapper/ && cd /var/tmp/portage/app-office/libreoffice-5.4.4.2/work/libreoffice-5.4.4.2 &&    x86_64-pc-linux-gnu-g++ -DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED -DCPPU_ENV=gcc3 -DLINUX -DNDEBUG -DOSL_DEBUG_LEVEL=0 -DUNIX -DUNX -DX86_64 -D_PTHREADS -D_REENTRANT  -DSYSTEM_ZLIB   -fvisibility=hidden    -Wall -Wno-missing-braces -Wnon-virtual-dtor -Wendif-labels -Wextra -Wundef -Wunused-macros -fmessage-length=0 -fno-common -pipe  -Wduplicated-cond -Wlogical-op -Wshift-overflow=2 -Wunused-const-variable=1 -fvisibility-inlines-hidden -fstack-protector-strong -fPIC -Wshadow -Woverloaded-virtual -std=gnu++14   -DEXCEPTIONS_ON -fexceptions -fno-enforce-eh-specs -march=native -mtune=native -O2 -pipe  -DLIBO_INTERNAL_ONLY  -c $S/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx -o $W/CxxObject/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.o  -I$S/sdext/source/pdfimport/xpdfwrapper/ -isystem /usr/include/poppler  -I$S/include  -I/usr/lib64/icedtea8/include -I/usr/lib64/icedtea8/include/linux -I$S/config_host  -I/usr/include    -I/usr/include/freetype2 -I/usr/include/harfbuzz -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/harfbuzz -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include    
/var/tmp/portage/app-office/libreoffice-5.4.4.2/work/libreoffice-5.4.4.2/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx:39:10: fatal error: UTF8.h: No such file or directory
 #include "UTF8.h"
          ^~~~~~~~
compilation terminated.
Comment 1 Andreas Sturmlechner gentoo-dev 2018-01-04 22:36:09 UTC
Reason being renaming of UTF8.h to UnicodeMapFuncs.h

See also:
https://cgit.freedesktop.org/poppler/poppler/commit/CMakeLists.txt?id=5c394f71f03d27507db3446ad34f299393fa3621
Comment 2 Andreas Sturmlechner gentoo-dev 2018-01-04 23:33:33 UTC
Second issue rename of UCS2 to UTF16.
Comment 3 Larry the Git Cow gentoo-dev 2018-01-05 00:35:01 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=db869f1cfa8ee0887d6729bcdc29e3865800e64e

commit db869f1cfa8ee0887d6729bcdc29e3865800e64e
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-01-04 23:01:23 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-01-05 00:34:28 +0000

    app-office/libreoffice: Fix build w/ USE=pdfimport and poppler-0.62
    
    Closes: https://bugs.gentoo.org/642602
    Package-Manager: Portage-2.3.19, Repoman-2.3.6

 .../files/libreoffice-5.4.4.2-poppler-0.62.patch   | 44 ++++++++++++++++++++++
 app-office/libreoffice/libreoffice-5.4.4.2.ebuild  |  3 +-
 2 files changed, 46 insertions(+), 1 deletion(-)