Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 641450 - app-crypt/gnupg-2.2.3 fails test: Failed tests: <extended-key-format>tests/openpgp/quick-key-manipulation.scm
Summary: app-crypt/gnupg-2.2.3 fails test: Failed tests: <extended-key-format>tests/op...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2017-12-17 10:09 UTC by Toralf Förster
Modified: 2022-02-13 09:51 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,14.82 KB, text/plain)
2017-12-17 10:09 UTC, Toralf Förster
Details
app-crypt:gnupg-2.2.3:20171217-030138.log (app-crypt:gnupg-2.2.3:20171217-030138.log,231.61 KB, text/plain)
2017-12-17 10:09 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,25.68 KB, text/plain)
2017-12-17 10:09 UTC, Toralf Förster
Details
environment (environment,53.16 KB, text/plain)
2017-12-17 10:09 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.90 KB, application/x-bzip)
2017-12-17 10:09 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,21.41 KB, application/x-bzip)
2017-12-17 10:09 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,29.36 KB, application/x-bzip)
2017-12-17 10:09 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-12-17 10:09:19 UTC
=================== 
180 tests run, 173 succeeded, 1 failed, 0 failed expectedly, 0 succeeded unexpectedly, 6 skipped. 
Failed tests: <extended-key-format>tests/openpgp/quick-key-manipulation.scm 
Skipped tests: <extended-key-format>tests/openpgp/issue2929.scm <extended-key-format>tests/openpgp/tofu.scm <use-keyring>tests/openpgp/issue2929.scm <use-keyring>tests/openpgp/tofu.scm tests/openpgp/issue2929.scm tests/openpgp/tofu.scm 
=================== 
make[2]: *** [Makefile:947: xcheck] Error 1

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0_test_20171216-103216

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python3.6 (fallback)
  [3]   python2.7 (fallback)

java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.6.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv app-crypt/gnupg
[ebuild  N    ] app-crypt/gnupg-2.2.3  USE="bzip2 gnutls nls readline smartcard -doc -ldap (-selinux) -tofu -tools -usb -wks-server"
Comment 1 Toralf Förster gentoo-dev 2017-12-17 10:09:22 UTC
Created attachment 510430 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-12-17 10:09:25 UTC
Created attachment 510432 [details]
app-crypt:gnupg-2.2.3:20171217-030138.log
Comment 3 Toralf Förster gentoo-dev 2017-12-17 10:09:28 UTC
Created attachment 510434 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2017-12-17 10:09:31 UTC
Created attachment 510436 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2017-12-17 10:09:34 UTC
Created attachment 510438 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-12-17 10:09:39 UTC
Created attachment 510440 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2017-12-17 10:09:42 UTC
Created attachment 510442 [details]
temp.tbz2
Comment 8 Kristian Fiskerstrand (RETIRED) gentoo-dev 2017-12-18 21:27:49 UTC
This seems to be a new one, looks like 
    > () (- - -) (default default never) (rsa sign auth encr seconds=600) (rsa auth,encr 2) (rsa sign 2038-01-01) ("/var/tmp/portage/app-crypt/gnupg-2.2.3/work/gnupg-2.2.3/g10/gpg" --no-permission-warning --always-trust --quick-add-key "9FFBAB87F0436CB33FECA99F99982D19F3772D39" rsa "sign" "2038-01-01") failed: gpg: signing failed: Corrupted protection
gpg: make_keysig_packet failed for backsig: Corrupted protection
gpg: Key generation failed: Corrupted protection
gpg: Key not changed so no update needed.

is the kicker... I haven't seen that one before, seems for some reason it fails adding the cross-certification during subkey binding signature generation.
Comment 9 Rolf Eike Beer archtester 2018-06-08 15:17:19 UTC

*** This bug has been marked as a duplicate of bug 636100 ***
Comment 10 Kristian Fiskerstrand (RETIRED) gentoo-dev 2018-10-30 21:35:15 UTC
I'm removing this as dupe as the assertion error is different from the protection corruption
Comment 11 Agostino Sarubbo gentoo-dev 2022-02-13 09:51:34 UTC
Update summary. [something] is used when something refers to an overlay