Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 640832 - dev-libs/elfutils-0.170 [lto] libdw.so: No symbol version section for versioned symbol `dwarf_decl_column@ELFUTILS_0.143
Summary: dev-libs/elfutils-0.170 [lto] libdw.so: No symbol version section for version...
Status: RESOLVED DUPLICATE of bug 616038
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: lto
  Show dependency tree
 
Reported: 2017-12-12 16:59 UTC by cryptopsy
Modified: 2019-01-26 22:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (info,3.24 KB, text/plain)
2017-12-12 16:59 UTC, cryptopsy
Details
build.log (log.log,398.39 KB, text/x-log)
2017-12-12 17:08 UTC, cryptopsy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cryptopsy 2017-12-12 16:59:01 UTC
Created attachment 509608 [details]
emerge --info

/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/../../../../x86_64-pc-linux-gnu/bin/ld: libdw.so: No symbol version section for versioned symbol `dwarf_decl_column@ELFUTILS_0.143'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/../../../../x86_64-pc-linux-gnu/bin/ld: final link failed: Nonrepresentable section on output
collect2: error: ld returned 1 exit status
make[3]: *** [Makefile:1010: libdw.so] Error 1
make[2]: *** [Makefile:514: all] Error 2
Comment 1 cryptopsy 2017-12-12 16:59:31 UTC
Note -flto in make.conf
Comment 2 cryptopsy 2017-12-12 17:08:47 UTC
Created attachment 509612 [details]
build.log
Comment 3 Andreas K. Hüttel gentoo-dev 2017-12-17 00:10:26 UTC
Seeing this too.
Comment 4 Sergei Trofimovich gentoo-dev 2019-01-26 22:14:55 UTC

*** This bug has been marked as a duplicate of bug 616038 ***