Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 640706 - net-irc/anope version bump
Summary: net-irc/anope version bump
Status: RESOLVED DUPLICATE of bug 420613
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Bjarke Istrup Pedersen (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-11 16:18 UTC by Palme
Modified: 2018-03-13 12:18 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Palme 2017-12-11 16:18:55 UTC
Anope 2.0.5 has been released, which contains bug fixes, and several new features.

The notable changes includes:

Fix negative levels to not match users with negative access
Fix memo sender to always be the account name of the sender
Allow unregistered users to use the ChanServ seen command
Fix secureops to not be enforced on operators with the chanserv/administration privilege
Fix command name in HELP syntax messages to always be upper case
Show unconfirmed nickname messages on registration in webcpanel
Fix NickServ SET EMAIL to be executable via XMLRPC
Fix OperServ USERLIST/CHANLIST to accept regexes
Allow OperServ USERLIST to also match realname syntax (n!u@h#r)
Fix db_old importing languages to use the UTF-8 version
Fix m_dns to return REFUSED if no answers could be found
Fix ns_maxemail to be case insensitive
Add MemoServ READ ALL command
Add support for NickServ GROUP to be executed via XMLRPC
Add support for logging hostname/ip of SASL authentication attempts, if supported by IRCd
https://github.com/anope/anope/releases/download/2.0.5/anope-2.0.5-source.tar.gz
Comment 1 Jonas Stein gentoo-dev 2017-12-11 16:26:59 UTC
Thank you for the bump request. 
You can help the maintainer with further information:
Does a simple bump [1] work on your system? 
Chances are high, because a first look on the bump revealed only small changes.

[1] https://wiki.gentoo.org/wiki/Custom_repository#Simple_version_bump_of_an_ebuild_in_the_local_overlay
Comment 2 Palme 2017-12-11 19:19:08 UTC
(In reply to Jonas Stein from comment #1)
> Thank you for the bump request. 
> You can help the maintainer with further information:
> Does a simple bump [1] work on your system? 
> Chances are high, because a first look on the bump revealed only small
> changes.
> 
> [1]
> https://wiki.gentoo.org/wiki/
> Custom_repository#Simple_version_bump_of_an_ebuild_in_the_local_overlay


unfortunately not, a simple bump Doesnt work on my system

> * ERROR: net-irc/anope-2.0.5::localrepo failed (depend phase):
> *   External commands disallowed while sourcing ebuild: Questions or comments?
> *
> * Call stack:
> *            ebuild.sh, line 620:  Called source '/usr/local/portage/net->irc/anope/anope-2.0.5.ebuild'
> *   anope-2.0.5.ebuild, line 123:  Called command_not_found_handle 'Questions' 'or' 'comments?'
> *            ebuild.sh, line  88:  Called die
> * The specific snippet of code:
> *              die "External commands disallowed while sourcing ebuild: ${*}"
> *
> * If you need support, post the output of `emerge --info '=net-irc/anope-2.0.5::localrepo'`,
> * the complete build log and the output of `emerge -pqv '=net-irc/anope-2.0.5::localrepo'`.
> * Working directory: '/usr/lib64/python3.5/site-packages'
 >* S: '/var/tmp/portage/net-irc/anope-2.0.5/work/anope-2.0.5'
> !!! getFetchMap(): aux_get() error reading net-irc/anope-2.0.5; aborting.
> Unable to generate manifest.
Comment 3 Pacho Ramos gentoo-dev 2018-03-13 12:18:24 UTC

*** This bug has been marked as a duplicate of bug 420613 ***