Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 639956 - dev-ruby/sigar-0.7.3 : sigar_util.c:742:10: fatal error: rpc/rpc.h: No such file or directory
Summary: dev-ruby/sigar-0.7.3 : sigar_util.c:742:10: fatal error: rpc/rpc.h: No such f...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-rpc
  Show dependency tree
 
Reported: 2017-12-05 16:18 UTC by Toralf Förster
Modified: 2018-05-21 11:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.84 KB, text/plain)
2017-12-05 16:18 UTC, Toralf Förster
Details
dev-ruby:sigar-0.7.3:20171205-011050.log (dev-ruby:sigar-0.7.3:20171205-011050.log,13.17 KB, text/plain)
2017-12-05 16:18 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,154.54 KB, text/plain)
2017-12-05 16:18 UTC, Toralf Förster
Details
environment (environment,158.41 KB, text/plain)
2017-12-05 16:18 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,37.33 KB, application/x-bzip)
2017-12-05 16:18 UTC, Toralf Förster
Details
emerge-info.txt (emerge-info.txt,15.20 KB, text/plain)
2018-05-21 07:32 UTC, Toralf Förster
Details
dev-ruby:sigar-0.7.3:20180520-231816.log (dev-ruby:sigar-0.7.3:20180520-231816.log,11.99 KB, text/plain)
2018-05-21 07:32 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,105.22 KB, text/plain)
2018-05-21 07:32 UTC, Toralf Förster
Details
environment (environment,156.42 KB, text/plain)
2018-05-21 07:32 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.25 KB, application/x-bzip)
2018-05-21 07:32 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-12-05 16:18:03 UTC
            ^~~~~~~~~
sigar_util.c: At top level:
sigar_util.c:742:10: fatal error: rpc/rpc.h: No such file or directory
 #include <rpc/rpc.h>
          ^~~~~~~~~~~
compilation terminated.

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-desktop-plasma_20171130-223509

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.6 (fallback)
  [3]   python3.5 (fallback)
  [4]   python2.7 (fallback)
  [5]   pypy (fallback)
Available Ruby profiles:
  [1]   ruby22 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.6.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv dev-ruby/sigar
[ebuild  N    ] dev-ruby/sigar-0.7.3  USE="{-test}" RUBY_TARGETS="ruby22 -ruby23"
Comment 1 Toralf Förster gentoo-dev 2017-12-05 16:18:05 UTC
Created attachment 508306 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-12-05 16:18:08 UTC
Created attachment 508308 [details]
dev-ruby:sigar-0.7.3:20171205-011050.log
Comment 3 Toralf Förster gentoo-dev 2017-12-05 16:18:11 UTC
Created attachment 508310 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2017-12-05 16:18:14 UTC
Created attachment 508312 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2017-12-05 16:18:17 UTC
Created attachment 508314 [details]
etc.portage.tbz2
Comment 6 Hans de Graaff gentoo-dev 2018-02-17 07:34:17 UTC

*** This bug has been marked as a duplicate of bug 639470 ***
Comment 7 Toralf Förster gentoo-dev 2018-05-21 07:32:32 UTC
got at the unstable amd64 chroot image 17.0-hardened_20180519-101508 this : sigar_util.c:742:10: fatal error: rpc/rpc.h: No such file or directory
Comment 8 Toralf Förster gentoo-dev 2018-05-21 07:32:36 UTC
Created attachment 532432 [details]
emerge-info.txt
Comment 9 Toralf Förster gentoo-dev 2018-05-21 07:32:39 UTC
Created attachment 532434 [details]
dev-ruby:sigar-0.7.3:20180520-231816.log
Comment 10 Toralf Förster gentoo-dev 2018-05-21 07:32:42 UTC
Created attachment 532436 [details]
emerge-history.txt
Comment 11 Toralf Förster gentoo-dev 2018-05-21 07:32:46 UTC
Created attachment 532438 [details]
environment
Comment 12 Toralf Förster gentoo-dev 2018-05-21 07:32:49 UTC
Created attachment 532440 [details]
etc.portage.tbz2
Comment 13 Larry the Git Cow gentoo-dev 2018-05-21 11:50:16 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b53e02875a4c129ad7d6ebd114b186393726f002

commit b53e02875a4c129ad7d6ebd114b186393726f002
Author:     Hans de Graaff <graaff@gentoo.org>
AuthorDate: 2018-05-21 11:48:55 +0000
Commit:     Hans de Graaff <graaff@gentoo.org>
CommitDate: 2018-05-21 11:49:26 +0000

    dev-ruby/sigar: properly set tirpc include directory
    
    Fixes building with libtirpc on a glibc 2.26+ system.
    
    Closes: https://bugs.gentoo.org/639956
    Package-Manager: Portage-2.3.36, Repoman-2.3.9

 dev-ruby/sigar/sigar-0.7.3.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)