Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 639726 - dev-lisp/sbcl-1.3.11 Fails to build with profile 17.0 emerge -e world
Summary: dev-lisp/sbcl-1.3.11 Fails to build with profile 17.0 emerge -e world
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 2 votes (vote)
Assignee: Common Lisp Bugs
URL:
Whiteboard:
Keywords:
: 642246 (view as bug list)
Depends on:
Blocks: default-pie gcc-6
  Show dependency tree
 
Reported: 2017-12-04 07:25 UTC by Peter Fox
Modified: 2018-02-16 13:54 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (einfo.txt,5.77 KB, text/plain)
2017-12-04 07:27 UTC, Peter Fox
Details
build.log (build.log,88.34 KB, text/x-log)
2017-12-04 07:29 UTC, Peter Fox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Fox 2017-12-04 07:25:44 UTC
Followed instructions in enews "2017-11-30  New 17.0 profiles in the Gentoo repository" and above package failed to build during "emerge -e @world" with
linker errors:
/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/../../../../x86_64-pc-linux-gnu/bin/ld: x86-64-assem.o: relocation R_X86_64_32S against undefined symbol `all_threads' can not be used when making a shared object; recompile with -fPIC
/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/../../../../x86_64-pc-linux-gnu/bin/ld: ldso-stubs.o: warning: relocation against `getenv@@GLIBC_2.2.5' in readonly section `.text'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/../../../../x86_64-pc-linux-gnu/bin/ld: final link failed: Nonrepresentable section on output



Reproducible: Always
Comment 1 Peter Fox 2017-12-04 07:27:24 UTC
Created attachment 507976 [details]
emerge --info
Comment 2 Peter Fox 2017-12-04 07:29:02 UTC
Created attachment 507978 [details]
build.log
Comment 3 Viacheslav Ostroukh 2017-12-04 14:41:55 UTC
Confirm, same is for me.
Comment 4 Pacho Ramos gentoo-dev 2017-12-05 22:02:00 UTC
dev-lisp/sbcl-1.3.21 works, maybe we could stable that one
Comment 5 Mircea Sava 2017-12-05 23:11:40 UTC
I can confirm successful build of dev-lisp/sbcl-1.3.21
Comment 6 LdBeth 2017-12-06 08:46:24 UTC
Confirmed for me.
Building 1.4.2 have no problem.
Comment 7 Pacho Ramos gentoo-dev 2017-12-06 09:33:42 UTC
What version should we stabilize? I would opt for latest 1.3.x because of bug 639898 and bug 636340 affecting 1.4
Comment 8 Vincent-Xavier JUMEL 2017-12-06 19:30:51 UTC
I'm trying every single version of SBCL in tree and the all failed. Seems to have a -no-pie flag to be set about this : https://sourceforge.net/p/sbcl/sbcl/ci/3403dbaffc0a9bab49b78cf0bb5308cce0a0c153/
Comment 9 Vincent-Xavier JUMEL 2017-12-06 20:01:33 UTC
There's also https://bugs.launchpad.net/sbcl/+bug/1633559
Comment 10 Peter Fox 2017-12-07 23:51:37 UTC
Build of dev-lisp/sbcl-1.3.21 works for me.
Comment 11 Chema Alonso Josa (RETIRED) gentoo-dev 2017-12-08 09:16:32 UTC
(In reply to Peter Fox from comment #10)
> Build of dev-lisp/sbcl-1.3.21 works for me.

=dev-lisp/sbcl-1.3.21 builds fine here with profile 17.0

I'll create the stabilization bug shortly

Thanks all.
Comment 12 Chema Alonso Josa (RETIRED) gentoo-dev 2017-12-08 09:17:47 UTC
(In reply to Vincent-Xavier JUMEL from comment #8)
> I'm trying every single version of SBCL in tree and the all failed. Seems to
> have a -no-pie flag to be set about this :
> https://sourceforge.net/p/sbcl/sbcl/ci/
> 3403dbaffc0a9bab49b78cf0bb5308cce0a0c153/

Could you open a separate bug with info for your failing sbcl-1.3.21?

Thanks.
Comment 13 Vincent-Xavier JUMEL 2017-12-08 19:28:10 UTC
(In reply to Chema Alonso Josa from comment #12)
> (In reply to Vincent-Xavier JUMEL from comment #8)
> > I'm trying every single version of SBCL in tree and the all failed. Seems to
> > have a -no-pie flag to be set about this :
> > https://sourceforge.net/p/sbcl/sbcl/ci/
> > 3403dbaffc0a9bab49b78cf0bb5308cce0a0c153/
> 
> Could you open a separate bug with info for your failing sbcl-1.3.21?
> 
> Thanks.

See #640320
Comment 14 Vincent-Xavier JUMEL 2017-12-08 19:28:36 UTC
(In reply to Chema Alonso Josa from comment #12)
> (In reply to Vincent-Xavier JUMEL from comment #8)
> > I'm trying every single version of SBCL in tree and the all failed. Seems to
> > have a -no-pie flag to be set about this :
> > https://sourceforge.net/p/sbcl/sbcl/ci/
> > 3403dbaffc0a9bab49b78cf0bb5308cce0a0c153/
> 
> Could you open a separate bug with info for your failing sbcl-1.3.21?
> 
> Thanks.

See https://bugs.gentoo.org/640320
Comment 15 Pacho Ramos gentoo-dev 2017-12-27 23:45:12 UTC
(In reply to Chema Alonso Josa from comment #11)
> (In reply to Peter Fox from comment #10)
> > Build of dev-lisp/sbcl-1.3.21 works for me.
> 
> =dev-lisp/sbcl-1.3.21 builds fine here with profile 17.0
> 
> I'll create the stabilization bug shortly
> 
> Thanks all.

Any news on this? Current stable is still broken 

Thanks
Comment 16 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2018-01-03 14:56:23 UTC
*** Bug 642246 has been marked as a duplicate of this bug. ***
Comment 17 Chema Alonso Josa (RETIRED) gentoo-dev 2018-01-29 21:53:16 UTC
(In reply to Pacho Ramos from comment #15)
> Any news on this? Current stable is still broken 
> 
> Thanks

Bug filled, sorry for the long delay:

https://bugs.gentoo.org/645954
Comment 18 charlz_klug 2018-02-16 13:21:48 UTC
Confirm, same is for me.
Comment 19 charlz_klug 2018-02-16 13:54:23 UTC
But, version 1.3.21 is emerging successfully.