Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 639250 - www-client/seamonkey www-client/firefox with x11-drivers/nvidia-drivers-387.22 - MOZ_CRASH("GFX: Unexpected GLSL version.");
Summary: www-client/seamonkey www-client/firefox with x11-drivers/nvidia-drivers-387.2...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords: InVCS, PATCH
Depends on:
Blocks:
 
Reported: 2017-11-30 00:43 UTC by Tango
Modified: 2018-01-01 17:04 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_639250.txt,5.73 KB, text/plain)
2017-11-30 00:43 UTC, Tango
Details
WebGLShaderValidator.patch (WebGLShaderValidator.patch,547 bytes, patch)
2017-12-01 00:46 UTC, Tango
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tango 2017-11-30 00:43:32 UTC
Created attachment 507248 [details]
emerge --info

The latest nvidia-drivers-387.22 will cause rare crashes when loading some Websites in both Seamonkey and Firefox with the error "MozCrashReason: MOZ_CRASH(GFX: Unexpected GLSL version.)"

Crash occurs when:
1. When any version of Firefox or Firefox backend less than 56.* (Seamonkey) is installed.
2. =>nvidia-drivers-387.22 are installed.
3. System hardware supports Opengl 4.6.0 and GLSL 4.60
4. Attempt to load Newegg or Reddit (may affect other sites as well)

This was fixed upstream in versions of =>Firefox-56.*
Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1382358
Patch: https://hg.mozilla.org/integration/mozilla-inbound/rev/4a5185552a07

Seamonkey has no fix yet.  I reported it upstream at:
https://bugzilla.mozilla.org/show_bug.cgi?id=1421093

A short discussion in Gentoo forums at:
https://forums.gentoo.org/viewtopic.php?p=8147630#8147630

Code change in source necessary:
@ dom/canvas/WebGLShaderValidator.cpp
-            MOZ_CRASH("GFX: Unexpected GLSL version.");
+            MOZ_ASSERT(false, "GFX: Unexpected GLSL version.");

I have tested with ~firefox-bin-57.0 and can confirm the bug is not present.

Sorry but I don't know how to write a patch or I would submit one.
Comment 1 Tango 2017-11-30 00:52:53 UTC
This bug is related to both Firefox and Samonkey as opposed to Nvidia-drivers. However I did not know where best to report it.
Comment 2 Tango 2017-12-01 00:46:04 UTC
Created attachment 507474 [details, diff]
WebGLShaderValidator.patch
Comment 3 Tango 2017-12-01 01:41:47 UTC
I recompiled Seamonkey-2.48 applying the attached patch and can confirm the bug is no longer present
Comment 4 Thomas Albers 2017-12-02 16:06:28 UTC
Can confirm that Firefox-52.4.0 together with nvidia-drivers-387.22 crashes when certain websites (i.e. Reddit) are visited, and that downgrade to nvidia-drivers-384.90 fixes the problem.
Comment 5 Jeroen Roovers gentoo-dev 2017-12-02 21:56:30 UTC
(In reply to Tango from comment #0)
> Created attachment 507248 [details]
> Emerge --info
> 
> The latest nvidia-drivers-387.22 will cause rare crashes

That's a funny way of looking at it.
Comment 6 Tango 2017-12-03 01:12:50 UTC
(In reply to Jeroen Roovers from comment #5)
> (In reply to Tango from comment #0)
> > Created attachment 507248 [details]
> > Emerge --info
> > 
> > The latest nvidia-drivers-387.22 will cause rare crashes
> 
> That's a funny way of looking at it.

LOL... I Know.

Its just the sequence of events that caused me to describe it that way.

System updated Seamonkey form 2.46 to 2.48 stable all is well and normal for several days.

System installs updated nvidia-drivers then both Seamonkey and Firefox browsers begin to crash, but only on some web sites.
Comment 7 Thomas Albers 2017-12-03 22:48:25 UTC
> > The latest nvidia-drivers-387.22 will cause rare crashes
> 
> That's a funny way of looking at it.

You can crash Firefox *reproducibly* just by visiting Reddit (and many other sites). It's a very serious bug, the stable release of a mainline webbrowser not playing nicely with the latest driver of a popular line of graphics cards.

</gets off the soapbox>
Comment 8 Jory A. Pratt gentoo-dev 2017-12-04 01:14:18 UTC
(In reply to Thomas Albers from comment #7)
> > > The latest nvidia-drivers-387.22 will cause rare crashes
> > 
> > That's a funny way of looking at it.
> 
> You can crash Firefox *reproducibly* just by visiting Reddit (and many other
> sites). It's a very serious bug, the stable release of a mainline webbrowser
> not playing nicely with the latest driver of a popular line of graphics
> cards.
> 
> </gets off the soapbox>

You comments are not needed. If they are not gonna add to the solution please leave them behind. Noone is forcing you to use a closed source driver, you are welcome to patch the build yourself until I or another mozilla team member has time to address the issue.
Comment 9 Thomas Albers 2017-12-07 20:25:30 UTC
The bug is triggered when the graphics driver returns a GLSL version > 4.50. GLSL version 4.60 is part of the standard since July 2017. It is not only recent Nvidia drivers that crash affected versions of Firefox, any graphics driver declaring GLSL 4.60 would do so.

The esr branch being incompatible with recent graphics drivers is a serious usability issue.

The above patch can be applied to 52.4 and 52.5 and fixes the problem. It should be in the tree already, there is no reason to wait for the official channels.
Comment 10 Jory A. Pratt gentoo-dev 2017-12-11 04:14:25 UTC
Has been addressed in 52.5.2 which is now in the tree.
Comment 11 Tango 2017-12-11 22:16:12 UTC
(In reply to Jory A. Pratt from comment #10)
> Has been addressed in 52.5.2 which is now in the tree.

Thanks

Will this also apply to the seamonkey web browser? Or do I continue to apply the above patch until an official fix for that browser is out?
Comment 12 Krzysztof Kołodziejczyk 2017-12-22 04:43:01 UTC
The problem is still reproducible in www-client/firefox-bin-52.5.2 which is latest stable firefox-bin in default/linux/amd64/17.0/desktop/plasma/systemd. Possibly =x11-drivers/nvidia-drivers-387.22 should block <www-client/firefox-bin-57.0.1.