Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 639214 - app-editors/xemacs-21.4.24: xemacs hangs during build
Summary: app-editors/xemacs-21.4.24: xemacs hangs during build
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: XEmacs team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-29 18:45 UTC by Rolf Eike Beer
Modified: 2017-12-11 21:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,41.47 KB, text/plain)
2017-11-29 18:46 UTC, Rolf Eike Beer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rolf Eike Beer 2017-11-29 18:45:57 UTC
During build this command is called, which hangs forever:

  ./xemacs -nd -batch -l /var/tmp/portage/app-editors/xemacs-21.4.24/work/xemacs-21.4.24/src/../lisp/update-elc.el

Portage 2.3.8 (python 2.7.14-final-0, default/linux/sparc/13.0, gcc-5.4.0, glibc-2.25-r9, 4.14.2 sparc64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.14.2-sparc64-sun4v-with-gentoo-2.3
KiB Mem:    33133616 total,  13012432 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Wed, 29 Nov 2017 09:15:01 +0000
Head commit of repository gentoo: e7434ec7eeb4b4be5cd53cebba9576f940b076e9
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28.1 p1.0) 2.28.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14::gentoo, 3.4.5::gentoo, 3.5.4::gentoo, 3.6.3-r1::gentoo
dev-util/cmake:           3.8.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.34.9::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.10.3-r2::gentoo, 1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.15.1-r1::gentoo
sys-devel/binutils:       2.28.1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r9::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="sparc"
ACCEPT_LICENSE="* -@EULA"
CBUILD="sparc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=niagara2 -pipe"
CHOST="sparc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /etc/omega.conf /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -mcpu=niagara2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS=""
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j20"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl berkdb big-endian bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 modules ncurses nls nptl openmp pam pcre readline session sparc ssl tcpd unicode xattr zlib" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="fbdev glint mga r128 radeon dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always
Comment 1 Rolf Eike Beer 2017-11-29 18:46:16 UTC
Created attachment 507210 [details]
build.log
Comment 2 Mats Lidell gentoo-dev 2017-12-02 08:58:14 UTC
I don't have access to sparc arch but will try to recreate on amd or x86 to see if it affects the build there.
Comment 3 Rolf Eike Beer 2017-12-02 09:19:00 UTC
It eats one CPU when it hangs. Can gdb return an interesting backtrace here given that it is likely some lisp code involved?
Comment 4 Mats Lidell gentoo-dev 2017-12-02 22:44:15 UTC
When building now on x86 I get the same error so I have something to go on.
Comment 5 Larry the Git Cow gentoo-dev 2017-12-10 12:39:36 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=de27d8e5c53b1aaca10875b5fe5f5a19a7a9dcaf

commit de27d8e5c53b1aaca10875b5fe5f5a19a7a9dcaf
Author:     Mats Lidell <matsl@gentoo.org>
AuthorDate: 2017-12-10 12:34:21 +0000
Commit:     Mats Lidell <matsl@gentoo.org>
CommitDate: 2017-12-10 12:35:20 +0000

    app-editors/xemacs: Use system malloc and -no-pie
    
    For 21.4 use system malloc on all architectures. For both 21.4 and 21.5 use -no-pie option
    since xemacs can't be built with positions indipendent code yet. This is for adopting
    to the 17.0 profiles which defaults to use PIE.
    
    Bug: https://bugs.gentoo.org/639214
    Bug: https://bugs.gentoo.org/639508
    Bug: https://bugs.gentoo.org/639642
    Package-Manager: Portage-2.3.13, Repoman-2.3.3

 app-editors/xemacs/xemacs-21.4.24-r1.ebuild | 18 +++++++-----------
 app-editors/xemacs/xemacs-21.4.24.ebuild    | 18 +++++++-----------
 app-editors/xemacs/xemacs-21.5.34-r4.ebuild |  9 ++++++---
 3 files changed, 20 insertions(+), 25 deletions(-)}
Comment 6 Mats Lidell gentoo-dev 2017-12-11 21:51:49 UTC
The updated xemacs-21.4.24.ebuild solves the problem for amd64 and x86. Feel free to reopen if problem still occurs on sparc.