Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 639030 - app-i18n/scim-1.4.17 stable request
Summary: app-i18n/scim-1.4.17 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: CJK Team
URL:
Whiteboard: Was: app-i18n/scim-1.4.14[gtk3]: buil...
Keywords: STABLEREQ
: 639100 (view as bug list)
Depends on:
Blocks: gcc-6
  Show dependency tree
 
Reported: 2017-11-28 06:27 UTC by Rolf Eike Beer
Modified: 2018-03-21 05:53 UTC (History)
3 users (show)

See Also:
Package list:
app-i18n/scim-1.4.17
Runtime testing required: ---
stable-bot: sanity-check+


Attachments
build.log (build.log,44.32 KB, text/plain)
2017-11-28 06:29 UTC, Rolf Eike Beer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rolf Eike Beer 2017-11-28 06:27:56 UTC
scim_debug.cpp:53:1: error: narrowing conversion of ‘-1’ from ‘int’ to ‘scim::uint32 {aka unsigned int}’ inside { } [-Wnarrowing]
 };
 ^
make[2]: *** [Makefile:767: scim_debug.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
In file included from /usr/lib/gcc/sparc-unknown-linux-gnu/6.4.0/include/g++-v6/bits/stl_algobase.h:64:0,
                 from /usr/lib/gcc/sparc-unknown-linux-gnu/6.4.0/include/g++-v6/bits/char_traits.h:39,
                 from /usr/lib/gcc/sparc-unknown-linux-gnu/6.4.0/include/g++-v6/ios:40,
                 from /usr/lib/gcc/sparc-unknown-linux-gnu/6.4.0/include/g++-v6/ostream:38,
                 from /usr/lib/gcc/sparc-unknown-linux-gnu/6.4.0/include/g++-v6/iostream:39,
                 from scim.h:193,
                 from scim_backend.cpp:33:
/usr/lib/gcc/sparc-unknown-linux-gnu/6.4.0/include/g++-v6/bits/stl_pair.h: In instantiation of ‘struct std::pair<const std::__cxx11::basic_string<char>, scim::Pointer<scim::IMEngineFactoryBase> >’:
scim_backend.cpp:117:82:   required from here
/usr/lib/gcc/sparc-unknown-linux-gnu/6.4.0/include/g++-v6/bits/stl_pair.h:288:17: error: ‘constexpr std::pair<_T1, _T2>::pair(const std::pair<_T1, _T2>&) [with _T1 = const std::__cxx11::basic_string<char>; _T2 = scim::Pointer<scim::IMEngineFactoryBase>]’ declared to take const reference, but implicit declaration would take non-const
       constexpr pair(const pair&) = default;
                 ^~~~
libtool: compile:  sparc-unknown-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -I.. -I../src -I.. -I../src -I../intl -DSCIM_DATADIR=\"/usr/share/scim\" -DSCIM_LOCALEDIR=\"/usr/share/locale\" -DSCIM_SYSCONFDIR=\"/etc\" -DSCIM_LIBEXECDIR=\"/usr/lib/scim-1.0\" -DSCIM_ICONDIR=\"/usr/share/scim/icons\" -DSCIM_MODULE_PATH=\"/usr/lib/scim-1.0\" -O2 -mcpu=niagara2 -pipe -c scim_connection.cpp -o scim_connection.o >/dev/null 2>&1
libtool: compile:  sparc-unknown-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -I.. -I../src -I.. -I../src -I../intl -DSCIM_DATADIR=\"/usr/share/scim\" -DSCIM_LOCALEDIR=\"/usr/share/locale\" -DSCIM_SYSCONFDIR=\"/etc\" -DSCIM_LIBEXECDIR=\"/usr/lib/scim-1.0\" -DSCIM_ICONDIR=\"/usr/share/scim/icons\" -DSCIM_MODULE_PATH=\"/usr/lib/scim-1.0\" -O2 -mcpu=niagara2 -pipe -c scim_config_module.cpp -o scim_config_module.o >/dev/null 2>&1
In file included from /usr/lib/gcc/sparc-unknown-linux-gnu/6.4.0/include/g++-v6/bits/stl_algobase.h:64:0,
                 from /usr/lib/gcc/sparc-unknown-linux-gnu/6.4.0/include/g++-v6/bits/char_traits.h:39,
                 from /usr/lib/gcc/sparc-unknown-linux-gnu/6.4.0/include/g++-v6/ios:40,
                 from /usr/lib/gcc/sparc-unknown-linux-gnu/6.4.0/include/g++-v6/ostream:38,
                 from /usr/lib/gcc/sparc-unknown-linux-gnu/6.4.0/include/g++-v6/iostream:39,
                 from scim.h:193,
                 from scim_frontend.cpp:28:
/usr/lib/gcc/sparc-unknown-linux-gnu/6.4.0/include/g++-v6/bits/stl_pair.h: In instantiation of ‘struct std::pair<const int, scim::Pointer<scim::IMEngineInstanceBase> >’:
scim_frontend.cpp:57:46:   required from here
/usr/lib/gcc/sparc-unknown-linux-gnu/6.4.0/include/g++-v6/bits/stl_pair.h:288:17: error: ‘constexpr std::pair<_T1, _T2>::pair(const std::pair<_T1, _T2>&) [with _T1 = const int; _T2 = scim::Pointer<scim::IMEngineInstanceBase>]’ declared to take const reference, but implicit declaration would take non-const
       constexpr pair(const pair&) = default;
                 ^~~~


Reproducible: Always
Comment 1 Rolf Eike Beer 2017-11-28 06:28:36 UTC
Portage 2.3.8 (python 2.7.14-final-0, default/linux/sparc/13.0, gcc-6.4.0, glibc-2.25-r9, 4.14.2 sparc64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.14.2-sparc64-sun4v-with-gentoo-2.3
KiB Mem:    33133616 total,  18649480 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Tue, 28 Nov 2017 01:15:01 +0000
Head commit of repository gentoo: 5d1cfbfb0969d506e72d4bdf1bdf1f888a92d794
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28.1 p1.0) 2.28.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14::gentoo, 3.4.5::gentoo, 3.5.4::gentoo
dev-util/cmake:           3.8.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.34.9::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.10.3-r2::gentoo, 1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15.1-r1::gentoo
sys-devel/binutils:       2.28.1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo, 6.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r9::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="sparc"
ACCEPT_LICENSE="* -@EULA"
CBUILD="sparc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=niagara2 -pipe"
CHOST="sparc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /etc/omega.conf /usr/share/gnupg/qualified.txt /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -mcpu=niagara2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS=""
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j20"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl berkdb big-endian bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 modules ncurses nls nptl openmp pam pcre readline session sparc ssl tcpd unicode xattr zlib" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="fbdev glint mga r128 radeon dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Rolf Eike Beer 2017-11-28 06:29:31 UTC
Created attachment 506902 [details]
build.log
Comment 3 Pacho Ramos gentoo-dev 2017-11-28 19:13:00 UTC
This was fixed by upstream in newer versions, please try with 1.4.17
Comment 4 Rolf Eike Beer 2017-11-28 20:25:42 UTC
Confirmed, builds fine for me. Stable request?
Comment 5 Jeroen Roovers gentoo-dev 2017-12-02 21:10:48 UTC
*** Bug 639100 has been marked as a duplicate of this bug. ***
Comment 6 Sergei Trofimovich gentoo-dev 2017-12-02 21:42:12 UTC
hppa stable (thanks to Rolf Eike Beer)
Comment 7 Sergei Trofimovich gentoo-dev 2017-12-03 10:42:00 UTC
sparc stable (thanks to Rolf Eike Beer)
Comment 8 Tobias Klausmann gentoo-dev 2017-12-16 17:27:10 UTC
Stable on amd64.
Comment 9 Sergei Trofimovich gentoo-dev 2017-12-28 12:00:50 UTC
ppc stable
Comment 10 Sergei Trofimovich gentoo-dev 2017-12-29 12:42:10 UTC
ppc64 stable
Comment 11 Benda Xu gentoo-dev 2018-01-16 04:45:17 UTC
Any progress in stablizing x86?

arm arch team is dysfunctional, now.  abandon the stable keyword of arm.
Comment 12 Tobias Klausmann gentoo-dev 2018-01-29 08:34:48 UTC
Stable on alpha.
Comment 13 Thomas Deutschmann gentoo-dev Security 2018-02-06 18:38:37 UTC
x86 stable
Comment 14 Markus Meier gentoo-dev 2018-03-21 05:53:11 UTC
arm stable, all arches done.