Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 638666 - sys-devel/gcc-7.2.0 - checking host system type... configure: error: system bdw-gc required but not found
Summary: sys-devel/gcc-7.2.0 - checking host system type... configure: error: system b...
Status: RESOLVED DUPLICATE of bug 617788
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-24 06:34 UTC by Ognian Tenchev
Modified: 2018-01-12 00:30 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_638666.txt,8.05 KB, text/plain)
2017-11-24 06:34 UTC, Ognian Tenchev
Details
gcc-build-logs.tar.bz2 (gcc-build-logs.tar.bz2,411.14 KB, application/x-bzip)
2017-11-24 06:35 UTC, Ognian Tenchev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ognian Tenchev 2017-11-24 06:34:05 UTC
Created attachment 506252 [details]
emerge --info

emerging gcc-7.2.0 failed to build with error:
checking host system type... configure: error: system bdw-gc required but not found
Comment 1 Ognian Tenchev 2017-11-24 06:35:16 UTC
Created attachment 506254 [details]
gcc-build-logs.tar.bz2
Comment 2 Bernie Hackett 2017-12-04 23:33:21 UTC
Assuming you're on a multilib system, add these lines to /etc/portage/package.use:

dev-libs/libatomic_ops abi_x86_32
dev-libs/boehm-gc abi_x86_32

Then rebuild libatomic_ops and boehm-gc. The problem is boehm-gc is needed for objc-gc. It used to be bundled in gcc, but was removed in gcc 7.1.

See the last few comments of https://bugs.gentoo.org/617788
Comment 3 Ognian Tenchev 2017-12-05 05:07:42 UTC
Thanks, that works for me
Comment 4 Andreas K. Hüttel gentoo-dev 2017-12-16 23:03:56 UTC

*** This bug has been marked as a duplicate of bug 617788 ***