Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 638640 - net-fs/samba-4.7.3 should depend on dev-libs/jansson
Summary: net-fs/samba-4.7.3 should depend on dev-libs/jansson
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's SAMBA Team
URL:
Whiteboard:
Keywords:
: 679756 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-11-23 23:20 UTC by cyrillic
Modified: 2020-01-07 22:15 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cyrillic 2017-11-23 23:20:51 UTC
I noticed that emerge --depclean wanted to remove dev-libs/jansson

Reproducible: Always

Actual Results:  
 * In order to avoid breakage of link level dependencies, one or more
 * packages will not be removed. This can be solved by rebuilding the
 * packages that pulled them in.
 * 
 *   dev-libs/jansson-2.10 pulled in by:
 *     net-fs/samba-4.7.3 needs libjansson.so.4
 *     net-libs/nghttp2-1.27.0 needs libjansson.so.4
 *     net-misc/networkmanager-1.10.0 needs libjansson.so.4
 * 
 *   x11-libs/libcryptui-3.12.2-r1 pulled in by:
 *     mail-client/evolution-3.27.2 needs libcryptui.so.0
 * 
>>> Adding lib providers to graph...
Comment 1 Brian Evans Gentoo Infrastructure gentoo-dev 2018-03-14 13:20:11 UTC
I've also hit this automagic dependency which drives the "auth event notification" option which is primary used in the samba test suite. (At least according to 'man 5 smb.conf'.)
Comment 2 Ben Kohler gentoo-dev 2020-01-07 22:14:37 UTC
*** Bug 679756 has been marked as a duplicate of this bug. ***
Comment 3 Ben Kohler gentoo-dev 2020-01-07 22:15:07 UTC
Newer samba ebuilds have this dependency, we will stabilize one soon