Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 638172 - media-libs/babl-0.1.18: test failures on sparc (floatclamp, float-to-8bit)
Summary: media-libs/babl-0.1.18: test failures on sparc (floatclamp, float-to-8bit)
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sergey Torokhov
URL: https://gitlab.gnome.org/GNOME/gegl/i...
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks: unaligned-access 641322
  Show dependency tree
 
Reported: 2017-11-19 19:55 UTC by Rolf Eike Beer
Modified: 2020-11-04 15:12 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,97.40 KB, text/plain)
2017-11-19 19:55 UTC, Rolf Eike Beer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rolf Eike Beer 2017-11-19 19:55:27 UTC
This is the same on 0.1.12:

PASS: babl_class_name
PASS: sanity
PASS: hsva
PASS: rgb_to_bgr
PASS: extract
PASS: rgb_to_ycbcr
PASS: nop
../test-driver: line 107: 40404 Bus error               "$@" > $log_file 2>&1
PASS: srgb_to_lab_u8
FAIL: float-to-8bit
PASS: hsl
../test-driver: line 107: 40406 Bus error               "$@" > $log_file 2>&1
PASS: types
FAIL: floatclamp
PASS: n_components_cast
PASS: cairo-RGB24
PASS: models
PASS: palette
PASS: grayscale_to_rgb
PASS: concurrency-stress-test
PASS: n_components

The logs of the individual tests do not contain anything useful.

Portage 2.3.8 (python 2.7.14-final-0, default/linux/sparc/13.0, gcc-5.4.0, glibc-2.25-r9, 4.13.8 sparc64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.13.8-sparc64-sun4v-with-gentoo-2.3
KiB Mem:    33133648 total,  20667648 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sun, 19 Nov 2017 17:45:01 +0000
Head commit of repository gentoo: d57d14678aacfc4a9559f9d6679dbdcbba85eb26
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28.1 p1.0) 2.28.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.9.6::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.34.8::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.15.1-r1::gentoo
sys-devel/binutils:       2.28.1::gentoo
sys-devel/gcc:            3.4.6-r2::gentoo, 4.1.2::gentoo, 4.2.4-r1::gentoo, 4.3.6-r1::gentoo, 4.4.7::gentoo, 4.5.4::gentoo, 4.6.4::gentoo, 4.7.4::gentoo, 4.8.5::gentoo, 4.9.4::gentoo, 5.4.0-r3::gentoo, 6.4.0::gentoo, 7.2.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r9::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage
    priority: -1000

dakon
    location: /usr/local/portage
    masters: gentoo
    priority: 100

ACCEPT_KEYWORDS="sparc"
ACCEPT_LICENSE="* -@EULA"
CBUILD="sparc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=niagara2 -pipe"
CHOST="sparc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -mcpu=niagara2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS=""
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j20"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl big-endian bzip2 cli cracklib crypt curl cxx dri fortran gdbm iconv ipv6 modules ncurses nptl openmp pam pcre readline session sparc ssl tcpd unicode xattr zlib" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" L10N="en de" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="fbdev glint mach64 mga r128 radeon sunbw2 suncg14 suncg3 suncg6 sunffb sunleo tdfx dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always
Comment 1 Rolf Eike Beer 2017-11-19 19:55:53 UTC
Created attachment 505000 [details]
build.log
Comment 2 Rolf Eike Beer 2018-04-19 16:20:19 UTC
Probably this one: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=806208
Comment 3 Pacho Ramos gentoo-dev 2018-06-20 08:50:09 UTC
Can you retry with 0.1.50? In Debian bug report they were applying a patch for this in older versions, but not for that one, maybe it got fixed by upstream
Comment 4 Rolf Eike Beer 2018-06-20 16:47:49 UTC
No, this is still completely broken on sparc. Debian just used the automated Gnome Bugzilla mail as "fixed upstream", but instead just the bugzilla bug was closed because Gnome moved to Gitlab. There are more recent patches that try to fix the unaligned accesses during image conversions (like https://gitlab.gnome.org/GNOME/babl/issues/1), but e.g. bug 638388 has another crash. I fear that the sort of problems will continue as the whole lib consists of casts of all sorts. Without upstream really caring I fear we are lost here and should just mask it on sparc as broken.
Comment 5 Pacho Ramos gentoo-dev 2019-11-19 11:14:18 UTC
Maybe it will be better to drop the keyword indeed
Comment 6 Sergey Torokhov 2020-11-04 15:12:08 UTC
Package was sparc un-keyworded due to multiple test fails.