Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 637450 (CVE-2017-16808) - net-analyzer/tcpdump: buffer over-read in print-aoe.c, lookup_emem and addrtoname.c
Summary: net-analyzer/tcpdump: buffer over-read in print-aoe.c, lookup_emem and addrto...
Status: CONFIRMED
Alias: CVE-2017-16808
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL: https://github.com/the-tcpdump-group/...
Whiteboard: B3 [upstream/ebuild cve]
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-14 03:25 UTC by D'juan McDonald (domhnall)
Modified: 2019-08-21 19:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description D'juan McDonald (domhnall) 2017-11-14 03:25:09 UTC
CVE-2017-16080(https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-16808):
tcpdump 4.9.2 has a heap-based buffer over-read related to aoe_print in print-aoe.c and lookup_emem in addrtoname.c

@maintainers, bug will be addressed in a future release of tcpdump. Proceed as necessary, thank you.

Gentoo Security Padawan
(jmbailey/mbailey_j)
Comment 1 D'juan McDonald (domhnall) 2019-08-21 19:38:42 UTC
Update: fixes in since (June 5, 2019)

Upstream commit: https://github.com/the-tcpdump-group/tcpdump/commit/46aead6c5265e8ae376d2cf274fb2b5195cd6b57