Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 636746 - sys-apps/coreutils-8.28-r1 : ERROR: tests/rm/deep-2.sh
Summary: sys-apps/coreutils-8.28-r1 : ERROR: tests/rm/deep-2.sh
Status: RESOLVED DUPLICATE of bug 413621
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2017-11-06 21:27 UTC by Toralf Förster
Modified: 2018-05-21 11:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.93 KB, text/plain)
2017-11-06 21:27 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,212.01 KB, text/plain)
2017-11-06 21:27 UTC, Toralf Förster
Details
environment (environment,128.99 KB, text/plain)
2017-11-06 21:27 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,40.46 KB, application/x-bzip)
2017-11-06 21:27 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,289.09 KB, application/x-bzip)
2017-11-06 21:27 UTC, Toralf Förster
Details
sys-apps:coreutils-8.28-r1:20171106-203145.log.bz2 (sys-apps:coreutils-8.28-r1:20171106-203145.log.bz2,50.38 KB, application/x-bzip)
2017-11-06 21:27 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,81.26 KB, application/x-bzip)
2017-11-06 21:27 UTC, Toralf Förster
Details
tests.tbz2 (tests.tbz2,558.87 KB, application/x-bzip)
2017-11-06 21:27 UTC, Toralf Förster
Details
emerge-info.txt (emerge-info.txt,15.77 KB, text/plain)
2018-05-21 07:33 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,28.19 KB, text/plain)
2018-05-21 07:33 UTC, Toralf Förster
Details
environment (environment,124.95 KB, text/plain)
2018-05-21 07:33 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.83 KB, application/x-bzip)
2018-05-21 07:33 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,302.64 KB, application/x-bzip)
2018-05-21 07:33 UTC, Toralf Förster
Details
sys-apps:coreutils-8.29:20180520-233044.log.bz2 (sys-apps:coreutils-8.29:20180520-233044.log.bz2,52.87 KB, application/x-bzip)
2018-05-21 07:33 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,82.12 KB, application/x-bzip)
2018-05-21 07:33 UTC, Toralf Förster
Details
tests.tbz2 (tests.tbz2,568.04 KB, application/x-bzip)
2018-05-21 07:33 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-11-06 21:27:09 UTC
PASS: tests/rm/deep-1.sh
deep-2.sh: set-up failure: 
ERROR: tests/rm/deep-2.sh
PASS: tests/rm/dir-no-w.sh
PASS: tests/rm/dir-nonrecur.sh
PASS: tests/rm/dot-rel.sh

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 13.0-desktop_abi32+64-test_20171029-135004

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.4.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.6 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy3 (fallback)
  [5]   pypy (fallback)

java-config:
The following VMs are available for generation-2:
1)	IcedTea JDK 7.2.6.11 [icedtea-7]
2)	IcedTea JDK 3.6.0 [icedtea-8]
3)	IcedTea JDK 7.2.6.11 [icedtea-bin-7]
*)	IcedTea JDK 3.6.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-7 
  [2]   icedtea-8 
  [3]   icedtea-bin-7 
  [4]   icedtea-bin-8  system-vm

emerge -qpv sys-apps/coreutils
[ebuild     U ] sys-apps/coreutils-8.28-r1 [8.28] USE="acl nls xattr -caps -gmp -hostname -kill -multicall (-selinux) -static {-test%} -vanilla"
Comment 1 Toralf Förster gentoo-dev 2017-11-06 21:27:12 UTC
Created attachment 502856 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-11-06 21:27:15 UTC
Created attachment 502858 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2017-11-06 21:27:18 UTC
Created attachment 502860 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2017-11-06 21:27:21 UTC
Created attachment 502862 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2017-11-06 21:27:24 UTC
Created attachment 502864 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-11-06 21:27:27 UTC
Created attachment 502866 [details]
sys-apps:coreutils-8.28-r1:20171106-203145.log.bz2
Comment 7 Toralf Förster gentoo-dev 2017-11-06 21:27:30 UTC
Created attachment 502868 [details]
temp.tbz2
Comment 8 Toralf Förster gentoo-dev 2017-11-06 21:27:34 UTC
Created attachment 502870 [details]
tests.tbz2
Comment 9 Thomas Deutschmann gentoo-dev Security 2017-11-06 21:35:29 UTC
From sys-apps:coreutils-8.28-r1:20171106-203145.log.bz2:

>  * FEATURES:   network-sandbox preserve-libs sandbox test userpriv usersandbox
                                                                     ^^^^^^^^^^^^

> >>> Source compiled.
> >>> Test phase: sys-apps/coreutils-8.28-r1
>  * You are emerging coreutils-8.28 with 'usersandbox' enabled. Expect some test failures or emerge with 'FEATURES=-usersandbox'!
> make -j1 -j1 -k check 


FEATURES=usersandbox isn't supported anymore. See commit msg https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0edff67f453a7509c08fce538d3da9c947daa433 for details.
Comment 10 Thomas Deutschmann gentoo-dev Security 2017-11-06 21:37:31 UTC
Actually also a duplicate of bug 413621.

*** This bug has been marked as a duplicate of bug 413621 ***
Comment 11 Toralf Förster gentoo-dev 2018-05-21 07:33:18 UTC
got at the unstable amd64 chroot image 17.0-desktop-gnome-systemd_test_20180520-112305 this : ERROR: tests/rm/deep-2.sh
Comment 12 Toralf Förster gentoo-dev 2018-05-21 07:33:22 UTC
Created attachment 532442 [details]
emerge-info.txt
Comment 13 Toralf Förster gentoo-dev 2018-05-21 07:33:25 UTC
Created attachment 532444 [details]
emerge-history.txt
Comment 14 Toralf Förster gentoo-dev 2018-05-21 07:33:28 UTC
Created attachment 532446 [details]
environment
Comment 15 Toralf Förster gentoo-dev 2018-05-21 07:33:32 UTC
Created attachment 532448 [details]
etc.portage.tbz2
Comment 16 Toralf Förster gentoo-dev 2018-05-21 07:33:35 UTC
Created attachment 532450 [details]
logs.tbz2
Comment 17 Toralf Förster gentoo-dev 2018-05-21 07:33:38 UTC
Created attachment 532452 [details]
sys-apps:coreutils-8.29:20180520-233044.log.bz2
Comment 18 Toralf Förster gentoo-dev 2018-05-21 07:33:41 UTC
Created attachment 532454 [details]
temp.tbz2
Comment 19 Toralf Förster gentoo-dev 2018-05-21 07:33:44 UTC
Created attachment 532456 [details]
tests.tbz2
Comment 20 Thomas Deutschmann gentoo-dev Security 2018-05-21 11:01:00 UTC
> >>> Source compiled.
> >>> Test phase: sys-apps/coreutils-8.29
>  * You are emerging coreutils-8.29 with 'usersandbox' enabled. Expect some test failures or emerge with 'FEATURES=-usersandbox'!

Our sandbox has a problem with nested folders. This is known. I don't understand why you have re-open this issue. So I am closing again as dupe of bug 413621.

If you think the solution is wrong please re-open with a comment explaining why you are reopening...

*** This bug has been marked as a duplicate of bug 413621 ***
Comment 21 Toralf Förster gentoo-dev 2018-05-21 11:25:50 UTC
(In reply to Thomas Deutschmann from comment #20)
Hhm, I just translated "FIXED" into - "problem solved" - wouldn't for the remaining issue of the sandbox an open bug being helpful then?