Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 636326 - media-libs/mesa-17.1.8: test failures on sparc (glsl/tests/cache-test, glsl/tests/warnings-test.sh, glsl/glcpp/tests/glcpp-test.sh)
Summary: media-libs/mesa-17.1.8: test failures on sparc (glsl/tests/cache-test, glsl/t...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords: TESTFAILURE
: 670338 (view as bug list)
Depends on:
Blocks: 629244
  Show dependency tree
 
Reported: 2017-11-02 20:51 UTC by Rolf Eike Beer
Modified: 2018-11-15 22:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build and test logs (mesa-sparc.tar.xz,79.05 KB, application/x-xz)
2017-11-02 20:52 UTC, Rolf Eike Beer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rolf Eike Beer 2017-11-02 20:51:13 UTC
Portage 2.3.8 (python 2.7.14-final-0, default/linux/sparc/13.0, gcc-5.4.0, glibc-2.25-r8, 4.13.8 sparc64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.13.8-sparc64-sun4v-with-gentoo-2.3
KiB Mem:    33133648 total,  17873376 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Thu, 02 Nov 2017 01:15:01 +0000
Head commit of repository gentoo: 67e214453823f189c1f835335bb3f50eff6ccccc
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28.1 p1.0) 2.28.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.8.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.32.1::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.28.1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r8::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="sparc"
ACCEPT_LICENSE="* -@EULA"
CBUILD="sparc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=niagara2 -pipe"
CHOST="sparc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/qmail/alias /var/qmail/control /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -mcpu=niagara2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS=""
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j20"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl berkdb big-endian bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 modules ncurses nls nptl openmp pam pcre readline session sparc ssl tcpd unicode xattr zlib" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="fbdev glint mach64 mga r128 radeon sunbw2 suncg14 suncg3 suncg6 sunffb sunleo tdfx dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

media-libs/mesa-17.1.8::gentoo was built with the following:
USE="bindist classic d3d9 dri3 egl gallium gbm gles1 gles2 nptl osmesa pax_kernel pic wayland xa -debug (-llvm) (-opencl) (-openmax) (-selinux) (-unwind) (-vaapi) (-valgrind) (-vdpau) (-vulkan) (-xvmc)" VIDEO_CARDS="radeon (-freedreno) (-i915) (-i965) (-imx) (-intel) (-nouveau) -r100 -r200 -r300 -r600 (-radeonsi) (-vc4) (-vivante) (-vmware)"

Reproducible: Always
Comment 1 Rolf Eike Beer 2017-11-02 20:52:26 UTC
Created attachment 501956 [details]
Build and test logs
Comment 2 Matt Turner gentoo-dev 2017-11-26 05:08:20 UTC
The cache-test failure should now be fixed upstream. I expect the fix to be in 17.2.7 and 17.3.0.
Comment 3 Rolf Eike Beer 2017-11-26 09:20:17 UTC
Is that a test error or does the code misbehave? If it is the former, should it be disabled in the ebuild to avoid confusion?
Comment 4 Matt Turner gentoo-dev 2017-11-26 19:07:53 UTC
(In reply to Rolf Eike Beer from comment #3)
> Is that a test error or does the code misbehave? If it is the former, should
> it be disabled in the ebuild to avoid confusion?

It was both. The test did something that wasn't endian-safe, and while debugging that I found out that the SHA1 implementation had a trivial bug in it that caused it to be broken on big endian as well.
Comment 5 Rolf Eike Beer 2018-04-07 21:18:53 UTC
Same with 17.3.8.
Comment 6 Rolf Eike Beer 2018-04-07 21:22:16 UTC
Correction: the latter 2 are the same with 17.3.8, the first one is fixed then.
Comment 7 Rolf Eike Beer 2018-08-19 10:21:43 UTC
state with 18.1.6:

FAIL: glsl/tests/warnings-test.sh
FAIL: glsl/glcpp/tests/glcpp-test.sh
FAIL: glsl/glcpp/tests/glcpp-test-cr-lf.sh
Comment 8 Matt Turner gentoo-dev 2018-11-07 21:27:45 UTC
*** Bug 670338 has been marked as a duplicate of this bug. ***
Comment 9 Matt Turner gentoo-dev 2018-11-12 00:30:03 UTC
It's an alignment issue. I'm working on it.
Comment 10 Matt Turner gentoo-dev 2018-11-15 22:45:03 UTC
Fixed in 18.2.5. Fixes will probably be in 18.3.0_rc3.