Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 635418 - net-dns/avahi-0.7-r1 stable request
Summary: net-dns/avahi-0.7-r1 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 622648
Blocks: 525884
  Show dependency tree
 
Reported: 2017-10-25 13:32 UTC by Pacho Ramos
Modified: 2019-01-02 02:42 UTC (History)
1 user (show)

See Also:
Package list:
net-dns/avahi-0.7-r1
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2017-10-25 13:32:29 UTC
It seems to work ok for me for a long time, maybe we could stabilize it finally

Thanks
Comment 1 Anthony Basile gentoo-dev 2017-10-25 13:37:12 UTC
Should be good to go

KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"


@pacho, what are we doing about sparc?  Has it been dropped to ~arch?  I didn't include it in the CC list, please add it should be there.
Comment 2 Stabilization helper bot gentoo-dev 2017-10-25 14:00:57 UTC
An automated check of this bug failed - repoman reported dependency errors (9 lines truncated): 

> dependency.bad net-dns/avahi/avahi-0.7.ebuild: DEPEND: hppa(default/linux/hppa/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad net-dns/avahi/avahi-0.7.ebuild: RDEPEND: hppa(default/linux/hppa/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad net-dns/avahi/avahi-0.7.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
Comment 3 Matt Turner gentoo-dev 2017-10-25 18:22:49 UTC
(In reply to Anthony Basile from comment #1)
> @pacho, what are we doing about sparc?  Has it been dropped to ~arch?  I
> didn't include it in the CC list, please add it should be there.

No, just its profile has been made "exp" so repoman doesn't notice problems. It's nice to include it in stabilization bugs nonetheless.
Comment 4 Pacho Ramos gentoo-dev 2017-10-25 19:19:22 UTC
Ah, ok, I thought it was moved to be handled like s390, sh... i.e, people from that arch teams go ahead stabilizing directly when they need/prefer 

If you want it to be still CCed, maybe you could contact bugzilla to move it back to the group of stable arches (I mean in terms of "bugzilla" only) as, otherwise, I am sure many maintainers won't CC you (like it happens for the other "testing only" arches)
Comment 5 Manuel Rüger (RETIRED) gentoo-dev 2017-10-25 23:43:41 UTC
Stable on amd64
Comment 6 Stabilization helper bot gentoo-dev 2017-10-26 00:02:07 UTC
An automated check of this bug failed - repoman reported dependency errors (9 lines truncated): 

> dependency.bad net-dns/avahi/avahi-0.7.ebuild: DEPEND: hppa(default/linux/hppa/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad net-dns/avahi/avahi-0.7.ebuild: RDEPEND: hppa(default/linux/hppa/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad net-dns/avahi/avahi-0.7.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
Comment 7 Stabilization helper bot gentoo-dev 2017-10-26 07:01:05 UTC
An automated check of this bug failed - repoman reported dependency errors (9 lines truncated): 

> dependency.bad net-dns/avahi/avahi-0.7.ebuild: DEPEND: hppa(default/linux/hppa/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad net-dns/avahi/avahi-0.7.ebuild: RDEPEND: hppa(default/linux/hppa/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad net-dns/avahi/avahi-0.7.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
Comment 8 Thomas Deutschmann gentoo-dev Security 2017-10-26 17:39:05 UTC
x86 stable
Comment 9 Stabilization helper bot gentoo-dev 2017-10-26 18:02:38 UTC
An automated check of this bug failed - repoman reported dependency errors (9 lines truncated): 

> dependency.bad net-dns/avahi/avahi-0.7.ebuild: DEPEND: hppa(default/linux/hppa/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad net-dns/avahi/avahi-0.7.ebuild: RDEPEND: hppa(default/linux/hppa/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad net-dns/avahi/avahi-0.7.ebuild: DEPEND: ia64(default/linux/ia64/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
Comment 10 Mattia Rossi 2017-10-27 08:06:50 UTC
Maybe on a stable system it works, but on ~amd64 I can't compile it due to issues with gobject-introspection when calling g-ir-scanner.

Using dev-libs/gobject-introspection-1.52.1, dev-libs/gobject-introspection-common-1.52.1, dev-libs/glib-2.52.3, dev-python/pygobject-3.24.1, dev-lang/python 2.7.14 3.4.6 and 3.6.3, PYTHON_TARGETS="python2_7 python3_6", PYTHON_SINGLE_TARGET="python3_6"

The failing command is:

CPPFLAGS="" CFLAGS="-O2 -pipe -fstack-protector -std=c99 -Wall -W -Wex
tra -pedantic -pipe -Wformat -Wold-style-definition -Wdeclaration-afte
r-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -fdiagnostics-show-option -Wno-cast-qual -fno-strict-aliasing" LDFLAGS="-Wl,-O1 -Wl,--as-needed" CC="x86_64-pc-linux-gnu-gcc" PKG_CONFIG="/usr/bin/x86_64-pc-linux-gnu-pkg-config" DLLTOOL="false"  /usr/bin/g-ir-scanner  --add-include-path=. --namespace=Avahi --nsversion=0.6 --libtool="/bin/sh ../libtool"  --include=GObject-2.0 --include=AvahiCore-0.6    --library=libavahi-gobject.la --strip-prefix=Ga --cflags-begin -I.. '-DDEBUG_TRAP=__asm__("int ")' -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include --cflags-end  ga-client.c ga-client.h ga-entry-group.c ga-entry-group.h ga-enums.h ga-error.c ga-error.h ga-record-browser.c ga-record-browser.h ga-service-browser.c ga-service-browser.h ga-service-resolver.c ga-service-resolver.h signals-marshal.list signals-marshal.h signals-marshal.c ga-client-enumtypes.h ga-client-enumtypes.c ga-entry-group-enumtypes.h ga-entry-group-enumtypes.c ga-enums-enumtypes.h ga-enums-enumtypes.c libavahi-gobject.la --output Avahi-0.6.gir
g-ir-scanner: warning: Option --strip-prefix has been deprecated;
see --identifier-prefix and --symbol-prefix.
Traceback (most recent call last):
  File "/usr/lib64/gobject-introspection/giscanner/cachestore.py", line 186, in load
    data = pickle.load(fd)
EOFError: Ran out of input
Comment 11 Sergei Trofimovich gentoo-dev 2017-10-28 22:35:36 UTC
(In reply to Mattia Rossi from comment #10)
> Maybe on a stable system it works, but on ~amd64 I can't compile it due to
> issues with gobject-introspection when calling g-ir-scanner.
> 
> Using dev-libs/gobject-introspection-1.52.1,
> dev-libs/gobject-introspection-common-1.52.1, dev-libs/glib-2.52.3,
> dev-python/pygobject-3.24.1, dev-lang/python 2.7.14 3.4.6 and 3.6.3,
> PYTHON_TARGETS="python2_7 python3_6", PYTHON_SINGLE_TARGET="python3_6"
> 
> The failing command is:
> 
> CPPFLAGS="" CFLAGS="-O2 -pipe -fstack-protector -std=c99 -Wall -W -Wex
> tra -pedantic -pipe -Wformat -Wold-style-definition -Wdeclaration-afte
> r-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes
> -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow
> -Wendif-labels -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align
> -Wwrite-strings -fdiagnostics-show-option -Wno-cast-qual
> -fno-strict-aliasing" LDFLAGS="-Wl,-O1 -Wl,--as-needed"
> CC="x86_64-pc-linux-gnu-gcc"
> PKG_CONFIG="/usr/bin/x86_64-pc-linux-gnu-pkg-config" DLLTOOL="false" 
> /usr/bin/g-ir-scanner  --add-include-path=. --namespace=Avahi
> --nsversion=0.6 --libtool="/bin/sh ../libtool"  --include=GObject-2.0
> --include=AvahiCore-0.6    --library=libavahi-gobject.la --strip-prefix=Ga
> --cflags-begin -I.. '-DDEBUG_TRAP=__asm__("int ")' -I/usr/include/glib-2.0
> -I/usr/lib64/glib-2.0/include --cflags-end  ga-client.c ga-client.h
> ga-entry-group.c ga-entry-group.h ga-enums.h ga-error.c ga-error.h
> ga-record-browser.c ga-record-browser.h ga-service-browser.c
> ga-service-browser.h ga-service-resolver.c ga-service-resolver.h
> signals-marshal.list signals-marshal.h signals-marshal.c
> ga-client-enumtypes.h ga-client-enumtypes.c ga-entry-group-enumtypes.h
> ga-entry-group-enumtypes.c ga-enums-enumtypes.h ga-enums-enumtypes.c
> libavahi-gobject.la --output Avahi-0.6.gir
> g-ir-scanner: warning: Option --strip-prefix has been deprecated;
> see --identifier-prefix and --symbol-prefix.
> Traceback (most recent call last):
>   File "/usr/lib64/gobject-introspection/giscanner/cachestore.py", line 186,
> in load
>     data = pickle.load(fd)
> EOFError: Ran out of input

Please file a separate bug with more details.
Comment 12 Sergei Trofimovich gentoo-dev 2017-10-28 22:36:34 UTC
ia64 stable. To restore parity with other arches stabled a bunch
of packages as dependencies:

=dev-python/priority-1.3.0
=dev-python/hpack-2.3.0-r1
=dev-python/hyperframe-4.0.1
=dev-python/hyper-h2-2.5.1
=dev-python/constantly-15.1.0
=dev-python/incremental-16.10.1
=dev-python/twisted-16.6.0-r3
=net-dns/avahi-0.7 ia64
Comment 13 Stabilization helper bot gentoo-dev 2017-10-28 23:01:22 UTC
An automated check of this bug failed - repoman reported dependency errors: 

> dependency.bad net-dns/avahi/avahi-0.7.ebuild: DEPEND: hppa(default/linux/hppa/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad net-dns/avahi/avahi-0.7.ebuild: RDEPEND: hppa(default/linux/hppa/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
Comment 14 Sergei Trofimovich gentoo-dev 2017-10-30 22:04:14 UTC
sparc stable (thanks to Rolf Eike Beer)
Comment 15 ernsteiswuerfel 2017-11-27 13:14:07 UTC
Looking good on ppc.

# cat avahi.report 
USE='-autoipd -bookmarks -dbus -doc -gdbm -gtk -gtk3 -howl-compat -introspection -ipv6 -mdnsresponder-compat -mono -nls -python -qt4'  succeeded for =net-dns/avahi-0.7
USE='-autoipd bookmarks dbus -doc gdbm gtk -gtk3 -howl-compat -introspection -ipv6 mdnsresponder-compat -mono -nls -python -qt4'  succeeded for =net-dns/avahi-0.7
USE='-autoipd -bookmarks dbus doc gdbm -gtk gtk3 howl-compat introspection ipv6 mdnsresponder-compat -mono -nls -python -qt4'  succeeded for =net-dns/avahi-0.7
USE='-autoipd bookmarks dbus -doc gdbm gtk gtk3 -howl-compat -introspection -ipv6 mdnsresponder-compat mono -nls -python -qt4'  succeeded for =net-dns/avahi-0.7
USE='-autoipd -bookmarks dbus doc -gdbm gtk gtk3 -howl-compat introspection -ipv6 mdnsresponder-compat mono -nls -python -qt4'  succeeded for =net-dns/avahi-0.7
USE='-autoipd bookmarks dbus -doc gdbm -gtk gtk3 -howl-compat -introspection -ipv6 mdnsresponder-compat -mono -nls python -qt4'  succeeded for =net-dns/avahi-0.7
USE='autoipd bookmarks -dbus doc -gdbm -gtk gtk3 -howl-compat introspection -ipv6 mdnsresponder-compat mono nls python -qt4' : REQUIRED_USE not satisfied (probably)
USE='-autoipd bookmarks -dbus doc -gdbm -gtk gtk3 howl-compat -introspection -ipv6 -mdnsresponder-compat -mono -nls -python qt4' : REQUIRED_USE not satisfied (probably)
USE='autoipd bookmarks dbus doc gdbm gtk -gtk3 howl-compat introspection ipv6 -mdnsresponder-compat -mono -nls -python qt4'  succeeded for =net-dns/avahi-0.7
USE='autoipd -bookmarks dbus doc gdbm gtk -gtk3 howl-compat -introspection -ipv6 -mdnsresponder-compat mono nls -python qt4'  succeeded for =net-dns/avahi-0.7
USE='autoipd bookmarks -dbus -doc gdbm -gtk -gtk3 -howl-compat -introspection -ipv6 -mdnsresponder-compat -mono -nls python qt4' : REQUIRED_USE not satisfied (probably)
USE='autoipd -bookmarks dbus doc gdbm -gtk -gtk3 -howl-compat -introspection -ipv6 -mdnsresponder-compat mono -nls python qt4'  succeeded for =net-dns/avahi-0.7
USE='autoipd bookmarks -dbus -doc -gdbm -gtk gtk3 -howl-compat introspection -ipv6 -mdnsresponder-compat -mono nls python qt4' : REQUIRED_USE not satisfied (probably)
USE='autoipd bookmarks dbus doc gdbm gtk gtk3 howl-compat introspection ipv6 mdnsresponder-compat mono nls python qt4'  succeeded for =net-dns/avahi-0.7
 FEATURES= test succeeded for =net-dns/avahi-0.7
Comment 16 Sergei Trofimovich gentoo-dev 2017-11-27 20:04:26 UTC
ppc stable (thanks to ernsteiswuerfel)
Comment 17 Stabilization helper bot gentoo-dev 2017-11-27 21:01:33 UTC
An automated check of this bug failed - repoman reported dependency errors: 

> dependency.bad net-dns/avahi/avahi-0.7.ebuild: DEPEND: hppa(default/linux/hppa/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad net-dns/avahi/avahi-0.7.ebuild: RDEPEND: hppa(default/linux/hppa/13.0) ['>=dev-python/twisted-16.0.0[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
Comment 18 Markus Meier gentoo-dev 2017-12-24 11:58:07 UTC
arm stable
Comment 19 Tobias Klausmann gentoo-dev 2018-01-28 18:23:46 UTC
Stable on alpha.
Comment 20 Andreas Sturmlechner gentoo-dev 2018-02-27 20:30:30 UTC
While this is stalled, we could abort 0.7 stabilisation and move on to 0.7-r1 to get rid of USE=qt4.
Comment 21 Sergei Trofimovich gentoo-dev 2018-03-18 19:37:08 UTC
ppc64 stable
Comment 22 Anthony Basile gentoo-dev 2018-03-21 18:50:05 UTC
@arch teams, we need to start over with 0.7-r1

KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
Comment 23 Sergei Trofimovich gentoo-dev 2018-03-21 20:11:14 UTC
Was this bug locked down from users on purpose?
""" Only users in all of the selected groups can view this bug: Gentoo Developers"""
Comment 24 Anthony Basile gentoo-dev 2018-03-21 20:41:57 UTC
(In reply to Sergei Trofimovich from comment #23)
> Was this bug locked down from users on purpose?
> """ Only users in all of the selected groups can view this bug: Gentoo
> Developers"""

No!  I see from the history that it was probably me, but it was an accident.  There's no reason this bug needs to be gentoo-dev only.
Comment 25 Sergei Trofimovich gentoo-dev 2018-03-21 22:29:19 UTC
ppc stable
Comment 26 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-03-22 13:10:18 UTC
amd64 stable
Comment 27 Sergei Trofimovich gentoo-dev 2018-03-22 22:38:04 UTC
ia64 stable
Comment 28 Sergei Trofimovich gentoo-dev 2018-03-22 22:50:38 UTC
commit 095557802e4efcd83235a56729c25102b6c0c518
Author: Rolf Eike Beer <eike@sf-mail.de>
Date:   Thu Mar 22 18:08:43 2018 +0100

    net-dns/avahi: stable 0.7-r1 for sparc, bug #635418
Comment 29 Sergei Trofimovich gentoo-dev 2018-03-25 20:23:11 UTC
ppc64 stable
Comment 30 Thomas Deutschmann gentoo-dev Security 2018-03-25 22:43:25 UTC
x86 stable
Comment 31 Tobias Klausmann gentoo-dev 2018-03-31 14:18:36 UTC
Stable on alpha.
Comment 32 Mart Raudsepp gentoo-dev 2018-04-18 05:33:19 UTC
arm64 stable
Comment 33 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-04-21 12:41:57 UTC
arm stable
Comment 34 Matt Turner gentoo-dev 2019-01-02 02:42:42 UTC
hppa stable