Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 634348 - sys-devel/binutils-2.29.1-r1 : tests fail
Summary: sys-devel/binutils-2.29.1-r1 : tests fail
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL: https://sourceware.org/bugzilla/show_...
Whiteboard:
Keywords: TESTFAILURE
: 627756 627800 627846 628394 629326 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-15 15:55 UTC by Andreas K. Hüttel
Modified: 2018-11-30 23:02 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build and test log (build.log.gz,100.31 KB, application/gzip)
2017-10-15 16:02 UTC, Andreas K. Hüttel
Details
emerge --info (emerge-info.txt,20.06 KB, text/plain)
2017-10-15 16:02 UTC, Andreas K. Hüttel
Details
build and test log, this time with dependencies installed... (build.log.gz,108.78 KB, application/gzip)
2017-10-15 16:21 UTC, Andreas K. Hüttel
Details
build.log (x86) (x86_build.log,957.74 KB, text/plain)
2017-10-15 16:24 UTC, Thomas Deutschmann
Details
ld test logs (ld.log.gz,154.59 KB, application/gzip)
2017-10-15 17:56 UTC, Andreas K. Hüttel
Details
build log with patch from comment 18 (build.log.gz,107.95 KB, application/gzip)
2017-10-16 22:59 UTC, Andreas K. Hüttel
Details
ld test log with patch from comment 18 (ld.log.gz,154.36 KB, application/gzip)
2017-10-16 22:59 UTC, Andreas K. Hüttel
Details
build log with patches from comment 18 and comment 21 (build.log.gz,107.37 KB, application/gzip)
2017-10-17 22:49 UTC, Andreas K. Hüttel
Details
ld test log with patches from comment 18 and comment 21 (ld.log.gz,149.37 KB, application/gzip)
2017-10-17 22:50 UTC, Andreas K. Hüttel
Details
build log with patches from comments 18,21,24 (build.log.gz,107.60 KB, application/gzip)
2017-10-18 19:18 UTC, Andreas K. Hüttel
Details
ld test log with patches from comments 18,21,24 (ld.log.gz,146.57 KB, application/gzip)
2017-10-18 19:18 UTC, Andreas K. Hüttel
Details
emerge-info.txt (emerge-info.txt,15.03 KB, text/plain)
2017-10-26 16:30 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,22.62 KB, text/plain)
2017-10-26 16:30 UTC, Toralf Förster
Details
environment (environment,117.48 KB, text/plain)
2017-10-26 16:30 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.49 KB, application/x-bzip)
2017-10-26 16:30 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,308.23 KB, application/x-bzip)
2017-10-26 16:30 UTC, Toralf Förster
Details
sys-devel:binutils-2.29.1-r1:20171026-043446.log.bz2 (sys-devel:binutils-2.29.1-r1:20171026-043446.log.bz2,44.65 KB, application/x-bzip)
2017-10-26 16:30 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,74.38 KB, application/x-bzip)
2017-10-26 16:30 UTC, Toralf Förster
Details
build log with test failures on sparc (build.log.xz,29.65 KB, application/x-xz)
2017-12-03 19:19 UTC, Rolf Eike Beer
Details
build log with test failures on hppa (build.log.xz,25.03 KB, application/x-xz)
2017-12-17 17:46 UTC, Rolf Eike Beer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas K. Hüttel archtester gentoo-dev 2017-10-15 15:55:23 UTC
Collecting information here to fix things.

I won't fix older versions, so all other binutils test failure bugs will be closed as duplicates of this one here.
Comment 1 Andreas K. Hüttel archtester gentoo-dev 2017-10-15 15:57:06 UTC
*** Bug 627756 has been marked as a duplicate of this bug. ***
Comment 2 Andreas K. Hüttel archtester gentoo-dev 2017-10-15 15:57:19 UTC
*** Bug 627800 has been marked as a duplicate of this bug. ***
Comment 3 Andreas K. Hüttel archtester gentoo-dev 2017-10-15 15:57:46 UTC
*** Bug 627846 has been marked as a duplicate of this bug. ***
Comment 4 Andreas K. Hüttel archtester gentoo-dev 2017-10-15 15:57:57 UTC
*** Bug 628394 has been marked as a duplicate of this bug. ***
Comment 5 Andreas K. Hüttel archtester gentoo-dev 2017-10-15 15:58:12 UTC
*** Bug 629326 has been marked as a duplicate of this bug. ***
Comment 6 Andreas K. Hüttel archtester gentoo-dev 2017-10-15 16:02:37 UTC
Created attachment 498770 [details]
build and test log
Comment 7 Andreas K. Hüttel archtester gentoo-dev 2017-10-15 16:02:56 UTC
Created attachment 498772 [details]
emerge --info
Comment 8 Felix Janda 2017-10-15 16:21:07 UTC
This seems to be distinct from the "duplicates" (which concern test
failures). From the build log:

gcctestdir/ld: internal error in relocate, at /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/gold/x86_64.cc:4300

Looks like https://sourceware.org/bugzilla/show_bug.cgi?id=21090
Comment 9 Andreas K. Hüttel archtester gentoo-dev 2017-10-15 16:21:58 UTC
Created attachment 498778 [details]
build and test log, this time with dependencies installed...
Comment 10 Thomas Deutschmann gentoo-dev 2017-10-15 16:24:17 UTC
Created attachment 498780 [details]
build.log (x86)

Portage 2.3.8 (python 3.4.5-final-0, default/linux/x86/13.0, gcc-5.4.0, glibc-2.23-r4, 4.12.12-gentoo i686)
=================================================================
System uname: Linux-4.12.12-gentoo-i686-Intel-R-_Core-TM-_i7-3770K_CPU_@_3.50GHz-with-gentoo-2.4.1
KiB Mem:     3108084 total,    885064 free
KiB Swap:     488276 total,    488276 free
Timestamp of repository gentoo: Sun, 15 Oct 2017 14:44:12 +0000
Head commit of repository gentoo: 428c149926735a7a5c4ec522a98f2dd2b30aa162

sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28.1 p1.0) 2.28.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.32.1::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.15-r2::gentoo
sys-devel/binutils:       2.28.1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gentoo.git
    priority: -1000

ABI="x86"
ABI_X86="32"
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
ACCEPT_PROPERTIES="*"
ACCEPT_RESTRICT="*"
ANT_HOME="/usr/share/ant"
ARCH="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=ivybridge -mtune=ivybridge -mno-xsaveopt"
CHOST="i686-pc-linux-gnu"
CHOST_x86="i686-pc-linux-gnu"
COLLISION_IGNORE="/lib/modules/* *.py[co] *$py.class */dropin.cache"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
CXXFLAGS="-O2 -pipe -march=ivybridge -mtune=ivybridge -mno-xsaveopt"
DEFAULT_ABI="x86"
EDITOR="/usr/bin/mcedit"
ELIBC="glibc"
EPREFIX=""
EROOT="/"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs cgroup config-protect-if-modified distlocks downgrade-backup ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -march=i686 -pipe"
GCC_SPECS=""
GRUB_PLATFORMS="efi-32 pc"
GUILE_LOAD_PATH="/usr/share/guile/1.8"
HOME="/root"
INFOPATH="/usr/share/gcc-data/i686-pc-linux-gnu/5.4.0/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.28.1/info:/usr/share/info:/usr/share/info/emacs-25"
INPUT_DEVICES="libinput keyboard mouse"
IUSE_IMPLICIT="abi_x86_32 prefix prefix-chain prefix-guest"
JAVAC="/etc/java-config-2/current-system-vm/bin/javac"
JAVA_HOME="/etc/java-config-2/current-system-vm"
JDK_HOME="/etc/java-config-2/current-system-vm"
KERNEL="linux"
L10N="en en-US de de-DE"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LC_MESSAGES="C"
LC_PAPER="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LIBDIR_x86="lib"
LINGUAS="en de"
LOGNAME="root"
MAIL="/var/mail/root"
MAKEOPTS="--jobs 5 --load-average 7.95"
MOZ_GMP_PATH="/usr/lib/nsbrowser/plugins/gmp-gmpopenh264/system-installed"
MULTILIB_ABIS="x86"
NOCOLOR="true"
OFFICE_IMPLEMENTATION="libreoffice"
OLDPWD="/usr/portage"
OPENGL_PROFILE="xorg-x11"
PAGER="/usr/bin/less"
PATH="/usr/i686-pc-linux-gnu/gcc-bin/5.4.0:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin"
PHP_TARGETS="php5-6 php7-0"
POSTGRES_TARGETS="postgres9_5"
PWD="/usr/portage/sys-devel/binutils"
PYTHONDONTWRITEBYTECODE="1"
PYTHON_SINGLE_TARGET="python3_4"
PYTHON_TARGETS="python2_7 python3_4"
QT_GRAPHICSSYSTEM="raster"
ROOT="/"
ROOTPATH="/usr/i686-pc-linux-gnu/gcc-bin/5.4.0:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin"
RUBY_TARGETS="ruby22"
R_HOME="/usr/lib/R"
SBCL_HOME="/usr/lib/sbcl"
SBCL_SOURCE_ROOT="/usr/lib/sbcl/src"
SHELL="/bin/bash"
SHLVL="2"
SSH_TTY="/dev/pts/0"
TERM="screen"
TMUX="/tmp/tmux-0/default,5803,0"
TMUX_PANE="%0"
TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE="1"
USER="root"
USERLAND="GNU"
VIDEO_CARDS="intel"
Comment 11 Thomas Deutschmann gentoo-dev 2017-10-15 16:25:29 UTC
sys-devel/binutils-2.29.1-r1 test failures on x86:


========================================
   gold 0.1: testsuite/test-suite.log   
========================================

6 of 249 tests failed.  

.. contents:: :depth: 2


FAIL: icf_safe_so_test.sh (exit: 1)
===================================

Safe Identical Code Folding did not fold foo_hidden and foo_internal

FAIL: strong_ref_weak_def.sh (exit: 1)
======================================

pattern ".* FUNC.* GLOBAL.* UND.* weak_def" not found in file strong_ref_weak_def.stdout.


FAIL: dyn_weak_ref.sh (exit: 1)
===============================

pattern ".* WEAK .* UND.* weak_ref" not found in file dyn_weak_ref.stdout.


FAIL: exception_separate_shared_12_test (exit: 127)
===================================================

./exception_separate_shared_12_test: symbol lookup error: ./exception_shared_1.so: undefined symbol: _Z2f1v

FAIL: exception_separate_shared_21_test (exit: 127)
===================================================

./exception_separate_shared_21_test: symbol lookup error: ./exception_shared_1.so: undefined symbol: _Z2f1v

FAIL: dynamic_list_2 (exit: 1)
==============================
Comment 12 Andreas K. Hüttel archtester gentoo-dev 2017-10-15 16:37:15 UTC
(In reply to Felix Janda from comment #8)
> This seems to be distinct from the "duplicates" (which concern test
> failures). From the build log:
> 
> gcctestdir/ld: internal error in relocate, at
> /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/gold/
> x86_64.cc:4300
> 
> Looks like https://sourceware.org/bugzilla/show_bug.cgi?id=21090

Good catch, but sadly all the commits listed in that bug are already in 2.29.1-r1 ...
Comment 13 Andreas K. Hüttel archtester gentoo-dev 2017-10-15 16:52:33 UTC
(In reply to Andreas K. Hüttel from comment #9)
> Created attachment 498778 [details]
> build and test log, this time with dependencies installed...

Interesting bits from that: 

`echo x86_64-pc-linux-gnu-g++ -W -Wall    -Wstack-usage=262144 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fmerge-constants -march=native -O2 -pipe -ggdb -frecord-gcc-switches -fno
-use-linker-plugin  -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -o incremental_test_2 | sed -e 's/-Wp,-D_FORTIFY_SOURCE=[0-9][0-9]*//'` -Wl,--incremental-update -Wl,-z,norelro -Bg
cctestdir/ two_file_test_tmp_2.o two_file_test_1b_ndebug.o two_file_test_2_ndebug.o two_file_test_main_ndebug.o
gcctestdir/ld: internal error in relocate, at /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/gold/x86_64.cc:4300
collect2: error: ld returned 1 exit status
make[5]: *** [Makefile:7262: incremental_test_2] Error 1

`echo x86_64-pc-linux-gnu-g++ -W -Wall    -Wstack-usage=262144 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fmerge-constants -march=native -O2 -pipe -ggdb -frecord-gcc-switches -fno
-use-linker-plugin  -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -o incremental_test_5 | sed -e 's/-Wp,-D_FORTIFY_SOURCE=[0-9][0-9]*//'` -Wl,--incremental-update -Wl,-z,norelro -Bg
cctestdir/ two_file_test_main.o two_file_test_5.a
gcctestdir/ld: internal error in relocate, at /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/gold/x86_64.cc:4300
collect2: error: ld returned 1 exit status
make[5]: *** [Makefile:7286: incremental_test_5] Error 1

`echo x86_64-pc-linux-gnu-g++ -W -Wall    -Wstack-usage=262144 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fmerge-constants -march=native -O2 -pipe -ggdb -frecord-gcc-switches -fno
-use-linker-plugin  -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -o incremental_copy_test | sed -e 's/-Wp,-D_FORTIFY_SOURCE=[0-9][0-9]*//'` -Wl,--incremental-update -Wl,-z,norelro 
-Bgcctestdir/ -Wl,-R,. -Wl,--no-as-needed copy_test_tmp.o copy_test_1.so copy_test_2.so
gcctestdir/ld: internal error in relocate, at /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/gold/x86_64.cc:4300
collect2: error: ld returned 1 exit status
make[5]: *** [Makefile:7301: incremental_copy_test] Error 1

`echo x86_64-pc-linux-gnu-g++ -W -Wall    -Wstack-usage=262144 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fmerge-constants -march=native -O2 -pipe -ggdb -frecord-gcc-switches -fno
-use-linker-plugin  -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -o incremental_common_test_1 | sed -e 's/-Wp,-D_FORTIFY_SOURCE=[0-9][0-9]*//'` -Wl,--incremental-update -Wl,-z,nore
lro -Bgcctestdir/ common_test_1_tmp.o
gcctestdir/ld: internal error in relocate, at /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/gold/x86_64.cc:4300
collect2: error: ld returned 1 exit status
make[5]: *** [Makefile:7307: incremental_common_test_1] Error 1


Running /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-bootstrap/bootstrap.exp ...
ERROR: tcl error sourcing /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-bootstrap/bootstrap.exp.
ERROR: can't read "flags": no such variable
    while executing
"run_host_cmd_yesno "$ld" "$HOSTING_EMU --hash-style=sysv $flags -o $target $objs $libs""
    (procedure "default_ld_relocate" line 5)
    invoked from within
"default_ld_relocate $ld $target $objects"
    (procedure "ld_relocate" line 2)
    invoked from within
"ld_relocate $ld tmpdir/ld-partial.o "$partial_flags $OFILES""
    ("foreach" body line 45)
    invoked from within
"foreach flags $test_flags {
    set gcc_B_opt $gcc_B_opt_save
    set do_strip "no"
    if {"$flags" == "strip"} { 
        set testname "bootstrap with $fla..."
    (file "/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-bootstrap/bootstrap.exp" line 68)
    invoked from within
"source /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-bootstrap/bootstrap.exp"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 source /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-bootstrap/bootstrap.exp"
    invoked from within
"catch "uplevel #0 source $test_file_name""
Running /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-cdtest/cdtest.exp ...
ERROR: tcl error sourcing /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-cdtest/cdtest.exp.
ERROR: can't read "flags": no such variable
    while executing
"run_host_cmd_yesno "$ld" "$HOSTING_EMU --hash-style=sysv $flags -o $target $objs $libs""
    (procedure "default_ld_relocate" line 5)
    invoked from within
"default_ld_relocate $ld $target $objects"
    (procedure "ld_relocate" line 2)
    invoked from within
"ld_relocate $ld tmpdir/cdtest.o {-Ur tmpdir/cdtest-foo.o tmpdir/cdtest-bar.o tmpdir/cdtest-main.o}"
    (file "/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-cdtest/cdtest.exp" line 95)
    invoked from within
"source /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-cdtest/cdtest.exp"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 source /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-cdtest/cdtest.exp"
    invoked from within
"catch "uplevel #0 source $test_file_name""

Running /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf/comm-data.exp ...
FAIL: Common symbol override test

Running /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf/elf.exp ...
FAIL: Link using broken linker script
FAIL: ld-elf/eh6
FAIL: ld-elf/ehdr_start-shared
FAIL: ld-elf/pr19539
FAIL: ld-elf/pr19617a
FAIL: ld-elf/pr21384

Running /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf/shared.exp ...
FAIL: PR ld/20828 dynamic symbols with section GC (auxiliary shared library)
FAIL: PR ld/20828 dynamic symbols with section GC (plain)
FAIL: PR ld/20828 dynamic symbols with section GC (version script)
FAIL: PR ld/20828 dynamic symbols with section GC (versioned shared library)
FAIL: PR ld/20828 dynamic symbols with section GC (versioned)
FAIL: PR ld/20828 forcibly exported symbol version without section GC
FAIL: PR ld/20828 forcibly exported symbol version with section GC
FAIL: PR ld/21233 dynamic symbols with section GC (auxiliary shared library)
FAIL: PR ld/21233 dynamic symbols with section GC (--undefined)
FAIL: PR ld/21233 dynamic symbols with section GC (--require-defined)
FAIL: PR ld/21233 dynamic symbols with section GC (EXTERN)


Running /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elfvsb/elfvsb.exp ...
FAIL: ld-elfvsb/hidden2

Running /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-i386/i386.exp ...
FAIL: TLS -fpic -shared transitions
FAIL: TLS -fpic -shared transitions without PLT
FAIL: TLS descriptor -fpic -shared transitions
FAIL: TLS -fpic and -fno-pic exec transitions
FAIL: TLS -fpic and -fno-pic exec transitions without PLT
FAIL: TLS descriptor -fpic and -fno-pic exec transitions
FAIL: TLS -fno-pic -shared
FAIL: TLS with global dynamic and descriptors
FAIL: Reloc section order
FAIL: Build pr19827
FAIL: Build pr19827.so
FAIL: ld-i386/nogot1
FAIL: ld-i386/pr19636-2a
FAIL: ld-i386/pr19636-2b
FAIL: ld-i386/pr19636-2c
FAIL: ld-i386/pr19636-2d
FAIL: ld-i386/pr19636-2e
FAIL: ld-i386/pr19636-3d
FAIL: ld-i386/pr19636-3e
FAIL: ld-i386/undefweaka
FAIL: ld-i386/undefweakb
FAIL: ld-i386/pr19539
FAIL: ld-i386/pr19939b



Running /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-ifunc/ifunc.exp ...
FAIL: ld-ifunc/ifunc-1-local-x86
FAIL: ld-ifunc/ifunc-2-i386-now
FAIL: ld-ifunc/ifunc-3a-x86

Running /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-plugin/lto.exp ...
FAIL: PR ld/12758

Running /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-scripts/crossref.exp ...
ERROR: tcl error sourcing /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-scripts/crossref.exp.
ERROR: can't read "flags": no such variable
    while executing
"run_host_cmd_yesno "$ld" "$HOSTING_EMU --hash-style=sysv $flags -o $target $objs $libs""
    (procedure "default_ld_relocate" line 5)
    invoked from within
"default_ld_relocate $ld $target $objects"
    (procedure "ld_relocate" line 2)
    invoked from within
"ld_relocate $ld tmpdir/cross3-partial.o "tmpdir/cross1.o tmpdir/cross4.o""
    (file "/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-scripts/crossref.exp" line 143)
    invoked from within
"source /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-scripts/crossref.exp"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 source /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-scripts/crossref.exp"
    invoked from within
"catch "uplevel #0 source $test_file_name""

Running /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-shared/shared.exp ...
FAIL: shared
FAIL: shared -Bsymbolic
Running /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-size/size.exp ...
FAIL: Run size-1
FAIL: Run size-2
FAIL: Run size-3a
FAIL: Run size-3b
FAIL: Run size-3c
FAIL: Run size-3d (1)
FAIL: Run size-3d (2)
FAIL: Run size-9
FAIL: Run size-10

Running /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-unique/unique.exp ...
FAIL: Could not link a dynamic executable
FAIL: Could not create a shared library containing an unique symbol with reference

Running /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-x86-64/mpx.exp ...
FAIL: Build mpx4
FAIL: Build mpx3 (-z now)
FAIL: Build mpx4 (-z now)
FAIL: Run mpx1

Running /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-x86-64/x86-64.exp ...
FAIL: TLS -fpic -shared transitions
FAIL: TLS -fpic -shared transitions with r15 as GOT base
FAIL: TLS descriptor -fpic -shared transitions
FAIL: TLS -fpic and -fno-pic exec transitions
FAIL: TLS -fpic and -fno-pic exec transitions without PLT
FAIL: TLS descriptor -fpic and -fno-pic exec transitions
FAIL: TLS with global dynamic and descriptors
FAIL: Build pr19827
FAIL: Build pr19827.so
FAIL: PR ld/14207
FAIL: PIE with undefined symbol
FAIL: ld-x86-64/pie3
FAIL: ld-x86-64/pr19539a
FAIL: ld-x86-64/pr19539b
FAIL: ld-x86-64/pr19807-1a
FAIL: ld-x86-64/pr19807-1b
FAIL: ld-x86-64/pr19807-2b
FAIL: ld-x86-64/pr19807-2c
FAIL: ld-x86-64/pr19807-2d
FAIL: ld-x86-64/pr19807-2e
FAIL: ld-x86-64/ilp32-4
FAIL: ld-x86-64/load1c
FAIL: ld-x86-64/load1d
FAIL: ld-x86-64/pr19162
FAIL: ld-x86-64/pr19636-1d
FAIL: ld-x86-64/pr19636-1e
FAIL: ld-x86-64/pr19636-2d
FAIL: ld-x86-64/pr19939b
FAIL: ld-x86-64/pr20253-1d
FAIL: ld-x86-64/pr20253-1f
FAIL: ld-x86-64/pr20253-1j
FAIL: ld-x86-64/pr20253-1l
FAIL: Build plt-main
FAIL: Build pr18900a
FAIL: Build pr18900b
FAIL: Build property 1
FAIL: Build property 2
FAIL: Build property 3
FAIL: Build property 4
FAIL: Build property 4 (-Wl,-z,stack-size=0)
FAIL: Build property 5
FAIL: Build property-6
FAIL: Run plt-main
FAIL: Run pr18900
FAIL: Run gotpcrel1
FAIL: Run property 1
FAIL: Run property 2
FAIL: Run property 3
FAIL: Run property 4
FAIL: Run property 5
FAIL: Run pr19784a
FAIL: Run pr19784b
FAIL: Build plt-main with -z bndplt
FAIL: Build plt-main with -z bndplt -z now
FAIL: Run plt-main with -z bndplt
FAIL: Run plt-main with -z bndplt -z now
FAIL: Build plt-main with -z ibtplt
FAIL: Build plt-main with -z ibtplt -z now
FAIL: Run plt-main with -z ibtplt
FAIL: Run plt-main with -z ibtplt -z now
FAIL: Run plt-main with libibtplt-lib.so -z ibtplt
FAIL: Run plt-main with libibtplt-lib.so -z ibtplt -z now
FAIL: basic PLT generation (-z now)
FAIL: PR ld/20830 (.plt.got)
FAIL: PR ld/20830 (.plt.got)
FAIL: PR ld/21038 (.plt.got)
FAIL: PR ld/21038 (.plt.sec)
FAIL: PR ld/20830 (.plt.got, -z now)
FAIL: PR ld/20830 (.plt.got, -z now)
FAIL: PR ld/21038 (.plt.got, -z now)
FAIL: PR ld/21038 (.plt.sec, -z now)
Comment 14 Andreas K. Hüttel archtester gentoo-dev 2017-10-15 17:44:46 UTC
(In reply to Andreas K. Hüttel from comment #13)

> Running
> /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/
> testsuite/ld-elf/elf.exp ...
> FAIL: Link using broken linker script

Executing on host: sh -c {/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/ld-new   -o tmpdir/a.out -z norelro -L/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf --script note-3.t tmpdir/note-3.so   2>&1}  /dev/null ld.tmp (timeout = 300)
spawn [open ...]
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: could not find section .gnu.hash
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: final link failed: Nonrepresentable section on output
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: could not find section .gnu.hash
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: final link failed: Nonrepresentable section on output
regexp_diff match failure
regexp "^.*warning: section '.hash' is being made into a note$"
line   "/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: could not find section .gnu.hash"
FAIL: Link using broken linker script

> FAIL: ld-elf/eh6

Executing on host: sh -c {/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/../gas/as-new    -o tmpdir/eh6.o /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf/eh6.s 2>&1}  /dev/null ld.tmp (timeout = 300)
spawn [open ...]
./ld-new -z norelro  -L/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf  --gc-sections -shared -o tmpdir/dump tmpdir/eh6.o 
Executing on host: sh -c {./ld-new -z norelro  -L/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf  --gc-sections -shared -o tmpdir/dump tmpdir/eh6.o  2>&1}  /dev/null ld.tmp (timeout = 300)
spawn [open ...]
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: tmpdir/eh6.o: warning: relocation in readonly section `.eh_frame'
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: warning: creating a DT_TEXTREL in a shared object.
succeeded with: </var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: tmpdir/eh6.o: warning: relocation in readonly section `.eh_frame'
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: warning: creating a DT_TEXTREL in a shared object.>, no expected output
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: tmpdir/eh6.o: warning: relocation in readonly section `.eh_frame'
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: warning: creating a DT_TEXTREL in a shared object.
FAIL: ld-elf/eh6

Ugh... this is likely due to our textrels trickery patch.

> FAIL: ld-elf/ehdr_start-shared

./ld-new -z norelro  -L/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf  -e _start -shared -o tmpdir/dump tmpdir/ehdr_start.o 
Executing on host: sh -c {./ld-new -z norelro  -L/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf  -e _start -shared -o tmpdir/dump tmpdir/ehdr_start.o  2>&1}  /dev/null ld.tmp (timeout = 300)
spawn [open ...]
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: tmpdir/ehdr_start.o: warning: relocation against `__ehdr_start' in readonly section `.rodata'
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: warning: creating a DT_TEXTREL in a shared object.
succeeded with: </var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: tmpdir/ehdr_start.o: warning: relocation against `__ehdr_start' in readonly section `.rodata'
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: warning: creating a DT_TEXTREL in a shared object.>, no expected output
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: tmpdir/ehdr_start.o: warning: relocation against `__ehdr_start' in readonly section `.rodata'
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: warning: creating a DT_TEXTREL in a shared object.
FAIL: ld-elf/ehdr_start-shared

Another one.

> FAIL: ld-elf/pr19539

./ld-new -z norelro  -L/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf  -pie -T pr19539.t -o tmpdir/dump tmpdir/start.o tmpdir/pr19539.o 
Executing on host: sh -c {./ld-new -z norelro  -L/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf  -pie -T pr19539.t -o tmpdir/dump tmpdir/sta
rt.o tmpdir/pr19539.o  2>&1}  /dev/null ld.tmp (timeout = 300)
spawn [open ...]
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: tmpdir/pr19539.o: warning: relocation against `foo' in readonly section `.prefix'
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: warning: creating a DT_TEXTREL in a shared object.
succeeded with: </var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: tmpdir/pr19539.o: warning: relocation against `foo' in readonly section `.prefix'
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: warning: creating a DT_TEXTREL in a shared object.>, no expected output
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: tmpdir/pr19539.o: warning: relocation against `foo' in readonly section `.prefix'
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: warning: creating a DT_TEXTREL in a shared object.
FAIL: ld-elf/pr19539

Another one.

> FAIL: ld-elf/pr19617a

/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/../gas/as-new    -o tmpdir/pr19617.o /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf/pr19617.s
Executing on host: sh -c {/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/../gas/as-new    -o tmpdir/pr19617.o /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf/pr19617.s 2>&1}  /dev/null ld.tmp (timeout = 300)
spawn [open ...]
./ld-new -z norelro  -L/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf  -E --no-dynamic-linker -o tmpdir/dump tmpdir/pr19617.o 
Executing on host: sh -c {./ld-new -z norelro  -L/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf  -E --no-dynamic-linker -o tmpdir/dump tmpdir/pr19617.o  2>&1}  /dev/null ld.tmp (timeout = 300)
spawn [open ...]
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/../binutils/readelf  --dyn-syms --wide tmpdir/dump > tmpdir/dump.out
Executing on host: sh -c {/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/../binutils/readelf  --dyn-syms --wide tmpdir/dump > tmpdir/dump.out 2>ld.tmp}  /dev/null  (timeout = 300)
spawn [open ...]
extra regexps in /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf/pr19617a.d starting with "^ +[0-9]+: +[a-f0-9]+ +0 +OBJECT +GLOBAL +DEFAULT +[0-9]+ +bar$"
EOF from tmpdir/dump.out
FAIL: ld-elf/pr19617a

That's something different.

> FAIL: ld-elf/pr21384

spawn [open ...]
./ld-new -z norelro  -L/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf  -T pr21384.ld --dynamic-list /var/tmp/portage/sys-devel/binutils-2.29
.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf/pr21384.dl --no-dynamic-linker -o tmpdir/dump tmpdir/pr21384.o 
Executing on host: sh -c {./ld-new -z norelro  -L/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf  -T pr21384.ld --dynamic-list /var/tmp/porta
ge/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/testsuite/ld-elf/pr21384.dl --no-dynamic-linker -o tmpdir/dump tmpdir/pr21384.o  2>&1}  /dev/null ld.tmp (timeout = 300)
spawn [open ...]
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: could not find section .gnu.hash
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: final link failed: Nonrepresentable section on output
failed with: </var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: could not find section .gnu.hash
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: final link failed: Nonrepresentable section on output>, no expected output
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: could not find section .gnu.hash
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: final link failed: Nonrepresentable section on output
FAIL: ld-elf/pr21384



> 
> Running
> /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/
> testsuite/ld-elf/shared.exp ...
> FAIL: PR ld/20828 dynamic symbols with section GC (auxiliary shared library)

spawn [open ...]
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/ld-new   -o tmpdir/libpr20828.so -z norelro -L/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/test
suite/ld-elf  -shared --gc-sections -T pr20828.ld tmpdir/pr20828.o 
Executing on host: sh -c {/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/ld-new   -o tmpdir/libpr20828.so -z norelro -L/var/tmp/portage/sys-devel/binutils-2.29.1-r1/wo
rk/binutils-2.29.1/ld/testsuite/ld-elf  -shared --gc-sections -T pr20828.ld tmpdir/pr20828.o  2>&1}  /dev/null ld.tmp (timeout = 300)
spawn [open ...]
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: could not find section .gnu.hash
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: final link failed: Nonrepresentable section on output
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: could not find section .gnu.hash
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: final link failed: Nonrepresentable section on output
FAIL: PR ld/20828 dynamic symbols with section GC (auxiliary shared library)
Comment 15 Andreas K. Hüttel archtester gentoo-dev 2017-10-15 17:55:44 UTC
A different sample... 

(In reply to Andreas K. Hüttel from comment #13)

> Running
> /var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/binutils-2.29.1/ld/
> testsuite/ld-x86-64/x86-64.exp ...
> FAIL: TLS -fpic -shared transitions

Executing on host: sh -c {/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/../binutils/readelf -Ssrl tmpdir/libtlspic.so >dump.out 2>ld.stderr}  /dev/null  (timeout = 30
0)
spawn [open ...]
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/../binutils/readelf -Ssrl tmpdir/libtlspic.so
regexp_diff match failure
regexp "^ +\[[ 0-9]+\] \.hash +.*$"
line   "  [ 1] .gnu.hash         GNU_HASH        000000b4 0000b4 00005c 04   A  2   0  4"
regexp_diff match failure
regexp "^ +00 +.hash .dynsym .dynstr .rel.dyn .rel.plt .plt .text *$"
line   "   00     .gnu.hash .dynsym .dynstr .rel.dyn .rel.plt .plt .text "
regexp_diff match failure
regexp "^ +[0-9]+: 0+1c +0 +TLS +GLOBAL +DEFAULT +8 sg8$"
line   "     1: 00000000     0 NOTYPE  GLOBAL DEFAULT  UND ___tls_get_addr"
regexp_diff match failure
regexp "^ +[0-9]+: 0+c +0 +TLS +GLOBAL +DEFAULT +8 sg4$"
line   "     3: 00000014     0 TLS     GLOBAL DEFAULT    8 sg6"
regexp_diff match failure
regexp "^ +[0-9]+: 0+10 +0 +TLS +GLOBAL +DEFAULT +8 sg5$"
line   "     4: 0000179c     0 NOTYPE  GLOBAL DEFAULT   12 _edata"
regexp_diff match failure
regexp "^ +[0-9]+: 0+ +0 +TLS +GLOBAL +DEFAULT +8 sg1$"
line   "     5: 0000179c     0 NOTYPE  GLOBAL DEFAULT   12 _end"
regexp_diff match failure
regexp "^ +[0-9]+: [0-9a-f]+ +0 +FUNC +GLOBAL +DEFAULT +7 fn1$"
line   "     6: 0000000c     0 TLS     GLOBAL DEFAULT    8 sg4"
regexp_diff match failure
regexp "^ +[0-9]+: [0-9a-f]+ +0 +NOTYPE +GLOBAL +DEFAULT +12 __bss_start$"
line   "     7: 00000000     0 TLS     GLOBAL DEFAULT    8 sg1"
regexp_diff match failure
regexp "^ +[0-9]+: 0+4 +0 +TLS +GLOBAL +DEFAULT +8 sg2$"
line   "     8: 00000340     0 FUNC    GLOBAL DEFAULT    7 fn1"
regexp_diff match failure
regexp "^ +[0-9]+: 0+14 +0 +TLS +GLOBAL +DEFAULT +8 sg6$"
line   "     9: 0000179c     0 NOTYPE  GLOBAL DEFAULT   12 __bss_start"
regexp_diff match failure
regexp "^ +[0-9]+: [0-9a-f]+ +0 +NOTYPE +GLOBAL +DEFAULT +12 _edata$"
line   "    11: 0000001c     0 TLS     GLOBAL DEFAULT    8 sg8"
regexp_diff match failure
regexp "^ +[0-9]+: [0-9a-f]+ +0 +NOTYPE +GLOBAL +DEFAULT +12 _end$"
line   "    12: 00000010     0 TLS     GLOBAL DEFAULT    8 sg5"
regexp_diff match failure
regexp "^ +[0-9]+: 0+ +0 +NOTYPE +GLOBAL +DEFAULT +UND ___tls_get_addr$"
line   "    13: 00000004     0 TLS     GLOBAL DEFAULT    8 sg2"
FAIL: TLS -fpic -shared transitions

>
Comment 16 Andreas K. Hüttel archtester gentoo-dev 2017-10-15 17:56:09 UTC
Created attachment 498782 [details]
ld test logs
Comment 17 Felix Janda 2017-10-15 20:07:18 UTC
The failures due to the DT_TEXTREL patch can maybe fixed by updating
the Gentoo tweak in ld/testsuite/lib/ld-lib.exp.
(See 0001_all_Gentoo-ld-always-warn-about-textrels-in-files.patch)
Comment 18 Andreas K. Hüttel archtester gentoo-dev 2017-10-16 22:52:39 UTC
(In reply to Felix Janda from comment #17)
> The failures due to the DT_TEXTREL patch can maybe fixed by updating
> the Gentoo tweak in ld/testsuite/lib/ld-lib.exp.
> (See 0001_all_Gentoo-ld-always-warn-about-textrels-in-files.patch)

Yep. Wasn't that simple though, since the failure occurs in a different test routine.

https://github.com/gentoo/binutils-gdb/commit/49a82abdafe1ff96167c50822fd593b2a4690e29

Aleph-zero tests fixed, Aleph-one still failing. New logs to follow.
Comment 19 Andreas K. Hüttel archtester gentoo-dev 2017-10-16 22:59:08 UTC
Created attachment 498924 [details]
build log with patch from comment 18
Comment 20 Andreas K. Hüttel archtester gentoo-dev 2017-10-16 22:59:41 UTC
Created attachment 498926 [details]
ld test log with patch from comment 18
Comment 21 Andreas K. Hüttel archtester gentoo-dev 2017-10-17 22:48:01 UTC
https://github.com/gentoo/binutils-gdb/commit/5cd19218cd1fbe6a4c7d0f60310f3a703c436045
Explicitly add --hash-style=sysv to linker calls in testsuite dump tests
Fixes another ~25 failing tests (which only fail because we change the default)

New logs follow.
Comment 22 Andreas K. Hüttel archtester gentoo-dev 2017-10-17 22:49:41 UTC
Created attachment 499034 [details]
build log with patches from comment 18 and comment 21
Comment 23 Andreas K. Hüttel archtester gentoo-dev 2017-10-17 22:50:10 UTC
Created attachment 499036 [details]
ld test log with patches from comment 18 and comment 21
Comment 24 Andreas K. Hüttel archtester gentoo-dev 2017-10-18 19:17:39 UTC
https://github.com/gentoo/binutils-gdb/commit/49973536740bdabc73541ab1ac52e212a0b57680
Another instance where we need to beat the linker into doing --hash-style=sysv
Comment 25 Andreas K. Hüttel archtester gentoo-dev 2017-10-18 19:18:18 UTC
Created attachment 499136 [details]
build log with patches from comments 18,21,24
Comment 26 Andreas K. Hüttel archtester gentoo-dev 2017-10-18 19:18:50 UTC
Created attachment 499138 [details]
ld test log with patches from comments 18,21,24
Comment 27 Felix Janda 2017-10-18 20:46:08 UTC
The remaining test failures seems to be of the following two types:

More DT_TEXTREL warnings.

Something probably related to PIE, e.g.

/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: tmpdir/mainnp.o: relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: final link failed: Nonrepresentable section on output
collect2: error: ld returned 1 exit status
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: tmpdir/mainnp.o: relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC
/var/tmp/portage/sys-devel/binutils-2.29.1-r1/work/build/ld/.libs/ld-new: final link failed: Nonrepresentable section on output
collect2: error: ld returned 1 exit status
FAIL: shared
Comment 28 Larry the Git Cow gentoo-dev 2017-10-20 23:26:22 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=27928b633f807a925cdf1b9a9dd45efa08c280c2

commit 27928b633f807a925cdf1b9a9dd45efa08c280c2
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2017-10-20 23:26:01 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2017-10-20 23:26:13 +0000

    sys-devel/binutils: Bump patchlevel to 3, only changes in the testsuite
    
    This fixes most of the tests. The only remaining failure here is
    a "real" one,
    "internal error in relocate, at ../../binutils-gdb/gold/x86_64.cc:4300"
    
    Upstream bug report:
    https://sourceware.org/bugzilla/show_bug.cgi?id=21090
    
    Bug: https://bugs.gentoo.org/634348
    Package-Manager: Portage-2.3.12, Repoman-2.3.3

 sys-devel/binutils/Manifest                  | 2 +-
 sys-devel/binutils/binutils-2.29.1-r1.ebuild | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)}
Comment 29 Toralf Förster gentoo-dev 2017-10-26 16:30:00 UTC
got at the unstable amd64 chroot image 13.0-desktop-plasma-systemd_test_20171025-203252 this : sys-devel/binutils-2.29.1-r1 : FAIL: strong_ref_weak_def.sh
Comment 30 Toralf Förster gentoo-dev 2017-10-26 16:30:03 UTC
Created attachment 500212 [details]
emerge-info.txt
Comment 31 Toralf Förster gentoo-dev 2017-10-26 16:30:06 UTC
Created attachment 500214 [details]
emerge-history.txt
Comment 32 Toralf Förster gentoo-dev 2017-10-26 16:30:09 UTC
Created attachment 500216 [details]
environment
Comment 33 Toralf Förster gentoo-dev 2017-10-26 16:30:13 UTC
Created attachment 500218 [details]
etc.portage.tbz2
Comment 34 Toralf Förster gentoo-dev 2017-10-26 16:30:16 UTC
Created attachment 500220 [details]
logs.tbz2
Comment 35 Toralf Förster gentoo-dev 2017-10-26 16:30:19 UTC
Created attachment 500222 [details]
sys-devel:binutils-2.29.1-r1:20171026-043446.log.bz2
Comment 36 Toralf Förster gentoo-dev 2017-10-26 16:30:22 UTC
Created attachment 500224 [details]
temp.tbz2
Comment 37 Larry the Git Cow gentoo-dev 2017-11-03 21:08:33 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a6dc051cd3b1dadb52d49133bdde51a04171aaf6

commit a6dc051cd3b1dadb52d49133bdde51a04171aaf6
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2017-11-03 21:08:15 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2017-11-03 21:08:15 +0000

    sys-devel/binutils: Temporarily disable ld.gold test suite, bug 634348
    
    The ld.gold test suite has problems with --enable-default-pie.
    This is known upstream, but there's no activity on the bug, so
    let's temporarily disable testing only for ld.gold.
    
    The rest of the test suite (gas, ld, ...) works fine.
    
    Bug: https://bugs.gentoo.org/634348
    Bug: https://sourceware.org/bugzilla/show_bug.cgi?id=21090
    Package-Manager: Portage-2.3.13, Repoman-2.3.4

 sys-devel/binutils/binutils-2.29.1-r1.ebuild       |  2 ++
 .../files/binutils-2.29.1-nogoldtest.patch         | 27 ++++++++++++++++++++++
 2 files changed, 29 insertions(+)}
Comment 38 Rolf Eike Beer archtester 2017-12-03 19:19:54 UTC
Created attachment 507930 [details]
build log with test failures on sparc
Comment 39 Rolf Eike Beer archtester 2017-12-17 17:46:40 UTC
Created attachment 510504 [details]
build log with test failures on hppa

FAIL: build-id-debuglink (copy debug info into debug directory)
FAIL: ld-elf/ehdr_start-shared
FAIL: ld-elf/pr19539
FAIL: relocatable with script
FAIL: vers26b3
FAIL: --gc-sections with __start_SECTIONNAME
FAIL: Could not create a shared library containing an unique symbol with reference
Comment 40 Andreas K. Hüttel archtester gentoo-dev 2018-11-30 23:02:05 UTC
2.29 is now masked. Let's close this here and continue with separate bugs for 2.31.1 or 2.30.