Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 634142 - app-antivirus/clamav-0.99.2-r1 check_bytecode.c:127:F:arithmetic:test_inflate_jit:0: cli_bytecode_run failed, expected: 0, have: 28
Summary: app-antivirus/clamav-0.99.2-r1 check_bytecode.c:127:F:arithmetic:test_inflate...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: Normal normal (vote)
Assignee: Antivirus Team
URL: https://bugzilla.clamav.net/show_bug....
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2017-10-12 22:30 UTC by ernsteiswuerfel
Modified: 2018-03-30 10:08 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_634142.txt,5.63 KB, text/plain)
2017-10-12 22:30 UTC, ernsteiswuerfel
Details
build.log (clamav_build.log,726.24 KB, text/x-log)
2017-10-12 22:30 UTC, ernsteiswuerfel
Details
test-suite.log (clamav_test-suite.log,1.40 KB, text/x-log)
2017-10-12 22:31 UTC, ernsteiswuerfel
Details
build.log (clamav-0.99.4) (build.log,296.32 KB, text/plain)
2018-03-20 20:07 UTC, ernsteiswuerfel
Details
test-suite.log (clamav-0.99.4) (test-suite.log,1.51 KB, text/plain)
2018-03-20 20:08 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernsteiswuerfel 2017-10-12 22:30:09 UTC
Created attachment 498478 [details]
emerge --info

One of the tests causes a segfault on my system:

check_bytecode.c:127:F:arithmetic:test_inflate_jit:0: cli_bytecode_run failed, expected: 0, have: 28

check_bytecode.c:108:E:arithmetic:test_inflate_int:0: (after this point) Received signal 11 (Segmentation fault)
NOTICE: Use the 'T' environment variable to adjust testcase timeout
Comment 1 ernsteiswuerfel 2017-10-12 22:30:38 UTC
Created attachment 498480 [details]
build.log
Comment 2 ernsteiswuerfel 2017-10-12 22:31:10 UTC
Created attachment 498482 [details]
test-suite.log
Comment 3 ernsteiswuerfel 2018-03-20 19:41:40 UTC
Same failure for app-antivirus/clamav-0.99.4.
Comment 4 ernsteiswuerfel 2018-03-20 19:57:49 UTC
Looks like this issue is already upstream (for AIX):
https://bugzilla.clamav.net/show_bug.cgi?id=12024
Comment 5 ernsteiswuerfel 2018-03-20 20:07:48 UTC
Created attachment 524612 [details]
build.log (clamav-0.99.4)
Comment 6 ernsteiswuerfel 2018-03-20 20:08:39 UTC
Created attachment 524614 [details]
test-suite.log (clamav-0.99.4)
Comment 7 Thomas Deutschmann gentoo-dev Security 2018-03-29 22:46:16 UTC
Please re-test with =app-antivirus/clamav-0.99.4-r1.
Comment 8 ernsteiswuerfel 2018-03-30 10:08:19 UTC
I can confirm =app-antivirus/clamav-0.99.4-r1 passes all the tests. Thanks!