Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 63384 - Gaim 0.82.1 crashes when finding any buddies online on an AIM account
Summary: Gaim 0.82.1 crashes when finding any buddies online on an AIM account
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gaim Bugs Crew
Depends on:
Reported: 2004-09-08 21:04 UTC by Ryan Pessa
Modified: 2004-09-15 20:57 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Gaim 0.82.1 backtrace (gaim 0.82.1 crash.20040908.txt,1.44 KB, text/plain)
2004-09-08 21:07 UTC, Ryan Pessa
Screenshot showing the point where Gaim crashes (gaim 0.82.1 crash.20040908.png,912.22 KB, image/png)
2004-09-08 21:22 UTC, Ryan Pessa

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Pessa 2004-09-08 21:04:10 UTC
I just upgraded to 0.82.1 from 0.81-r5, and found that Gaim would crash on startup every time.  I figured out that the problem is being caused when I connect to AIM and any user on my buddy list is online.  I can still connect to AIM with an account with no buddies, and can still IM with people.  I can also have buddies that are not online in my buddy list.  But any online buddy will cause Gaim to crash.  A backtrace of Gaim reveals absolutely nothing. :(

Reproducible: Always
Steps to Reproduce:
1. Run Gaim.
2. Log on to an AIM SN with online buddies in the buddy list.
3. Crash.

Actual Results:  
Gaim seg faults upon finding an online AIM buddy.

Expected Results:  
Gaim shouldn't crash here. ;)

Portage 2.0.50-r10 (default-x86-1.4, gcc-3.3.3, glibc-,
[[ Please note that my kernel is just the development-sources-2.6.8.  I like to
name my kernel cause it tickles me. ;) ]]
System uname: 2.6.8-shinryoku i686 AMD Athlon(tm) XP 1800+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.3
CFLAGS="-O3 -march=athlon-xp -funroll-loops -fprefetch-loop-arrays -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.1/share/config /usr/kde/3.3/share/config /usr/kde/3/share/config
/usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/bind
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=athlon-xp -funroll-loops -fprefetch-loop-arrays -pipe"
FEATURES="autoaddcvs ccache sandbox"
USE="3dnow S3TC X aalib alsa apm avi berkdb bonobo canna cdr cjk crypt cups dnd
doc dvd encode esd ffmpeg foomaticdb gdbm gif gnome gpm gstreamer gtk gtk2
gtkhtml guile imlib ipv6 java jpeg jpg libg++ libwww mad mikmod mmx motif mpeg
ncurses nls oggvorbis openal opengl oss pam pdflib perl png python quicktime
readline samba sdl slang spell sse ssl svga tcltk tcpd transcode truetype
unicode usagi usb x86 xml2 xmms xv zlib"
Comment 1 Ryan Pessa 2004-09-08 21:07:23 UTC
Created attachment 39236 [details]
Gaim 0.82.1 backtrace

Yes, I did emerge with the debug USE flag.
Comment 2 Ryan Pessa 2004-09-08 21:22:15 UTC
Created attachment 39237 [details]
Screenshot showing the point where Gaim crashes

At this point the connection dialog had just disappeared, and buddies should
have started appearing as online.
Comment 3 Don Seiler (RETIRED) gentoo-dev 2004-09-09 08:11:09 UTC
Try backing up your .gaim folder and starting gaim with a fresh profile and add your AIM account to see if it will download your buddies.
Comment 4 Don Seiler (RETIRED) gentoo-dev 2004-09-15 09:31:48 UTC
Still waiting for response from user.
Comment 5 Ryan Pessa 2004-09-15 19:35:37 UTC
Ok, sorry about the delay.  Took some time getting around to trying that... I had downgraded so I could still use gaim.  However, I removed my .gaim directory and added users, it worked fine.  Started reconfiguring, and killed it... evidently, the problem was with a plugin, (MSN-Style Notification).  Restored my backed up .gaim directory, removed the offending plugin from my prefs.xml file and everything works fine now... well except the notifications, of course. ;)  So this is not a problem with Gaim itself... I'll try recompiling the plugin and see if it works now.  Thanks for the help! :)
Comment 6 Don Seiler (RETIRED) gentoo-dev 2004-09-15 20:57:13 UTC
Yet another victim of third-party plugins.  See ebuild note about having to upgrade your plugins after upgrading gaim.