Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 63370 - Acroread Font problem with reiser4
Summary: Acroread Font problem with reiser4
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Printing Team
Depends on:
Reported: 2004-09-08 16:48 UTC by Dominik Stengel
Modified: 2005-01-08 23:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Dominik Stengel 2004-09-08 16:48:39 UTC
After emergeing acroread 5.09 from portage acroread has problems with missing fonts on several pdf's (but not on all). The errors that occur are complaining about missing or not creatable fonts as you can see in this 2 shots:

I'm running xorg-6.99.904 with gcc 3.4.1 and ntpl. Also i have installed all fonts i found in portage and took them into my xorg.conf paths.

As i found out it has something to do with the executable-file "acroread". When i download the install-package of Acrobat Reader for Unix directly from the pdf's which were formerly not viewable with acroread are viewable with this extra installed version. After copying just the executable "acroread" from this extra installed version over the emerged version the emerged version also works - every pdf is now viewable. 

So my solution was overwriting the emerged "acroread"-executable with the one from The procedure is reproducable.. 


Reproducible: Always
Steps to Reproduce:
1. Emerge acroread 5.09
2. Try to view for example
3. Overwrite acroread excecutable with the one from
4. Try again and it works
Comment 1 Dominik Stengel 2004-09-08 18:05:46 UTC
Real strange... my presumption was wrong with just copying the executable because inside the executable it's linking back to my installed version.

Furthermore i tried again with changing the ebuild to 


where /home is ext3 while / and /opt are Reiser 4

After emerging in the new INSTALLDIR everything works. I've checked this with one more ext2 partition i have and it also worked. But each time i try to emerge it into an reiser 4 partition the errors i talked about are occuring..

Comment 2 uehli 2004-09-24 13:29:33 UTC
I'm experiencing exactly the same problem as you.
The problem appeared after I changed / from ext3 to reiser4.
So it surely must be connected to reiser4!
Comment 3 SpanKY gentoo-dev 2005-01-08 23:13:40 UTC
gentoo doesnt support reiser4 let along with a closed source application such as adobe

you'll have to e-mail adobe support and get this resolved yourself