Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 63358 - app-editors/xemacs-21.4.15-r2 ebuild segfaults in update-elc.el
Summary: app-editors/xemacs-21.4.15-r2 ebuild segfaults in update-elc.el
Status: RESOLVED DUPLICATE of bug 75028
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: XEmacs team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-08 15:16 UTC by Timothy K. Armstrong
Modified: 2009-11-24 18:34 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
installation log (output from emerge xemacs) (xemacs-21.4.15-r2-log.txt.bz2,5.91 KB, application/octet-stream)
2004-09-08 15:18 UTC, Timothy K. Armstrong
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy K. Armstrong 2004-09-08 15:16:57 UTC
compilation of xemacs-21.4.15-r2 fails on my amd64 system.  The prior version (21.4.12) installed successfully.  Last few lines of output are:

./xemacs -nd -batch -l /var/tmp/portage/xemacs-21.4.15-r2/work/xemacs-21.4.15/src/../lisp/update-elc.el
make[1]: *** [update-elc.stamp] Segmentation fault
make[1]: Leaving directory `/var/tmp/portage/xemacs-21.4.15-r2/work/xemacs-21.4.15/src'
make: *** [src] Error 2

!!! ERROR: app-editors/xemacs-21.4.15-r2 failed.
!!! Function src_compile, Line 168, Exitcode 2
!!! (no error message)


Reproducible: Always
Steps to Reproduce:
1. emerge app-editors/xemacs
2.
3.

Actual Results:  
!!! ERROR: app-editors/xemacs-21.4.15-r2 failed.
!!! Function src_compile, Line 168, Exitcode 2
!!! (no error message)


Expected Results:  
compiled and installed xemacs-21.4.15-r2

emerge info:

Gentoo Base System version 1.4.16
Portage 2.0.50-r11 (default-amd64-2004.0, gcc-3.3.4, glibc-2.3.4.20040619-r1,
2.6.7-gentoo-r14)
=================================================================
System uname: 2.6.7-gentoo-r14 x86_64 4
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CFLAGS="-O2 -pipe -fno-stack-protector"
CHOST="x86_64-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -pipe -fno-stack-protector"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sfperms strict userpriv usersandbox"
GENTOO_MIRRORS="ftp:///ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
http://mirror.datapipe.net/gentoo http://ftp-mirror.internap.com/pub/gentoo/
http://mirrors.tds.net/gentoo http://gentoo.mirrors.pair.com/
http://mirrors.acm.cs.rpi.edu/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acpi alsa amd64 apm arts avi berkdb bzlib cdr crypt directfb divx4linux
dvd emacs encode exif fbcon foomaticdb ftp gdbm gif gphoto2 gpm gtk2 hardened
imagemagick imlib ipv6 java jpeg kde libg++ libwww mikmod motif mozilla mpeg
multilib ncurses nls nogcj oggvorbis opengl oss pam pdflib perl png python qt
quicktime readline samba sdl slang spell ssl tcpd tetex theora tidy tiff
truetype unicode usb xml2 xmms xsl xv zlib"
Comment 1 Timothy K. Armstrong 2004-09-08 15:18:18 UTC
Created attachment 39222 [details]
installation log (output from emerge xemacs)
Comment 2 Timothy K. Armstrong 2004-11-01 14:06:24 UTC
Compilation completed successfully after installing app-editors/emacs-21.3-r3.  Perhaps the xemacs ebuild could be fixed by specifying regular (non-X) emacs as a dependency.
Comment 3 François MASSON 2005-05-22 22:33:00 UTC
adding "app-editor/xemacs -berkdb" to /etc/profile/packages.use solved the
problem for me.
Maybe is it comme from having both berkdb and gdbm is use ?
Comment 4 François MASSON 2005-05-22 22:38:28 UTC
Hum, sorry, I mean:

adding "app-editor/xemacs -berkdb" to /etc/portage/package.use solved the
problem for me.
Maybe it come from having both berkdb and gdbm is use ?
Comment 5 Michael Labhard 2005-08-02 20:00:05 UTC
I have emacs-21.4-r1 installed and I attempted to install xemacs with
USE="-berkdb", and I still get exactly the same ERROR as reported in this report.

goliath ~ # emerge --info
Portage 2.0.51.22-r2 (default-linux/amd64/2004.3, gcc-3.4.3, glibc-2.3.5-r0,
2.6.12-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.12-gentoo-r4 x86_64 AMD Opteron(tm) Processor 246
Gentoo Base System version 1.6.13
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5
sys-apps/sandbox:    1.2.11
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -fPIC"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/resin/conf /usr//lib/mozilla/defaults/pref
/usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config
/usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config
/usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -fPIC"
DISTDIR="/opt/no_archive/portage/distfiles"
FEATURES="autoconfig buildpkg ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://128.213.5.34/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/opt/no_archive/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X alsa arts avi berkdb bitmap-fonts cdr crypt cups curl doc encode
esd fam flac foomaticdb fortran gd gdbm gif gnome gphoto2 gpm gtk gtk2 guile
imagemagick imlib ipv6 java jpeg junit kde ldap libg++ libwww log4cpp lzw
lzw-tiff mad mikmod motif mozilla mp3 mpeg multilib mysql nas ncurses nls ogg
opengl pam pdflib perl plotutils png postgres python qt quicktime readline ruby
sdl slang spell ssl svg tcltk tcpd tetex tiff truetype truetype-fonts
type1-fonts usb userlocales vorbis wxwindows xine xinerama xml2 xmms xpm xv zlib
userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS
Comment 6 Fulvio Scapin 2005-09-19 08:19:25 UTC
I solved the problem recompiling gcc and glibc with the hardened flag turned  
off before merging xemacs.  
Comment 7 Hans de Graaff gentoo-dev 2006-12-09 08:33:57 UTC
Could you please verify if this problem still exists with xemacs 21.4.19? If so, then please reopen the bug.
Comment 8 anthony 2007-08-06 12:59:12 UTC
Still a problem with xemacs-21.4.20-r5. Tried with -berkdb too.

[ebuild  N    ] app-editors/xemacs-21.4.20-r5  USE="X gif jpeg tiff -Xaw3d -athena -berkdb -canna -dnd -eolconv -esd -freewnn -gdbm -gpm -ldap -motif -mule -nas -neXt -png -pop -postgres -xface -xim" 0 kB 
[ebuild  N    ] app-xemacs/xemacs-base-2.10  526 kB 

Portage 2.1.3.3 (hardened/amd64/multilib, gcc-3.4.6, glibc-2.6-r0, 2.6.20-hardened-r1 x86_64)
=================================================================
System uname: 2.6.20-hardened-r1 x86_64 Dual-Core AMD Opteron(tm) Processor 2214 HE
Gentoo Base System release 1.12.10
Timestamp of tree: Sun, 05 Aug 2007 02:20:01 +0000
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -fomit-frame-pointer -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=k8 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -s"
MAKEOPTS="-j12"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X acpi aim amd64 apache2 apm avi berkdb bzlib cairo caps cracklib crypt curl encode exim extensions fam flash ftp gd gif gnutls gstreamer gtk2 hardened icq imagemagick imap innodb ithreads jpeg justify lcms mbox midi ming mng mpeg msql multilib mysql nls nptl nptlonly ogg oggvorbis opengl pam pic postgres python quicktime quotas readline sqlite ssl szip tcltk tcpd theora threads tiff tokenizer truetype urandom usb vhosts xml xorg xsl xvid zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 9 Hans de Graaff gentoo-dev 2007-08-06 13:50:50 UTC
I have the feeling that this may be a hardened incompatibility issue. According to bug 75028 xemacs is not compatible with PIE at the moment. Could you try to compile again with -nopie in the CFLAGS and see if that fixes things?
Comment 10 anthony 2007-08-06 15:08:11 UTC
that did it! CFLAGS="-nopie" emerge xemacs.

Thanks!!!
Comment 11 Hans de Graaff gentoo-dev 2007-08-07 05:11:26 UTC
Re-opening so it can be marked as a duplicate.
Comment 12 Hans de Graaff gentoo-dev 2007-08-07 05:12:01 UTC

*** This bug has been marked as a duplicate of bug 75028 ***