Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 633530 - x11-base/xorg-server-1.19.4: Failed Patch: xorg-server-1.18-sysmacros.patch
Summary: x11-base/xorg-server-1.19.4: Failed Patch: xorg-server-1.18-sysmacros.patch
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL: https://patchwork.freedesktop.org/pat...
Whiteboard:
Keywords:
: 633536 633566 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-05 05:22 UTC by Perfect Gentleman
Modified: 2018-02-09 23:23 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
xorg-server-1.18-sysmacros.patch.out (file_633530.txt,5.01 KB, text/plain)
2017-10-05 06:28 UTC, Søren Dalby Larsen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Perfect Gentleman 2017-10-05 05:22:43 UTC
>>> Preparing source in /tmp/portage/x11-base/xorg-server-1.19.4/work/xorg-server-1.19.4 ...
 * Applying xorg-server-1.12-unloadsubmodule.patch ...                                                                                                [ ok ]
 * Applying xorg-server-1.18-support-multiple-Files-sections.patch ...                                                                                [ ok ]
 * Applying xorg-server-1.18-sysmacros.patch ...

 * Failed Patch: xorg-server-1.18-sysmacros.patch !
 *  ( /tmp/portage/x11-base/xorg-server-1.19.4/files/xorg-server-1.18-sysmacros.patch )
Comment 1 Søren Dalby Larsen 2017-10-05 06:28:40 UTC
Created attachment 497710 [details]
xorg-server-1.18-sysmacros.patch.out
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2017-10-05 06:37:43 UTC
commit 9418cfb38753d4b481136ca411b70b443e292253 (HEAD -> master, origin/master, origin/HEAD)
Author: Lars Wendler <polynomial-c@gentoo.org>
Date:   Thu Oct 5 08:37:16 2017

    x11-base/xorg-server: Removed sysmacros patch from 1.19.4 (bug #633530)
    
    Package-Manager: Portage-2.3.11, Repoman-2.3.3
Comment 3 Neil 2017-10-05 15:09:08 UTC
*** Bug 633536 has been marked as a duplicate of this bug. ***
Comment 4 Mart Raudsepp gentoo-dev 2017-10-10 21:29:17 UTC
*** Bug 633566 has been marked as a duplicate of this bug. ***
Comment 5 Mart Raudsepp gentoo-dev 2017-10-10 21:30:11 UTC
https://bugs.gentoo.org/633566#c8 suggests a sysmacros patch might still be needed, not just removing it. Reopening to investigate
Comment 6 wbrana 2017-10-10 21:43:10 UTC
still error without patch with hardened/linux/amd64/no-multilib, gcc-6.4.0, glibc-2.25-r7
Comment 7 Mart Raudsepp gentoo-dev 2017-10-10 23:35:27 UTC
The patch needs re-doing, not complete removal. Only hw/xfree86/common/xf86Xinput.c and hw/xfree86/os-support/linux/lnx_init.c chunks seem included upstream now, with
#ifdef HAVE_SYS_SYSMACROS_H
guards (and a configure.ac change to define it if sys/sysmacros.h is present)

The updated patch should also get these HAVE_SYS_SYSMACROS_H guards and be upstreamed properly. So at least config/udev.c patching. It's sleeptime for me, so maybe I can cook something up afterwards tomorrow evening. Help welcome (especialy upstreaming).
Comment 8 Larry the Git Cow gentoo-dev 2017-10-11 21:52:59 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6f03b7d078f9f8b855ec61c802e5b64edb11f599

commit 6f03b7d078f9f8b855ec61c802e5b64edb11f599
Author:     Mart Raudsepp <leio@gentoo.org>
AuthorDate: 2017-10-11 21:48:06 +0000
Commit:     Mart Raudsepp <leio@gentoo.org>
CommitDate: 2017-10-11 21:51:54 +0000

    x11-base/xorg-server: restore still necessary part of sysmacros patch for 1.19.4
    
    Closes: https://bugs.gentoo.org/633530
    Package-Manager: Portage-2.3.8, Repoman-2.3.2

 .../files/xorg-server-1.19.4-sysmacros.patch       | 36 ++++++++++++++++++++++
 x11-base/xorg-server/xorg-server-1.19.4.ebuild     |  1 +
 2 files changed, 37 insertions(+)
Comment 9 Mart Raudsepp gentoo-dev 2017-10-11 21:59:20 UTC
(In reply to wbrana from comment #6)
> still error without patch with hardened/linux/amd64/no-multilib, gcc-6.4.0,
> glibc-2.25-r7

I didn't even get a warning on non-hardened with gcc-6.4.0 and glibc-2.25-r7, but I think the patch should fix it now for 2.26+ and maybe that hardened then. Please feel free to re-test and report back for peace of mind once the update hits your sync :)
Comment 10 wbrana 2017-10-14 09:23:04 UTC
common/.libs/libcommon.a(udev.o): In function `device_removed':
udev.c:(.text+0x149): undefined reference to `minor'
udev.c:(.text+0x156): undefined reference to `major'
common/.libs/libcommon.a(udev.o): In function `device_added':
udev.c:(.text+0x3ba): undefined reference to `minor'
udev.c:(.text+0x3c6): undefined reference to `major'
udev.c:(.text+0x3fb): undefined reference to `minor'
udev.c:(.text+0x407): undefined reference to `major'
udev.c:(.text+0x5fc): undefined reference to `major'
udev.c:(.text+0x64a): undefined reference to `minor'
common/.libs/libcommon.a(udev.o): In function `config_udev_odev_probe':
udev.c:(.text+0x141f): undefined reference to `minor'
udev.c:(.text+0x142e): undefined reference to `major'
collect2: error: ld returned 1 exit status
make[4]: *** [Makefile:805: Xorg] Error 1
make[4]: Leaving directory '/tmp/portage/x11-base/xorg-server-1.19.5/work/xorg-server-1.19.5_build/hw/xfree86'
make[3]: *** [Makefile:854: all-recursive] Error 1
make[3]: Leaving directory '/tmp/portage/x11-base/xorg-server-1.19.5/work/xorg-server-1.19.5_build/hw/xfree86'
make[2]: *** [Makefile:669: all] Error 2
make[2]: Leaving directory '/tmp/portage/x11-base/xorg-server-1.19.5/work/xorg-server-1.19.5_build/hw/xfree86'
make[1]: *** [Makefile:611: all-recursive] Error 1
make[1]: Leaving directory '/tmp/portage/x11-base/xorg-server-1.19.5/work/xorg-server-1.19.5_build/hw'
make: *** [Makefile:778: all-recursive] Error 1
 * ERROR: x11-base/xorg-server-1.19.5::gentoo failed (compile phase):
 *   emake failed
Comment 11 Mart Raudsepp gentoo-dev 2017-10-16 13:21:39 UTC
I guess we should re-open or have an open bug about this still then... smells some bind-now thing instead then. So 1.19.3 worked and this must be something more changed upstream than the header includes from temporarily not fully applied patch?
Comment 12 wbrana 2017-10-18 08:50:05 UTC
It works after removing "sys-fs/eudev -~amd64" from package.accept_keywords
https://bugs.gentoo.org/634590
Comment 13 Mart Raudsepp gentoo-dev 2017-10-19 20:30:32 UTC
This seems to be a stable eudev with testing glibc mixup then, and probably actually a manifestation of bug 634062.
My only concern here is if my patch is something that we should keep and I should venture to poke upstream enough to get included. I think the header gets included indirectly, so it wasn't actually a problem - but as major/minor are used directly in this file, I think the include makes sense upstream-wise because of that at least (just not necessarily a build fix, just correctness).