Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 633346 - net-irc/irc-server-2.11.1_p1-r4 : installs into paths that should be created at runtime
Summary: net-irc/irc-server-2.11.1_p1-r4 : installs into paths that should be created ...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal QA (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: PMASKED
: 682070 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-10-03 08:00 UTC by Toralf Förster
Modified: 2020-09-30 15:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-10-03 08:00:41 UTC
QA: other
QA Notice: This ebuild installs into paths that should be created at runtime.
 To fix, simply do not install into these directories.  Instead, your package
 should create dirs on the fly at runtime as needed via init scripts/etc...

  var/run
  var/run/ircd
QA Notice: Package triggers severe warnings which indicate that it
           may exhibit random runtime failures.
../contrib/tkserv/tkserv.c:377:25: warning: implicit declaration of function ‘fnmatch’ [-Wimplicit-function-declaration]
Please do not file a Gentoo bug and instead report the above QA
issues directly to the upstream developers of this software.
Homepage: http://www.irc.org/

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-desktop_libressl_20170914-215948

  -------------------------------------------------------------------
Comment 1 Sam James archtester gentoo-dev Security 2020-05-14 06:15:55 UTC
*** Bug 682070 has been marked as a duplicate of this bug. ***
Comment 2 Larry the Git Cow gentoo-dev 2020-08-30 01:05:07 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=01100e28006a203f7c11a353eb66b59f08de80ff

commit 01100e28006a203f7c11a353eb66b59f08de80ff
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2020-08-30 01:04:13 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2020-08-30 01:05:00 +0000

    profiles/package.mask: last-rite net-irc/irc-server
    
    Bug: https://bugs.gentoo.org/633346
    Bug: https://bugs.gentoo.org/708408
    Bug: https://bugs.gentoo.org/716264
    Signed-off-by: Sam James <sam@gentoo.org>

 profiles/package.mask | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
Comment 3 Larry the Git Cow gentoo-dev 2020-09-30 15:17:43 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ca36de6c32adb446067d48d898a524dc03d905c2

commit ca36de6c32adb446067d48d898a524dc03d905c2
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2020-09-30 15:10:07 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2020-09-30 15:17:14 +0000

    net-irc/irc-server: remove last-rited package
    
    Bug: https://bugs.gentoo.org/633346
    Bug: https://bugs.gentoo.org/708408
    Bug: https://bugs.gentoo.org/716264
    Signed-off-by: Sam James <sam@gentoo.org>

 net-irc/irc-server/Manifest                       |   1 -
 net-irc/irc-server/files/2.10.3_p3-gentoo.patch   |  11 ---
 net-irc/irc-server/files/ircd.confd               |  10 --
 net-irc/irc-server/files/ircd.rc                  |  30 ------
 net-irc/irc-server/irc-server-2.11.1_p1-r4.ebuild | 110 ----------------------
 net-irc/irc-server/metadata.xml                   |   5 -
 profiles/package.mask                             |   1 -
 7 files changed, 168 deletions(-)