Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 632686 - =net-fs/samba-4.5.10-r1 fails to build with sys-libs/glibc-2.26-r1- /usr/include/rpcsvc/yp_prot.h:10:10: fatal error: rpc/rpc.h: No such file or directory
Summary: =net-fs/samba-4.5.10-r1 fails to build with sys-libs/glibc-2.26-r1- /usr/incl...
Status: RESOLVED DUPLICATE of bug 606542
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo's SAMBA Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-rpc
  Show dependency tree
 
Reported: 2017-10-02 11:13 UTC by xxoo
Modified: 2017-10-07 23:35 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
all info in it (all,447.83 KB, text/plain)
2017-10-02 11:13 UTC, xxoo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xxoo 2017-10-02 11:13:48 UTC
Created attachment 497402 [details]
all info in it

error happen:


In file included from ../source3/include/includes.h:113:0,
                 from default/source3/librpc/gen_ndr/ndr_open_files.c:3:
/usr/include/rpcsvc/yp_prot.h:10:10: fatal error: rpc/rpc.h: No such file or directory
 #include <rpc/rpc.h>
          ^~~~~~~~~~~
compilation terminated.
In file included from ../source3/include/includes.h:113:0,
                 from default/source3/librpc/gen_ndr/ndr_smbXsrv.c:3:
/usr/include/rpcsvc/yp_prot.h:10:10: fatal error: rpc/rpc.h: No such file or directory
 #include <rpc/rpc.h>
          ^~~~~~~~~~~
compilation terminated.
Waf: Leaving directory `/var/tmp/portage/net-fs/samba-4.5.10-r1/work/samba-4.5.10-abi_x86_64.amd64/bin'
Build failed:
Comment 1 Michal Jakubowski 2017-10-02 21:32:32 UTC
Confirm
Comment 2 Andreas K. Hüttel gentoo-dev 2017-10-07 23:35:57 UTC

*** This bug has been marked as a duplicate of bug 606542 ***