Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 632570 - net-dns/opendnssec-2.1.6 - version bump
Summary: net-dns/opendnssec-2.1.6 - version bump
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Marc Schiffbauer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-30 18:10 UTC by Dennis Schridde
Modified: 2020-06-22 11:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2017-09-30 18:10:14 UTC
Version 2.1.3 of OpenDNSSEC is available: https://www.opendnssec.org/2017/08/opendnssec-2-1-3/
Comment 1 Jonas Stein gentoo-dev 2017-10-01 19:18:33 UTC
Thank you for the bump request. 
You can help the maintainer with further information:
Does a simple bump [1] work on your system? 
Chances are high, because a first look on the bump revealed only small changes.

[1] https://wiki.gentoo.org/wiki/Custom_repository#Simple_version_bump_of_an_ebuild_in_the_local_overlay
Comment 2 Dennis Schridde 2017-10-01 20:59:53 UTC
Some changes were necessary: https://github.com/devurandom/gentoo-overlay/commit/62061b802fb3bc46581a072c0d8f343911ae6148

I also fixed WorkingDirectory in conf/conf.xml.in, which was already broken in 2.0.3, by changing OPENDNSSEC_LOCALSTATE_DIR in m4/opendnssec_common.m4.  Any idea why econf uses --localstatedir=/var/lib and then the ebuild overrides this with --localstatedir=/var, just to patch about every place where it is used to append "/lib"?

The source seems to be able to make use of dev-util/cunit and and sys-libs/libunwind (messages from configure), which neither me nor a previous ebuild author so far reflected in the ebuild.

There are QA issues, which I also did not yet take care of:
 * QA Notice: Package triggers severe warnings which indicate that it
 *            may exhibit random runtime failures.
 * scheduler/task.c:136:25: warning: implicit declaration of function ‘clamp’ [-Wimplicit-function-declaration]
 * daemon/time_leap_cmd.c:129:7: warning: implicit declaration of function ‘strptime’ [-Wimplicit-function-declaration]

 * Please do not file a Gentoo bug and instead report the above QA
 * issues directly to the upstream developers of this software.
 * Homepage: http://www.opendnssec.org/

The ebuild referenced above builds, but I was unable to test whether it works properly, since I was already unable to get 2.0.3 to work.  (The `ods-enforcer-db-setup` step from the tutorial complains about "Error: unable to connect to database!" and there is no debug or verbose mode that I could find, nor any explanation of this issue in the troubleshooting section.  I was hoping for 2.1.3 to magically resolve the issue, but it did not.)
Comment 3 Dennis Schridde 2020-06-21 10:55:29 UTC
The current LTS release branch 1.4 (of which we provide an older version 1.4.12 instead of the latest version 1.4.14, bug #728990) will go EOL in about 3 months: https://www.opendnssec.org/2019/10/opendnssec-1-4-end-of-life-upgrading-and-testing-versions/
Comment 4 Dennis Schridde 2020-06-21 11:02:17 UTC
With dev-db/mariadb-10.3 and 10.4 the build fails: 

db/db_backend_mysql.c:75:5: error: unknown type name 'my_bool'
   75 |     my_bool error;
      |     ^~~~~~~
db/db_backend_mysql.c: In function '__db_backend_mysql_prepare':
db/db_backend_mysql.c:273:36: error: 'my_bool' undeclared (first use in this function); did you mean 'bool'?
  273 |             mysql_bind->is_null = (my_bool*)0;
      |                                    ^~~~~~~
      |                                    bool

The issue has been reported upstream, but received no reaction so far: https://issues.opendnssec.org/browse/SUPPORT-254