Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 631416 - media-gfx/hugin-2017.0 builds no /usr/bin/hugin
Summary: media-gfx/hugin-2017.0 builds no /usr/bin/hugin
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-19 13:40 UTC by Wolfgang Riegler
Modified: 2017-11-03 17:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
logs (logs.zip,19.11 KB, application/zip)
2017-09-19 13:40 UTC, Wolfgang Riegler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Riegler 2017-09-19 13:40:58 UTC
Created attachment 495432 [details]
logs

If I emerge media-gfx/hugin with ~amd64 it builds and installs media-gfx/hugin-2017.0 without any errors. But after that it's missing /usr/bin/hugin.

Building media-gfx/hugin-2016.2.0 works.
Comment 1 Theo Baumgartner 2017-10-15 16:29:03 UTC
I can confirm this but also found at least in my case the culprit.

Comparing the sources of hugin-2016.2.0 and hugin-2017.0.0 with kdiff3 I found in CMakeLists.txt of hugin-2017 that it requires WxWidgets 3.0 or above while the previous one had a requirement of 2.8 or above.

So I changed with eselect the wxwidgets profile from "gtk2-unicode-release-2.8" to "gtk2-unicode-3.0", rebooted my machine (I forgot how to make the changes in the current session active), recompiled and after that hugin-2017 worked :-)
Comment 2 Wolfgang Riegler 2017-11-03 17:27:59 UTC
(In reply to Theo Baumgartner from comment #1)
> I can confirm this but also found at least in my case the culprit.
> 
> Comparing the sources of hugin-2016.2.0 and hugin-2017.0.0 with kdiff3 I
> found in CMakeLists.txt of hugin-2017 that it requires WxWidgets 3.0 or
> above while the previous one had a requirement of 2.8 or above.
> 
> So I changed with eselect the wxwidgets profile from
> "gtk2-unicode-release-2.8" to "gtk2-unicode-3.0", rebooted my machine (I
> forgot how to make the changes in the current session active), recompiled
> and after that hugin-2017 worked :-)

this works for me, too :-)
Thank you very much