Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 631332 - app-emulation/virtualbox-5.1.28: version bump
Summary: app-emulation/virtualbox-5.1.28: version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-18 14:07 UTC by Perfect Gentleman
Modified: 2017-10-02 09:09 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
vbox-kernel-module-src-5.1.28.tar.xz (without vboxpci) (vbox-kernel-module-src-5.1.28.tar.xz,596.06 KB, application/octet-stream)
2017-09-21 22:34 UTC, Mads
Details

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Mads 2017-09-21 22:34:01 UTC
Created attachment 495844 [details]
vbox-kernel-module-src-5.1.28.tar.xz (without vboxpci)

It seems like virtualbox 5.1.28 works without vboxpci as a module! At least on my computer... When I build virtualbox 5.1.28 manually here, it does not automatically generate and build vboxpci, but it builds vboxdrv, vboxnetadp and vboxnetflt. And still my old Windows VM boots, at least...

Attaching the kernel module sources that got generated when I built it on my machine as a vbox-kernel-module-src-5.1.28.tar.xz-file.

Maybe it's a special case with my computer, because it seems like arch lists "vboxpci.ko.gz" as a module in their virtualbox-host-modules 5.1.28 package...
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2017-10-02 09:09:20 UTC
commit 462fbeff85629420d28b62ef19f6179fd542db96
Author: Lars Wendler <polynomial-c@gentoo.org>
Date:   Mon Oct 2 10:47:00 2017

    virtualbox packages: Bump to version 5.1.28 (bug #631332).

    Package-Manager: Portage-2.3.10, Repoman-2.3.3