Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 630868 - sci-libs/hdf-4.2.13-r1 stabilization
Summary: sci-libs/hdf-4.2.13-r1 stabilization
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard: was: sci-libs/hdf-4.2.13 : configure:...
Keywords: STABLEREQ
: 650686 652826 (view as bug list)
Depends on:
Blocks: glibc-2.26-stable
  Show dependency tree
 
Reported: 2017-09-13 08:28 UTC by Toralf Förster
Modified: 2021-12-08 04:00 UTC (History)
1 user (show)

See Also:
Package list:
sci-libs/hdf-4.2.13-r1
Runtime testing required: ---
stable-bot: sanity-check+


Attachments
emerge-info.txt (emerge-info.txt,15.85 KB, text/plain)
2017-09-13 08:28 UTC, Toralf Förster
no flags Details
emerge-history.txt (emerge-history.txt,288.14 KB, text/plain)
2017-09-13 08:28 UTC, Toralf Förster
no flags Details
environment (environment,105.71 KB, text/plain)
2017-09-13 08:28 UTC, Toralf Förster
no flags Details
etc.portage.tbz2 (etc.portage.tbz2,12.56 KB, application/x-bzip)
2017-09-13 08:28 UTC, Toralf Förster
no flags Details
logs.tbz2 (logs.tbz2,19.75 KB, application/x-bzip)
2017-09-13 08:28 UTC, Toralf Förster
no flags Details
sci-libs:hdf-4.2.13:20170913-061600.log (sci-libs:hdf-4.2.13:20170913-061600.log,12.33 KB, text/plain)
2017-09-13 08:28 UTC, Toralf Förster
no flags Details
temp.tbz2 (temp.tbz2,30.67 KB, application/x-bzip)
2017-09-13 08:28 UTC, Toralf Förster
no flags Details
Patch to fix BUILD_XDR handling in configure.ac (hdf-4.2.13-fix-xdr-configure.patch,376 bytes, patch)
2018-01-22 14:53 UTC, Bernd Feige
no flags Details | Diff
Use tirpc in configure.ac for linux just as for cygwin (hdf-4.2.13-linux-tirpc.patch,972 bytes, patch)
2018-01-22 14:56 UTC, Bernd Feige
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-09-13 08:28:16 UTC
checking whether x86_64-pc-linux-gnu-gfortran understands -c and -o together... yes
checking size of int*... 8
configure: error: --enable-hdf4-xdr is not supported for 64 bit mode.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sci-libs/hdf-4.2.13/work/hdf-4.2.13/config.log

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 13.0-desktop_20170905-225247

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.4.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.6 (fallback)
  [3]   python2.7 (fallback)
  [4]   jython2.7 (fallback)
Available Ruby profiles:
  [1]   ruby22 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.5.1 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv sci-libs/hdf
[ebuild  N    ] sci-libs/hdf-4.2.13  USE="fortran -examples -static-libs -szip {-test}"
Comment 1 Toralf Förster gentoo-dev 2017-09-13 08:28:19 UTC
Created attachment 494326 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-09-13 08:28:23 UTC
Created attachment 494328 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2017-09-13 08:28:26 UTC
Created attachment 494330 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2017-09-13 08:28:29 UTC
Created attachment 494332 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2017-09-13 08:28:32 UTC
Created attachment 494334 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-09-13 08:28:35 UTC
Created attachment 494336 [details]
sci-libs:hdf-4.2.13:20170913-061600.log
Comment 7 Toralf Förster gentoo-dev 2017-09-13 08:28:38 UTC
Created attachment 494338 [details]
temp.tbz2
Comment 8 Bernd Feige 2018-01-22 14:53:26 UTC
Created attachment 515836 [details, diff]
Patch to fix BUILD_XDR handling in configure.ac

There seem to be two general problems, here the first one with patch:

- A comparison is != "Xyes" where it should be = "Xyes". This leads to the configuration default of "no" for --enable-hdf4-xdr leading to BUILD_XDR="no"
to be overridden with a AC_TRY_LINK test, leading to BUILD_XDR="yes" and configure throwing the error "--enable-hdf4-xdr is not supported for 64 bit mode."
It seems that only the opposite can be intended - --enable-hdf4-xdr was requested but the library not found should override BUILD_XDR to "no".
Comment 9 Bernd Feige 2018-01-22 14:56:46 UTC
Created attachment 515838 [details, diff]
Use tirpc in configure.ac for linux just as for cygwin

Second:
- rpc/xdr.h is no longer present in /usr/include but provided by different packages such as tirpc. Actually configure.ac already had a provision to use that for cygwin, so just use it for linux as well.
Comment 10 Benda Xu gentoo-dev 2018-01-23 10:33:19 UTC
Thanks for the patches, Bernd! 

Looks like they are both worth raising upstream. May I ask you to do us a favor to do that, please?

In addition, is RPC a indispensible features of hdf4?  If so, we should let the sci-libs/hdf ebuild depend on  net-libs/libtirpc.
Comment 11 Bernd Feige 2018-01-23 13:50:07 UTC
(In reply to Benda Xu from comment #10)
> Thanks for the patches, Bernd! 
> 
> Looks like they are both worth raising upstream. May I ask you to do us a
> favor to do that, please?

I found some old copies on github, but the hdfgroup web site only carries a link to the Forum, not to an official repository. Do you know of an official channel for bug reports other than the Forum?

> In addition, is RPC a indispensible features of hdf4?  If so, we should let
> the sci-libs/hdf ebuild depend on  net-libs/libtirpc.

Yes, rpc/xdr.h is unconditionally included in common include files in the hdf4 sources. It contains definitions for data serialization. It seems necessary to depend upon net-libs/libtirpc (both compile and runtime).
Comment 12 Benda Xu gentoo-dev 2018-01-27 01:38:30 UTC
(In reply to Bernd Feige from comment #11)
> (In reply to Benda Xu from comment #10)
> > Thanks for the patches, Bernd! 
> > 
> > Looks like they are both worth raising upstream. May I ask you to do us a
> > favor to do that, please?
> 
> I found some old copies on github, but the hdfgroup web site only carries a
> link to the Forum, not to an official repository. Do you know of an official
> channel for bug reports other than the Forum?
> 
> > In addition, is RPC a indispensible features of hdf4?  If so, we should let
> > the sci-libs/hdf ebuild depend on  net-libs/libtirpc.
> 
> Yes, rpc/xdr.h is unconditionally included in common include files in the
> hdf4 sources. It contains definitions for data serialization. It seems
> necessary to depend upon net-libs/libtirpc (both compile and runtime).

I see.  Thanks for the debug Bernd. Well done.  Could you please post your patch to the forum, so that we can put a link to your forum post in the patch file?  Then we will carry the patch in the Gentoo repo and people who come around can know where to go to follow the upstream treatments.
Comment 13 Bernd Feige 2018-02-12 15:31:37 UTC
I notified upstream through help@hdfgroup.org now, as outlined in the FAQ, and was assigned bug HDFFR-1567. The bug tracker does not yet have an address on public internet.
Comment 14 Andreas K. Hüttel archtester gentoo-dev 2018-03-03 22:39:06 UTC
Any news here?
Comment 15 Bernd Feige 2018-03-08 10:57:04 UTC
(In reply to Andreas K. Hüttel from comment #14)
> Any news here?

Nope. No further E-Mail and also the HDF4 git repo is silent:
https://bitbucket.hdfgroup.org/projects/HDFFR/repos/hdf4/commits
Comment 16 Andreas K. Hüttel archtester gentoo-dev 2018-03-30 18:04:24 UTC
(In reply to Bernd Feige from comment #15)
> (In reply to Andreas K. Hüttel from comment #14)
> > Any news here?
> 
> Nope. No further E-Mail and also the HDF4 git repo is silent:
> https://bitbucket.hdfgroup.org/projects/HDFFR/repos/hdf4/commits

So how about adding the patches locally in Gentoo?
Comment 17 Larry the Git Cow gentoo-dev 2018-04-22 14:28:43 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ddb167f03450fcc9869a3a230894a700a19812b1

commit ddb167f03450fcc9869a3a230894a700a19812b1
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2018-04-22 14:28:07 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2018-04-22 14:28:07 +0000

    sci-libs/hdf: Revbump that uses libtirpc, bug 630868
    
    Patches by Bernd Feige. This still needs to be stabilized.
    
    Bug: https://bugs.gentoo.org/630868
    Package-Manager: Portage-2.3.31, Repoman-2.3.9

 .../hdf/files/hdf-4.2.13-fix-xdr-configure.patch   | 13 ++++
 sci-libs/hdf/files/hdf-4.2.13-linux-tirpc.patch    | 29 +++++++++
 sci-libs/hdf/hdf-4.2.13-r1.ebuild                  | 72 ++++++++++++++++++++++
 3 files changed, 114 insertions(+)}
Comment 18 Andreas K. Hüttel archtester gentoo-dev 2018-05-05 14:31:39 UTC
Arches please do
Comment 19 Larry the Git Cow gentoo-dev 2018-05-05 17:50:50 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=fb77d8be1f457e09fdc842febb98addc53949ee0

commit fb77d8be1f457e09fdc842febb98addc53949ee0
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-05-05 17:50:34 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-05-05 17:50:42 +0000

    sci-libs/hdf: stable 4.2.13-r1 for ia64, bug #630868
    
    Bug: https://bugs.gentoo.org/630868
    Package-Manager: Portage-2.3.36, Repoman-2.3.9
    RepoMan-Options: --include-arches="ia64"

 sci-libs/hdf/hdf-4.2.13-r1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 20 Benda Xu gentoo-dev 2018-05-06 09:16:14 UTC
*** Bug 652826 has been marked as a duplicate of this bug. ***
Comment 21 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-05-06 21:47:53 UTC
amd64 stable
Comment 22 Thomas Deutschmann (RETIRED) gentoo-dev 2018-05-07 00:25:12 UTC
x86 stable
Comment 23 Andreas K. Hüttel archtester gentoo-dev 2018-05-11 19:16:23 UTC
@ppc: ping pretty please!!!
Comment 24 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-05-25 21:10:35 UTC
ppc stable
Comment 25 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-12-08 04:00:23 UTC
*** Bug 650686 has been marked as a duplicate of this bug. ***