Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 630486 - sys-fs/encfs-1.9.2: keyword and stabilization request
Summary: sys-fs/encfs-1.9.2: keyword and stabilization request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: 634160 kde-plasma-5.11.5-stable
  Show dependency tree
 
Reported: 2017-09-09 14:42 UTC by Felix Janda
Modified: 2019-06-12 09:53 UTC (History)
2 users (show)

See Also:
Package list:
sys-fs/encfs-1.9.2 dev-libs/tinyxml2-3.0.0
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Janda 2017-09-09 14:42:33 UTC
RepoMan scours the neighborhood...
  KEYWORDS.dropped              1
   sys-fs/encfs/encfs-1.9.2.ebuild: arm sparc x86


Adding arm and x86 keywords is no problem. sparc keyword would require
keywording dev-libs/tinyxml2.
Comment 1 Anthony Basile gentoo-dev 2017-10-28 14:04:04 UTC
This requires the stabilization of dev-libs/tinyxml2:0/3.  I'm adding the Media Video team because they're maintaining tinyxml2.
Comment 2 Stabilization helper bot gentoo-dev 2017-10-28 15:01:18 UTC
An automated check of this bug failed - the following atom is unknown:

dev-libs/tinyxml2:0/3

Please verify the atom list.
Comment 3 Thomas Deutschmann gentoo-dev Security 2017-10-29 21:58:33 UTC
Keywording/stabilization on x86 stopped due to bug 630090.
Comment 4 Stabilization helper bot gentoo-dev 2017-10-29 22:02:48 UTC
An automated check of this bug failed - the following atom is unknown:

dev-libs/tinyxml2:0/3

Please verify the atom list.
Comment 5 Andreas Sturmlechner gentoo-dev 2017-11-23 22:16:32 UTC
A test failure with an unstable perl version cannot block stabilisation here.
Comment 6 Anthony Basile gentoo-dev 2017-11-23 22:26:11 UTC
(In reply to Andreas Sturmlechner from comment #5)
> A test failure with an unstable perl version cannot block stabilisation here.

thanks, i'm tired of arguing about stabilization with test failures.  i really don't want to add RESTRICT="test" cheaply to a bunch of packages just to get them past stabilization.
Comment 7 Larry the Git Cow gentoo-dev 2017-11-29 18:26:56 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d925e7b50dc41bb2beeeefcf501a87fed32afe82

commit d925e7b50dc41bb2beeeefcf501a87fed32afe82
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2017-10-09 19:43:38 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2017-11-29 18:26:23 +0000

    profiles: arm: Mask kde-plasma/plasma-meta[crypt]
    
    Keywording is stalled and thus arm fails to meet minimum version.
    
    Bug: https://bugs.gentoo.org/630486
    Bug: https://bugs.gentoo.org/633882

 profiles/arch/arm/package.use.mask | 5 +++++
 1 file changed, 5 insertions(+)}
Comment 8 Andreas Sturmlechner gentoo-dev 2018-01-04 19:24:14 UTC
ping x86
Comment 9 Frank Krömmelbein 2018-01-04 20:24:51 UTC
Apparently it was forgotten to add amd64 to CC list.
Comment 10 Thomas Deutschmann gentoo-dev Security 2018-01-08 19:20:51 UTC
Still failing tests for x86:

> 2/2 Test #2: scriptedtests ....................***Failed    1.04 sec
> 
> 2/2 Testing: scriptedtests
> 2/2 Test: scriptedtests
> Command: "/usr/bin/perl" "-MTest::Harness" "-e" "$$Test::Harness::verbose=1; runtests @ARGV;" "/var/tmp/portage/sys-fs/encfs-1.9.2/work/encfs-1.9.2/tests/normal.t.pl" "/var/tmp/portage/sys-fs/encfs-1.9.2/work/encfs-1.9.2/tests/reverse.t.pl"
> Directory: /var/tmp/portage/sys-fs/encfs-1.9.2/work/encfs-1.9.2
> "scriptedtests" start time: Jan 08 20:10 CET
> Output:
> ----------------------------------------------------------
> 
> runTests: mode=standard
> Bailout called.  Further testing stopped:
> 
> #   Failed test 'encfs command returns 0'
> #   at /var/tmp/portage/sys-fs/encfs-1.9.2/work/encfs-1.9.2/tests/normal.t.pl line 312.
> FAILED--Further testing stopped.
> <end of output>
> Test time =   1.04 sec
Comment 11 Thomas Deutschmann gentoo-dev Security 2018-01-17 06:08:53 UTC
It is a problem with the test suite and our out of source build.

If I copy encfs*_build dir back to $S, i.e.


tests are passing:

> $ ./test.sh
> tests/normal.t.pl ...
> runTests: mode=standard
> tests/normal.t.pl ... 54/116
> runTests: mode=paranoia
> tests/normal.t.pl ... ok
> tests/reverse.t.pl .. ok
> All tests successful.
> Files=2, Tests=141, 27 wallclock secs ( 0.05 usr  0.01 sys + 19.87 cusr  2.10 csys = 22.03 CPU)
> Result: PASS
> portage@vm-gentoo-x86 ~/sys-fs/encfs-1.9.2/work/encfs-1.9.2 $ echo $?
> 0

The following change to the ebuild fixes the problem for:

--- a/sys-fs/encfs/encfs-1.9.2.ebuild
+++ b/sys-fs/encfs/encfs-1.9.2.ebuild
@@ -25,6 +25,9 @@ DEPEND="
        sys-devel/gettext
        virtual/pkgconfig"

+# Build dir is hardcoded in test suite
+BUILD_DIR="${S}/build"
+
 src_configure() {
        local mycmakeargs=(
                -DENABLE_NLS="$(usex nls)"


> >>> Source compiled.
> >>> Test phase: sys-fs/encfs-1.9.2
> >>> Working in BUILD_DIR: "/var/tmp/portage/sys-fs/encfs-1.9.2/work/encfs-1.9.2/build"
> ctest -j 5 --test-load 7.95
> Invalid value for 'Test Load' : 7.95
> Test project /var/tmp/portage/sys-fs/encfs-1.9.2/work/encfs-1.9.2/build
>     Start 1: checkops
>     Start 2: scriptedtests
> 1/2 Test #1: checkops .........................   Passed    0.13 sec
> 2/2 Test #2: scriptedtests ....................   Passed   27.88 sec
> 
> 100% tests passed, 0 tests failed out of 2
> 
> Total Test time (real) =  27.89 sec
>  * Tests succeeded.
> >>> Completed testing sys-fs/encfs-1.9.2
> 
> >>> Install encfs-1.9.2 into /var/tmp/portage/sys-fs/encfs-1.9.2/image/ category sys-fs
>
Comment 12 Anthony Basile gentoo-dev 2018-01-17 23:53:28 UTC
(In reply to Thomas Deutschmann from comment #11)

> 
> The following change to the ebuild fixes the problem for:
> 
> --- a/sys-fs/encfs/encfs-1.9.2.ebuild
> +++ b/sys-fs/encfs/encfs-1.9.2.ebuild
> @@ -25,6 +25,9 @@ DEPEND="
>         sys-devel/gettext
>         virtual/pkgconfig"
> 
> +# Build dir is hardcoded in test suite
> +BUILD_DIR="${S}/build"
> +
>  src_configure() {
>         local mycmakeargs=(
>                 -DENABLE_NLS="$(usex nls)"
> 
> 

This is a problem but its not the biggest problem with the tests.  The problem is with test 2 which tries to do an encfs mount (read the perl).  This can fail for spurious reasons:

1) On a hardened kernel this is forbiddent

2) On gentoo-sources you might not have FUSE_FS configured

3) While you could use linux-mod.eclass to check for FUSE_FS, the problem is people often switch kernels, so I'm not a fan of checking for kernel modules from an ebuild.

I'll add the above along with RESTRICT="test".  I wanted to avoid doing that because the tests do work under some circumstances.
Comment 13 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-01-18 15:56:55 UTC
amd64 stable
Comment 14 Thomas Deutschmann gentoo-dev Security 2018-01-21 20:32:13 UTC
x86 stable
Comment 15 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-04-28 07:27:55 UTC
~arm restored, maybe sparc team wants it too.
Comment 16 Anthony Basile gentoo-dev 2018-04-29 11:38:45 UTC
dropping ~sparc.
Comment 17 Larry the Git Cow gentoo-dev 2018-04-29 19:41:55 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5393cdf47136677cbf8455f937b992f2082dc55b

commit 5393cdf47136677cbf8455f937b992f2082dc55b
Author:     Rolf Eike Beer <eike@sf-mail.de>
AuthorDate: 2018-04-29 19:39:47 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-04-29 19:41:40 +0000

    sys-fs/encfs: keyworded 1.9.2 for sparc
    
    Bug: https://bugs.gentoo.org/630486
    Package-Manager: Portage-2.3.24, Repoman-2.3.6
    RepoMan-Options: --include-arches="sparc"

 sys-fs/encfs/encfs-1.9.2.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)}
Comment 18 Larry the Git Cow gentoo-dev 2018-04-29 20:25:35 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f825d22a2e3ccb85bc5a1fa0c8a06b2f8d1f0b61

commit f825d22a2e3ccb85bc5a1fa0c8a06b2f8d1f0b61
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-04-29 20:25:17 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-04-29 20:25:29 +0000

    sys-fs/encfs: keyworded newer versions for sparc
    
    Reported-by: [Arfrever]
    Bug: https://bugs.gentoo.org/630486
    Package-Manager: Portage-2.3.31, Repoman-2.3.9

 sys-fs/encfs/encfs-1.9.4.ebuild | 2 +-
 sys-fs/encfs/encfs-1.9.5.ebuild | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)}
Comment 19 Rolf Eike Beer archtester 2018-09-04 19:26:11 UTC
sparc stable.
Comment 20 Andreas Sturmlechner gentoo-dev 2019-06-12 09:53:59 UTC
(In reply to Rolf Eike Beer from comment #19)
> sparc stable.

meh. at that time, we already had 1.9.4 stable, but now sparc is blocking 1.9.2 cleanup.