Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 62934 - mjpegtools-1.6.2-r{1,3}: mplex still ignores '-S 0' despite being fixed in 1.6.1.90
Summary: mjpegtools-1.6.2-r{1,3}: mplex still ignores '-S 0' despite being fixed in 1....
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 62936 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-09-05 10:19 UTC by Jason Cooper
Modified: 2004-09-25 07:38 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Cooper 2004-09-05 10:19:45 UTC
When passing '-S 0' or '-S 8192' to mplex, as of 1.6.1.90 of mjpegtools, it should not attempt to split the output at 2000 MB.  However, with media-video/mjpegtools-1.6.2-r{1,3} mplex still fails with:

**ERROR: [mplex] Need to split output but there appears to be no %d in the filename pattern movie.mpeg

The actual command used was:

mplex -f 8 -S 0 -o movie.mpeg movie.m2v ofile0.ac3


Reproducible: Always
Steps to Reproduce:
1.Make sure movie.mpeg is >2000MB
2.mplex -f 8 -S 0 -o movie.mpeg movie.m2v ofile0.ac3
3.fails.

Actual Results:  
**ERROR: [mplex] Need to split output but there appears to be no %d in the
filename pattern movie.mpeg

Expected Results:  
mplexed the files successfully.

Portage 2.0.50-r10 (default-x86-1.4, gcc-3.3.4, glibc-2.3.4.20040808-r0, 2.6.7)
=================================================================
System uname: 2.6.7 i686 AMD Athlon(tm) XP 2200+
Gentoo Base System version 1.5.3
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="http://gentoo.osuosl.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X alsa apm avi berkdb bonobo cdr crypt cups dga dvd encode esd foomaticdb
gdbm gif gpm gtk gtk2 gtkhtml guile imlib ipv6 java jpeg kde libg++ libwww mad
maildir mikmod mmx motif mozilla mpeg mysql ncurses nls nptl oggvorbis opengl
oss pam pda pdflib perl png python qt quicktime readline scanner sdl slang spell
sse ssl tcpd tiff truetype usb v4l x x86 xml2 xmms xv zlib"
Comment 1 Seemant Kulleen (RETIRED) gentoo-dev 2004-09-05 10:30:25 UTC
*** Bug 62936 has been marked as a duplicate of this bug. ***
Comment 2 Jason Cooper 2004-09-05 10:33:31 UTC
Did I hit something wrong?  I don't know where Bug 62936 came from.  I don't think I submitted twice...  Sure looks like it though :-(
Comment 3 Heinrich Wendel (RETIRED) gentoo-dev 2004-09-25 07:38:34 UTC
this is a upstream bug, see:

http://sourceforge.net/tracker/index.php?func=detail&aid=823273&group_id=5776&atid=105776