Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 628838 - app-text/ronn-0.7.3-r3 : /.../rbconfig.rb:7:in <module:RbConfig> : ruby lib version (2.2.7) doesn t match executable version (2.1.10) (RuntimeError)
Summary: app-text/ronn-0.7.3-r3 : /.../rbconfig.rb:7:in <module:RbConfig> : ruby lib ...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
: 729388 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-08-24 15:44 UTC by Toralf Förster
Modified: 2020-07-06 19:17 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.60 KB, text/plain)
2017-08-24 15:44 UTC, Toralf Förster
Details
app-text:ronn-0.7.3-r3:20170824-134016.log (app-text:ronn-0.7.3-r3:20170824-134016.log,2.95 KB, text/plain)
2017-08-24 15:44 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,356.58 KB, text/plain)
2017-08-24 15:44 UTC, Toralf Förster
Details
environment (environment,162.84 KB, text/plain)
2017-08-24 15:44 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,19.99 KB, application/x-bzip)
2017-08-24 15:44 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-08-24 15:44:15 UTC
 * Running compile phase for all ...
ronn -w -s toc -r5 --markdown man/*.ronn
/usr/lib64/ruby/2.2.0/x86_64-linux/rbconfig.rb:7:in `<module:RbConfig>': ruby lib version (2.2.7) doesn't match executable version (2.1.10) (RuntimeError)
	from /usr/lib64/ruby/2.2.0/x86_64-linux/rbconfig.rb:5:in `<top (required)>'
	from /usr/lib64/ruby/site_ruby/2.2.0/rubygems.rb:9:in `require'
	from /usr/lib64/ruby/site_ruby/2.2.0/rubygems.rb:9:in `<top (required)>'

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-desktop-gnome-systemd_20170815-183537

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.4.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.6 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems) *
  [2]   ruby22 (with Rubygems)
java-config:
The following VMs are available for generation-2:


emerge -qpv app-text/ronn
[ebuild  N    ] app-text/ronn-0.7.3-r3  USE="{-test}" RUBY_TARGETS="ruby22 -ruby23 -ruby24"
Comment 1 Toralf Förster gentoo-dev 2017-08-24 15:44:18 UTC
Created attachment 490476 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-08-24 15:44:21 UTC
Created attachment 490478 [details]
app-text:ronn-0.7.3-r3:20170824-134016.log
Comment 3 Toralf Förster gentoo-dev 2017-08-24 15:44:25 UTC
Created attachment 490480 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2017-08-24 15:44:28 UTC
Created attachment 490482 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2017-08-24 15:44:31 UTC
Created attachment 490484 [details]
etc.portage.tbz2
Comment 6 dx94.manage 2017-08-26 02:20:02 UTC
The problem comes from the eselect configuration to actually point to ruby 2.1 instead of 2.2, the error itself states that.

Had the same problem, I solved it by configuring eselect to point to ruby22 instead of 21

in your case would be:

eselect ruby set 2
Comment 7 Toralf Förster gentoo-dev 2017-08-26 07:24:59 UTC
So is this a bug or PEBKAC ?
In the later case I do wonder if an ewarn would makes sense ?
Comment 8 Alarig Le Lay 2020-06-15 13:40:21 UTC
I just lunched a world update and I have the same error (with 2.5.8 and 2.4.10 because time has passed).
So I think that the ebuild should force the ruby version base on the RUBY_TARGETS variable or something like that.
Comment 9 Alarig Le Lay 2020-06-15 13:43:31 UTC
Also please note that this puts the system in a state where “classical” emerge commands are failing:

alarig ~ # emerge --ask --depclean 

 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 * 
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence of this, it often becomes necessary to run 
 * `emerge --update --newuse --deep @world` prior to depclean.

Calculating dependencies... done!
 * Dependencies could not be completely resolved due to
 * the following required packages not being installed:
 * 
 *   >=dev-ruby/hpricot-0.8.2[ruby_targets_ruby24(-)] pulled in by:
 *     app-text/ronn-0.7.3-r3
 * 
 *   >=dev-ruby/rdoc-5.1.0-r1[ruby_targets_ruby24] pulled in by:
 *     dev-lang/ruby-2.4.10
 * 
 *   >=dev-ruby/json-2.0.2[ruby_targets_ruby24] pulled in by:
 *     dev-lang/ruby-2.4.10
 * 
 *   >=dev-ruby/test-unit-3.2.3[ruby_targets_ruby24] pulled in by:
 *     dev-lang/ruby-2.4.10
 * 
 *   >=dev-ruby/rdiscount-1.5.8[ruby_targets_ruby24(-)] pulled in by:
 *     app-text/ronn-0.7.3-r3
 * 
 *   >=dev-ruby/net-telnet-0.1.1[ruby_targets_ruby24] pulled in by:
 *     dev-lang/ruby-2.4.10
 * 
 *   >=dev-ruby/rake-12.0.0[ruby_targets_ruby24] pulled in by:
 *     dev-lang/ruby-2.4.10
 * 
 *   virtual/rubygems[ruby_targets_ruby24(-)] pulled in by:
 *     app-text/ronn-0.7.3-r3
 * 
 *   >=dev-ruby/mustache-0.7.0[ruby_targets_ruby24(-)] pulled in by:
 *     app-text/ronn-0.7.3-r3
 * 
 *   >=dev-ruby/power_assert-0.4.1[ruby_targets_ruby24] pulled in by:
 *     dev-lang/ruby-2.4.10
 * 
 *   >=dev-ruby/xmlrpc-0.2.1[ruby_targets_ruby24] pulled in by:
 *     dev-lang/ruby-2.4.10
 * 
 *   virtual/rubygems[ruby_targets_ruby24(-)] pulled in by:
 *     dev-ruby/did_you_mean-1.1.2
 * 
 *   virtual/rubygems[ruby_targets_ruby24] pulled in by:
 *     dev-lang/ruby-2.4.10
 * 
 *   >=dev-ruby/minitest-5.10.1[ruby_targets_ruby24] pulled in by:
 *     dev-lang/ruby-2.4.10
 * 
 * Have you forgotten to do a complete update prior to depclean? The
 * most comprehensive command for this purpose is as follows:
 * 
 *   emerge --update --newuse --deep --with-bdeps=y @world
 * 
 * Note that the --with-bdeps=y option is not required in many
 * situations. Refer to the emerge manual page (run `man emerge`)
 * for more information about --with-bdeps.
 * 
 * Also, note that it may be necessary to manually uninstall
 * packages that no longer exist in the repository, since it may not
 * be possible to satisfy their dependencies.
alarig ~ # emerge -vac =dev-lang/ruby-2.4.10

Calculating dependencies... done!
  dev-lang/ruby-2.4.10 pulled in by:
    app-text/ronn-0.7.3-r3 requires dev-lang/ruby:2.4
    dev-ruby/did_you_mean-1.1.2 requires dev-lang/ruby:2.4

>>> No packages selected for removal by depclean
Packages installed:   1398
Packages in world:    203
Packages in system:   43
Required packages:    1398
Number removed:       0
Comment 10 Jeroen Roovers gentoo-dev 2020-06-26 08:43:28 UTC
*** Bug 729388 has been marked as a duplicate of this bug. ***