Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 628212 - sys-libs/binutils-libs-2.28.1: stable request for stable crossdev toolchain
Summary: sys-libs/binutils-libs-2.28.1: stable request for stable crossdev toolchain
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Toolchain Maintainers
Depends on:
Reported: 2017-08-18 18:48 UTC by Gleb
Modified: 2017-09-15 20:45 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Gleb 2017-08-18 18:48:15 UTC
Similar to this:

When trying to build stable cross-toolchain, I get warning that it can't be build and binutils-libs-2.28.1 is required for cross-armv7a-hardfloat-linux-gnueabi/binutils. I can unmask or mask packages, but it's better to avoid it at all.
Comment 1 jorgicio 2017-08-25 23:01:38 UTC
This issue happens to me, so it needs to be stable to keep working with toolchain.

hackenherr:~# cat /var/log/portage/cross-avr-binutils.log                                                                                                      [20:00:00]
Calculating dependencies  ....... done!
[ebuild     U  ] sys-libs/binutils-libs-2.28.1 [2.28-r1]
[ebuild  NS    ] cross-avr/binutils-2.28.1 [2.28-r2] USE="cxx nls -multitarget -static-libs {-test} -vanilla" 

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:


  (sys-libs/binutils-libs-2.28.1:0/2.28.1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/binutils-libs-2.28.1 required by (cross-avr/binutils-2.28.1:2.28.1/2.28.1::crossdev, ebuild scheduled for merge)
    ^^                       ^^^^^^                                                                                             

  (sys-libs/binutils-libs-2.28-r1:0/2.28::gentoo, installed) pulled in by
    sys-libs/binutils-libs:0/2.28= required by (dev-db/mariadb-10.1.26:0/18::gentoo, installed)
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-db/mariadb-10.1.26::gentoo[-bindist]
# required by virtual/mysql-5.6-r9::gentoo
# required by dev-python/mysqlclient-1.3.10::gentoo
# required by @selected
# required by @world (argument)
=sys-libs/binutils-libs-2.28.1 ~amd64

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.
Comment 2 Sergei Trofimovich (RETIRED) gentoo-dev 2017-09-15 20:45:09 UTC
Sorry about that. It should be stabled in sync with sys-devel/binutils.

Fixed as: