Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 627746 - app-admin/sysstat-? - /etc/init.d/sysstat: line 11: /usr/lib/sa/sa1: No such file or directory
Summary: app-admin/sysstat-? - /etc/init.d/sysstat: line 11: /usr/lib/sa/sa1: No such ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jeroen Roovers (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: no-symlink-lib
  Show dependency tree
 
Reported: 2017-08-13 03:02 UTC by Georgy Yakovlev
Modified: 2019-06-03 14:55 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge.info,5.08 KB, text/plain)
2017-08-13 03:02 UTC, Georgy Yakovlev
Details
sysstat-11.4.0-r1.build.log (sysstat-11.4.0-r1.build.log,44.75 KB, text/plain)
2018-04-07 21:32 UTC, Georgy Yakovlev
Details
sysstat-11.6.1-r1.build.log (sysstat-11.6.1-r1.build.log,49.04 KB, text/plain)
2018-04-07 21:32 UTC, Georgy Yakovlev
Details
sysstat-11.6.2-r1.build.log (sysstat-11.6.2-r1.build.log,49.04 KB, text/plain)
2018-04-07 21:33 UTC, Georgy Yakovlev
Details
sysstat-11.7.1-r1.build.log (sysstat-11.7.1-r1.build.log,57.64 KB, text/plain)
2018-04-07 21:33 UTC, Georgy Yakovlev
Details
sysstat-11.7.2-r1.build.log (sysstat-11.7.2-r1.build.log,58.19 KB, text/x-log)
2018-04-07 21:34 UTC, Georgy Yakovlev
Details
0001-app-admin-sysstat-install-sa-files-to-usr-lib.patch (0001-app-admin-sysstat-install-sa-files-to-usr-lib.patch,2.65 KB, patch)
2018-11-17 05:41 UTC, Georgy Yakovlev
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Georgy Yakovlev gentoo-dev 2017-08-13 03:02:39 UTC
Created attachment 488732 [details]
emerge --info

I have a testing system with 
SYMLINK_LIB=no
LIBDIR_x86=lib


cleanly installed from fresh snapshot and migrated as discussed here:
https://archives.gentoo.org/gentoo-dev/message/b4a3e2ea1a6dec32b550812c9a25b1dc

the initscript fails to inject a boot record on startup.

817:/etc/init.d/sysstat: line 11: /usr/lib/sa/sa1: No such file or directory
819: * ERROR: sysstat failed to start



with above lib settings the file location is 
file /usr/lib64/sa/sa1
/usr/lib64/sa/sa1: POSIX shell script, ASCII text executable
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2018-04-07 11:30:36 UTC
Please attach the entire build log to this bug report.
Comment 2 Georgy Yakovlev gentoo-dev 2018-04-07 21:32:29 UTC
Created attachment 526826 [details]
sysstat-11.4.0-r1.build.log
Comment 3 Georgy Yakovlev gentoo-dev 2018-04-07 21:32:50 UTC
Created attachment 526828 [details]
sysstat-11.6.1-r1.build.log
Comment 4 Georgy Yakovlev gentoo-dev 2018-04-07 21:33:19 UTC
Created attachment 526830 [details]
sysstat-11.6.2-r1.build.log
Comment 5 Georgy Yakovlev gentoo-dev 2018-04-07 21:33:41 UTC
Created attachment 526832 [details]
sysstat-11.7.1-r1.build.log
Comment 6 Georgy Yakovlev gentoo-dev 2018-04-07 21:34:03 UTC
Created attachment 526834 [details]
sysstat-11.7.2-r1.build.log
Comment 7 Georgy Yakovlev gentoo-dev 2018-04-12 01:52:35 UTC
I see you've added a new version without fixing this bug or merging the pull request.

Can I get any input on this?
Is pull request needed, will you take a look at it?
Is anything else needed for this bug to get fixed?

I've uploaded all build logs for modified ebuilds in the pull request.

The issue itself it not related to build process, it's just the init.d file does not account for possible different libdir values.


Pull request is here, I have not updated it yet with the latest changes.
Before I update or delete it I'd like to get your point of view.
Thanks.
Comment 8 Georgy Yakovlev gentoo-dev 2018-04-12 01:54:29 UTC
forgot to link the pull request
https://github.com/gentoo/gentoo/pull/7850
it got removed from the "See Also" field for some reason.
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2018-06-16 20:05:42 UTC
(also CC-ing comrel@ as this is yet another example of jer's hostile behavior towards contributors and lack of willingness to communicate clearly)
Comment 10 Kristian Fiskerstrand gentoo-dev Security 2018-06-16 21:24:06 UTC
(In reply to Georgy Yakovlev from comment #8)
> forgot to link the pull request
> https://github.com/gentoo/gentoo/pull/7850
> it got removed from the "See Also" field for some reason.

As GitHub is not official Gentoo workflow I would recommend providing a git format-patch with a proper commit description for any change.
Comment 11 Georgy Yakovlev gentoo-dev 2018-06-16 21:51:25 UTC
(In reply to Kristian Fiskerstrand from comment #10)
> (In reply to Georgy Yakovlev from comment #8)
> > forgot to link the pull request
> > https://github.com/gentoo/gentoo/pull/7850
> > it got removed from the "See Also" field for some reason.
> 
> As GitHub is not official Gentoo workflow I would recommend providing a git
> format-patch with a proper commit description for any change.

I'll do that, thanks for suggestion.
Comment 12 email200202 2018-11-17 04:28:00 UTC
The bug was not fixed in app-admin/sysstat-12.1.1 and it is still marked as still "unconfirmed".
Comment 13 Georgy Yakovlev gentoo-dev 2018-11-17 05:41:16 UTC
Created attachment 555394 [details, diff]
0001-app-admin-sysstat-install-sa-files-to-usr-lib.patch

completely forgot about this one (I'm the reporter, not maintainer) 
it's not completely clear where should those files really go to

file /usr/lib64/sa/*
/usr/lib64/sa/sa1:  POSIX shell script, ASCII text executable
/usr/lib64/sa/sa2:  POSIX shell script, ASCII text executable
/usr/lib64/sa/sadc: ELF 64-bit LSB shared object ...


both sa1 and sa2 are scripts, so /usr/lib (new libexec variant) or /usr/libexec is a proper place for those files.

since this bug is about new profiles, all those files (including sadc) should go to /lib regardless of arch.

this should not break user's systems and require no intervention.

files/sysstat.init.d already does not account for different libdirs 

simple patch attached.

same result can be achieved with this lame sed line =)
sed -i 's#sa_lib_dir=/usr/$(get_libdir)/sa#sa_lib_dir=/usr/lib/sa#' *.ebuild
Comment 14 email200202 2018-11-18 08:15:31 UTC
Hi Georgy

While we have your attention in app-admin/sysstat, can you look at https://bugs.gentoo.org/531032. It is a four year bug to remove "root" from /etc/cron.d/sysstat if dcron is the selected cron.

Thanks
Comment 15 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-01-07 17:28:52 UTC
Remove ComRel, this is unclear what we expected to do here.
Comment 16 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-05-05 06:36:30 UTC
Revdeps:

x11-misc/i3blocks
x11-wm/lumina

I guess it's time to treeclean them all.
Comment 17 Larry the Git Cow gentoo-dev 2019-05-31 08:30:57 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=dbb8a1553777a1440b9041c9178c41cd9e1e716e

commit dbb8a1553777a1440b9041c9178c41cd9e1e716e
Author:     Jeroen Roovers <jer@gentoo.org>
AuthorDate: 2019-05-31 08:30:13 +0000
Commit:     Jeroen Roovers <jer@gentoo.org>
CommitDate: 2019-05-31 08:30:53 +0000

    app-admin/sysstat: Fix sa_lib_dir, drop rcdir variable hack
    
    Fixes: https://bugs.gentoo.org/627746
    Package-Manager: Portage-2.3.67, Repoman-2.3.13
    Signed-off-by: Jeroen Roovers <jer@gentoo.org>

 app-admin/sysstat/sysstat-12.0.5.ebuild | 10 +++-------
 app-admin/sysstat/sysstat-12.1.5.ebuild | 10 +++-------
 2 files changed, 6 insertions(+), 14 deletions(-)